Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000377KdenliveUser Interfacepublic2008-11-20 18:522008-12-29 16:27
Reporterrudlavibizon 
Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000377: Crash when adjusting transition
DescriptionNot quite sure when exactly it happens but it seems like it's when grabbing and moving a transition.
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Filesgz file icon kdenlive-crash.tar.gz [^] (3,289 bytes) 2008-11-20 18:52

- Relationships

-  Notes
(0001304)
madsdyd (administrator)
2008-11-20 21:18

Can we please get some more information about the version of ffmpeg, mlt, and mlt++ you have used?

How did you compile this?

It is possibly for you to run it in gdb, then use
bt
thread apply all bt
where full

when you get a crash?

Does it *only* crash when grabbing and moving a transition? It is otherwise stable?
(0001352)
rudlavibizon (reporter)
2008-11-22 19:12

Hello sorry for the delay in replying, day job etc...

I can't manage to crash it again, transitions work just fine now. I'll run it in gdb from now on and see if I can find more bugs for you to crush. By the way what is the equivalent of --enable-debug in cmake? Here is some info on my system:

Ubuntu 8.10 (Gnome)

ffpmeg --version:
FFmpeg version r11872+debian_3:0.svn20080206-12ubuntu3, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler --enable-x11grab --prefix=/usr --enable-libgsm --enable-libtheora --enable-libvorbis --enable-pthreads --disable-strip --enable-libfaad --enable-libfaadbin --enable-liba52 --enable-liba52bin --enable-libdc1394 --enable-shared --disable-static
  libavutil version: 49.6.0
  libavcodec version: 51.50.0
  libavformat version: 52.7.0
  libavdevice version: 52.0.0
  built on Oct 3 2008 22:41:23, gcc: 4.3.2

kdenlive,mlt,mlt++: svn versions

PS. I like how kdenlive is progressing right now, please continue :)

Bane
(0001353)
madsdyd (administrator)
2008-11-22 20:59

I am no expert on cmake, but I *think* this is it:

-DCMAKE_BUILD_TYPE=debugfull

At least that is what the wizard uses :-)

- Issue History
Date Modified Username Field Change
2008-11-20 18:52 rudlavibizon New Issue
2008-11-20 18:52 rudlavibizon File Added: kdenlive-crash.tar.gz
2008-11-20 21:18 madsdyd Note Added: 0001304
2008-11-20 21:18 madsdyd Status new => feedback
2008-11-22 19:12 rudlavibizon Note Added: 0001352
2008-11-22 20:59 madsdyd Note Added: 0001353
2008-11-22 21:00 madsdyd Build/Install Method => Other Method?
2008-11-22 21:00 madsdyd Status feedback => resolved
2008-11-22 21:00 madsdyd Resolution open => unable to reproduce
2008-12-29 16:27 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker