Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000379KdenliveBuild Systempublic2008-11-20 21:022008-12-29 16:27
Reporternadavkav 
Assigned To 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version0.7.0 
Target VersionFixed in Version 
Summary0000379: make error: "libkdecore.so', needed by `src/cmake_bindir/kdenlive'. Stop"
Descriptionat some point, along the make process i get:
[ 48%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/keyframehelper.o
[ 49%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/editclipcommand.o
make[2]: *** No rule to make target `/build/buildd/kde4libs-4.1.2/obj-i486-linux-gnu/lib/libkdecore.so', needed by `src/cmake_bindir/kdenlive'. Stop.
make[1]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/all] Error 2
make: *** [all] Error 2
Additional Informationi use ubuntu 8.10 (updated)

my default DE is gnome

BUT ! i have installed all the components
necessary to run KDE 4.1.2 desktop (from kubuntu repos)
TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0001303)
madsdyd (administrator)
2008-11-20 21:13

Hi nadavkav

Just to make sure: You ar not using the Wizard to build this, are you?

In any case: please check this thread:

http://www.kdenlive.org/bbforum/viewtopic.php?f=8&t=659 [^]

Basically, the only solution we have found for ubuntu is to enable backports
in the package manager (adept), then

sudo apt-get update ; sudo apt-get upgrade

Please check the forum thread for more info. Feel free to mail again if you
have trouble following these instructions.

Let me know how it goes.
(0001315)
cinephiliac (updater)
2008-11-20 22:21

It may also be valuable for us to know which packages it says will be upgraded after you do the apt-get upgrade, when it asks "Do you want to continue? (y/n)".

If you could copy and paste the list here, that would be great.
(0001317)
nadavkav (reporter)
2008-11-20 22:59

i guess i should have looked in the forums first !

i turned on the backports in "Software Sources"
updated apt package list.
and got ALL my kde 4.1.2 packages suggested to be upgraded to 4.1.3
that's a long list. and i guess you do not need it here.
well...
i was "brave" and did the upgrade.
.
.
issue solved :-)
(0001321)
madsdyd (administrator)
2008-11-21 08:32

I would still very much like to know if you are building manually, or using the wizard...

So far we have only had this for wizard users, but if you have the same issue when building manually, it would be very handy to know.
(0001324)
nadavkav (reporter)
2008-11-21 10:56

i started with the wizard, but only to download the sources.
then i compiled it manually according to the instructions:
http://kdenlive.org/compile [^]

later, when everything compiled and installed successfully (with your help!)

because you asked...
i started the wizard again and used it to compile it again
successfully (excluding the freiOr mlt plugin)

everything works great !!!
(0001325)
madsdyd (administrator)
2008-11-21 12:02

OK, thanks! I conclude that this issue is a build issue that happens also outside the wizard.

Resolving to no-change.

- Issue History
Date Modified Username Field Change
2008-11-20 21:02 nadavkav New Issue
2008-11-20 21:13 madsdyd Note Added: 0001303
2008-11-20 21:13 madsdyd Status new => feedback
2008-11-20 22:21 cinephiliac Note Added: 0001315
2008-11-20 22:59 nadavkav Note Added: 0001317
2008-11-21 06:32 cinephiliac Status feedback => resolved
2008-11-21 06:32 cinephiliac Resolution open => fixed
2008-11-21 08:32 madsdyd Note Added: 0001321
2008-11-21 08:32 madsdyd Status resolved => feedback
2008-11-21 08:32 madsdyd Resolution fixed => reopened
2008-11-21 10:56 nadavkav Note Added: 0001324
2008-11-21 12:02 madsdyd Note Added: 0001325
2008-11-21 12:02 madsdyd Status feedback => resolved
2008-11-21 12:02 madsdyd Resolution reopened => no change required
2008-12-29 16:27 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker