Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000406KdenliveFile Loadingpublic2008-11-24 17:082008-12-29 16:27
Reportercorax 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version0.7.0 
Target VersionFixed in Version 
Summary0000406: Highspeedsound/crushed PCM sound in AVI files
DescriptionHi,

on the forums Mads told me to post my problem here:

i got here some avi files taken with a Canon Ixus60.
In Kdenlive the sound on these files are played with highspeed an is crushed. Video is ok.

On Mplayer, VLC or Avidemux these files are played fine.

Mplayer consoleoutput:

[code]
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 11024 Hz, 1 ch, u8, 88.2 kbit/100.00% (ratio: 11024->11024)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
[/code]

I attached a sample file.

Best regards
corax
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files? file icon sample.avi [^] (4,283,750 bytes) 2008-11-24 17:08
txt file icon squashed_sound.backtrace.cinephiliac.txt [^] (19,840 bytes) 2008-11-24 19:02 [Show Content]

- Relationships
duplicate of 0000297closedddennedy MOV / AVI files crashing Kdenlive and showing up with incorrect sound previews 

-  Notes
(0001384)
cinephiliac (updater)
2008-11-24 19:02
edited on: 2008-11-24 19:07

ACKNOWLEDGED ON:
Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 15925 Last Changed Date: 2008-11-24 07:39:02 -0500 (Mon, 24 Nov 2008)
mlt: Revision: 1240 Last Changed Date: 2008-11-17 00:57:32 -0500 (Mon, 17 Nov 2008)
mlt++: Revision: 1240 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2728 Last Changed Date: 2008-11-24 06:15:54 -0500 (Mon, 24 Nov 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7


STEPS TO REPRODUCE:
1. Download sample.avi from this bug report.
2. Open into the project tree
3. Drag to timeline
4. Scroll current time marker through area where clip is.
5. Kdenlive crashes, usually on step 3, otherwise on step 4.


I think this is a duplicate of issue 0000297. The sample.avi uploaded by corax looks exactly the same in the audio thumbnail and crashes Kdenlive the same way.

If someone who can read backtraces could take a look at the one on this bug and 0000297 and confirm, I'll mark this as a dupe.

Can anyone tell if this has 8bit sound? That seemed to be the problem in 0000297...

(0001387)
madsdyd (administrator)
2008-11-24 20:35

I don't think the backtraces look particularly the same, but I could easily be wrong.

This definitely looks like 8 bit audio (in mono):

AUDIO: 11024 Hz, 1 ch, u8, 88.2 kbit/100.00% (ratio: 11024->11024)
 Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
(0001388)
madsdyd (administrator)
2008-11-24 20:49

OK, this plays back fine in ffplay, but audio is totally borken in inigo. This needs to be fixed in mlt, I think.
(0001389)
madsdyd (administrator)
2008-11-24 20:59

This *is* a duplicate of 0000297, so closing.

(Cute baby btw :-)

Hopefully Dan will be able to work on 297 in the near future.
(0001404)
ddennedy (developer)
2008-11-25 04:35

fixed in MLT SVN r1242

- Issue History
Date Modified Username Field Change
2008-11-24 17:08 corax New Issue
2008-11-24 17:08 corax File Added: sample.avi
2008-11-24 17:08 corax Build/Install Method => 3rd party package
2008-11-24 19:02 cinephiliac Note Added: 0001384
2008-11-24 19:02 cinephiliac Severity minor => crash
2008-11-24 19:02 cinephiliac Status new => acknowledged
2008-11-24 19:02 cinephiliac File Added: squashed_sound.backtrace.cinephiliac.txt
2008-11-24 19:03 cinephiliac Note Edited: 0001384
2008-11-24 19:06 cinephiliac Note Edited: 0001384
2008-11-24 19:07 cinephiliac Note Edited: 0001384
2008-11-24 20:35 madsdyd Note Added: 0001387
2008-11-24 20:49 madsdyd Note Added: 0001388
2008-11-24 20:57 ddennedy Relationship added duplicate of 0000297
2008-11-24 20:59 madsdyd Note Added: 0001389
2008-11-24 20:59 madsdyd Status acknowledged => resolved
2008-11-24 20:59 madsdyd Resolution open => duplicate
2008-11-25 04:35 ddennedy Note Added: 0001404
2008-12-29 16:27 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker