Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000412KdenliveUser Interfacepublic2008-11-26 14:392010-05-19 15:17
Reporterpapillon81 
Assigned Tomadsdyd 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000412: "Bus error" after setup wizard on PPC machine
DescriptionThe program starts, but after finishing the setup wizard it crashes with:

QStatusBar::insertPermanentWidget: Index out of range (5), appending widget
QStatusBar::insertPermanentWidget: Index out of range (7), appending widget
Bus error

GDB output is attached
Additional InformationDistribution is Gentoo with KDE 4.2 trunk
Tagscrash
Build/Install Method3rd party package
Attached Filestxt file icon kdenlive-crash.txt [^] (7,623 bytes) 2008-11-26 14:39 [Show Content]
txt file icon mlt.txt [^] (10,305 bytes) 2008-11-26 22:22 [Show Content]
patch file icon mlt-0.2.2-motion-est-nonx86.patch [^] (954 bytes) 2008-11-27 13:36 [Show Content]
patch file icon mlt-0.2.3-nostrip.patch [^] (1,763 bytes) 2008-11-27 13:37 [Show Content]
patch file icon mlt-0.3.0-sox1420.patch [^] (742 bytes) 2008-11-27 13:37 [Show Content]

- Relationships

-  Notes
(0001423)
administrator (administrator)
2008-11-26 18:10

Which version of MLT are you using ? Can you play a video clip with MLT's command line player ? Please try this:

inigo video.mpg (replace video.mpg by any video file you have)

Does it work ?
regards
(0001424)
papillon81 (reporter)
2008-11-26 18:44

Sadly it does not work. Crashes with segmentation fault. I'm using MLT version 0.3.2
(0001425)
ddennedy (developer)
2008-11-26 21:06

I can not support big endian in MLT at this time because I do not have a machine to test with, and there are no other developers contributing big endian fixes. Will you?
(0001428)
papillon81 (reporter)
2008-11-26 22:23

As already mentioned, I can do backtraces and try stuff, but I'm not a programmer, sorry. I uploaded a backtrace of the MLT crash. HTH
(0001443)
papillon81 (reporter)
2008-11-27 13:40

According to a request on IRC I added the 3 patches that Gentoo applies to the mlt-0.3.2 ebuild. When trying to compile mlt manually, the mlt-0.2.2-motion-est-nonx86.patch is needed at least, to make it compile on PPC, however the segmentation fault with inigo still occurs.
(0001453)
madsdyd (administrator)
2008-11-28 21:57

I have arranged to borrow a ppc Ibook laptop with a g3 CPU, and will try to reproduce at some point. However, it may be a while.
(0001553)
madsdyd (administrator)
2008-12-06 22:34

Update: I am not able to get my hands on the PPC machine until the 18th of december, so no further progess until then, I am afraid.
(0001788)
madsdyd (administrator)
2008-12-18 14:12

I now have the laptop - I will try to get around to this soonish, not sure we will make it for 0.7.1 though...
(0001885)
madsdyd (administrator)
2008-12-22 12:38

Update: I have been able to reproduce a crash, but has not had time to look into it. I will, one of these (christmas) days.
(0002048)
madsdyd (administrator)
2009-01-04 17:05

Update: Current situation is that inigo complains about loading avformat:

$ strace -o foo -f inigo -query consumers
mlt_repository.c, mlt_repository_init: failed to dlopen /home/madsdyd/kdenlive/lib/mlt/libmltavformat.so, reason: /home/madsdyd/kdenlive/lib/libswscale.so.0: R_PPC_REL24 relocation at 0x0d3fb1a0 for symbol `cos' out of range
---
consumers:
  - westley
  - sdl
  - sdl_preview
  - sdl_still
  - null
  - libdv
  - valerie
...

(the reason line is something I have added, using this patch to mlt:

$ svn diff src/framework/
Index: src/framework/mlt_repository.c
===================================================================
--- src/framework/mlt_repository.c (revision 1303)
+++ src/framework/mlt_repository.c (working copy)
@@ -99,7 +99,7 @@
                }
                else if ( strstr( object_name, "libmlt" ) )
                {
- fprintf( stderr, "%s, %s: failed to dlopen %s\n", __FILE__, __FUNCTION__, object_name );
+ fprintf( stderr, "%s, %s: failed to dlopen %s, reason: %s\n", __FILE__, __FUNCTION__, object_name, dlerror() );
                }
        }

reporter: What is your current situation? Do you know anything about this problem?
(0002059)
papillon81 (reporter)
2009-01-05 01:29

I just tested it:

strace -o foo -f inigo -query consumers
---
consumers:
  - avformat
  - sdl
  - sdl_preview
  - sdl_still
  - valerie
  - libdv
  - null
...

So obviously no problems at this place. I'm using mlt-0.3.2.
(0002420)
papillon81 (reporter)
2009-02-13 14:01

FYI: The Gentoo bugzilla has some more information and recent testing results that might be of interest:

http://bugs.gentoo.org/show_bug.cgi?id=249623 [^]
(0002819)
madsdyd (administrator)
2009-05-06 15:53

I still can't get past the relocation issue:

$ inigo -query producers
mlt_repository_init: failed to dlopen /home/madsdyd/kdenlive/20090506/lib/mlt/libmltavformat.so
  (/home/madsdyd/kdenlive/20090506/lib/libswscale.so.0: R_PPC_REL24 relocation at 0x0d285a84 for symbol `cos' out of range)

I think perhaps I need another PPC machine to test this on.

I am sorry, but I think I am stumped on this. I do not have access to other PPC machines.
(0004999)
LeHomard (developer)
2010-04-10 22:04

Is the issue still present with version 0.7.7 or latest svn ? If the issue isn't confirmed I'll go ahead and close the bug report.
(0005162)
LeHomard (developer)
2010-05-19 15:17

Lack of response, closing report.

- Issue History
Date Modified Username Field Change
2008-11-26 14:39 papillon81 New Issue
2008-11-26 14:39 papillon81 File Added: kdenlive-crash.txt
2008-11-26 14:39 papillon81 Build/Install Method => 3rd party package
2008-11-26 16:00 papillon81 Tag Attached: crash
2008-11-26 18:10 administrator Note Added: 0001423
2008-11-26 18:44 papillon81 Note Added: 0001424
2008-11-26 21:06 ddennedy Note Added: 0001425
2008-11-26 22:22 papillon81 File Added: mlt.txt
2008-11-26 22:23 papillon81 Note Added: 0001428
2008-11-27 13:36 papillon81 File Added: mlt-0.2.2-motion-est-nonx86.patch
2008-11-27 13:37 papillon81 File Added: mlt-0.2.3-nostrip.patch
2008-11-27 13:37 papillon81 File Added: mlt-0.3.0-sox1420.patch
2008-11-27 13:40 papillon81 Note Added: 0001443
2008-11-28 21:56 madsdyd Status new => assigned
2008-11-28 21:56 madsdyd Assigned To => madsdyd
2008-11-28 21:57 madsdyd Note Added: 0001453
2008-12-06 22:34 madsdyd Note Added: 0001553
2008-12-18 14:12 madsdyd Note Added: 0001788
2008-12-22 12:38 madsdyd Note Added: 0001885
2009-01-04 17:05 madsdyd Note Added: 0002048
2009-01-05 01:29 papillon81 Note Added: 0002059
2009-02-13 14:01 papillon81 Note Added: 0002420
2009-05-06 15:53 madsdyd Note Added: 0002819
2010-04-10 22:04 LeHomard Note Added: 0004999
2010-04-10 22:04 LeHomard Status assigned => feedback
2010-05-19 15:17 LeHomard Note Added: 0005162
2010-05-19 15:17 LeHomard Status feedback => resolved
2010-05-19 15:17 LeHomard Resolution open => fixed
2010-05-19 15:17 LeHomard Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker