Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000451KdenliveFile Loadingpublic2008-12-09 23:272008-12-29 15:37
Reporterzootrasgo 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.1 
Summary0000451: crash loading project
Descriptionkdenlive svn crashes loading a fileproject created 1 day ago.
Additional Informationkdenlive(29109) KdenliveDoc::KdenliveDoc: Reading file: "/home/al/Documentos/wii.kdenlive" , found clips: 7
kdenlive(29109) KdenliveDoc::KdenliveDoc: KDEnnlive document, init timecode: 25
ASSERT failure in QList<T>::operator[]: "index out of range", file /usr/include/qt4/QtCore/qlist.h, line 395
KCrash: Application 'kdenlive' crashing...
sock_file=/home/al/.kde/socket-xp-pavilion/kdeinit4__0
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon wii.kdenlive [^] (5,933 bytes) 2008-12-09 23:27

- Relationships

-  Notes
(0001606)
cinephiliac (updater)
2008-12-10 22:23

Hi Zootrasgo,

Thanks for letting us know about this. It would help if you could provide a bit of extra information.

1. Given that you've indicated the crash is reproducible, it would be great to know how to recreate it in a step 1...step 2..step 3... kind of format.

2. Your version numbers would also help here. Given that you've used the build wizard, you can get them easily. Instructions can be found at http://en.wikibooks.org/wiki/Kdenlive/Reporting_bugs [^] under "Version:".

Thanks!
(0001643)
zootrasgo (reporter)
2008-12-14 13:13

Sorry for not giving enough information:

Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 16042 Last Changed Date: 2008-12-09 21:11:37 +0100 (Tue, 09 Dec 2008)
mlt: Revision: 1255 Last Changed Date: 2008-12-04 19:25:48 +0100 (Thu, 04 Dec 2008)
mlt++: Revision: 1255 Last Changed Date: 2008-12-04 23:31:49 +0100 (Thu, 04 Dec 2008)
kdenlive: Revision: 2771 Last Changed Date: 2008-12-09 22:23:26 +0100 (Tue, 09 Dec 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7


0.7 still crashes opening a 0.5 project file (attached)

1 launch kdenlive form shell "/home/al/kdenlive/20081209/bin/kdenlive"
2 open file project "/home/al/Documentos/wii.kdenlive"
3 process up to (around) 47%
4 crash
5 shell output

QFile::remove: Empty or null file name
kdenlive(9971) EffectStackEdit::transferParamDesc: in
kdenlive(9971) KdenliveDoc::setProfilePath: KDEnnlive document, init timecode from path: "hdv_1080_50i" , 25
kdenlive(9971) KdenliveDoc::convertDocument: Opening a document with version 0.6
kdenlive(9971) ProfilesDialog::getVideoProfile: // WARNING, COULD NOT FIND PROFILE "pal_dv"
kdenlive(9971) KdenliveDoc::setProfilePath: KDEnnlive document, init timecode from path: "pal_dv" , 25
kdenlive(9971) KdenliveDoc::convertDocument: Converting producer element with type "3"
kdenlive(9971) KdenliveDoc::convertDocument: Converting producer element with type "3"
kdenlive(9971) KdenliveDoc::convertDocument: Converting producer element with type "3"
kdenlive(9971) KdenliveDoc::convertDocument: Converting producer element with type "3"
kdenlive(9971) KdenliveDoc::convertDocument: Converting producer element with type "3"
kdenlive(9971) KdenliveDoc::convertDocument: Converting producer element with type "1"
kdenlive(9971) KdenliveDoc::convertDocument: Converting producer element with type ""
kdenlive(9971) KdenliveDoc::convertDocument: found 8 <avfile />s and 7 <kdenlive_producer />s
kdenlive(9971) KdenliveDoc::KdenliveDoc: // PROD: "8"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // PROD: "7"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // PROD: "6"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // PROD: "4"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // PROD: "1"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // PROD: "0"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // NLIVE PROD: "8"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // NLIVE PROD: "7"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // NLIVE PROD: "6"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // NLIVE PROD: "4"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // NLIVE PROD: "1"
kdenlive(9971) KdenliveDoc::KdenliveDoc: // NLIVE PROD: "0"
kdenlive(9971) KdenliveDoc::KdenliveDoc: Reading file: "/home/al/Documentos/wii.kdenlive" , found clips: 7
kdenlive(9971) KdenliveDoc::KdenliveDoc: KDEnnlive document, init timecode: 25
ASSERT failure in QList<T>::operator[]: "index out of range", file /usr/include/qt4/QtCore/qlist.h, line 395
KCrash: Application 'kdenlive' crashing...
sock_file=/home/al/.kde/socket-xp-pavilion/kdeinit4__0
(0001739)
ddennedy (developer)
2008-12-17 07:11

When you use the build wizard, you need to launch kdenlive with "/home/al/kdenlive/20081209/bin/kdenlive_start"

Note the _start
(0001749)
zootrasgo (reporter)
2008-12-17 09:44

Thank you for the remark. However the error persists, and the output is the same. This afternoon I'll build Kdenlive again to check if the last commits solved the problem.
(0001767)
xzhayon (developer)
2008-12-17 21:04

this could be a duplicate of 358 (latest problems)
(0001771)
ddennedy (developer)
2008-12-17 22:52

What is interesting is that the original report did not indicate he was using a 0.5 project file. In fact, it says "created 1 day ago," which I assumed to be a 0.7 project. So which is it?

Also, when you rebuild, please enable the option to clean the sources.
(0001794)
xzhayon (developer)
2008-12-18 19:02

zootrasgo: i can't reproduce the crash after the latest commits, could you please retest it following ddennedy's instructions to build the latest svn version of kdenlive?
(0001818)
zootrasgo (reporter)
2008-12-19 20:46

The problem is solved now with the new built:

Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 16240 Last Changed Date: 2008-12-19 15:49:17 +0100 (Fri, 19 Dec 2008)
mlt: Revision: 1271 Last Changed Date: 2008-12-18 08:37:29 +0100 (Thu, 18 Dec 2008)
mlt++: Revision: 1271 Last Changed Date: 2008-12-04 23:31:49 +0100 (Thu, 04 Dec 2008)
kdenlive: Revision: 2809 Last Changed Date: 2008-12-19 17:50:54 +0100 (Fri, 19 Dec 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7

ddennedy, the file was created with the kubuntu version 0.5, although the file was marked as 0.6 on kdenlivedoc field. Then the next day I built the 0.7 version and that crashed.

thank you everyone
(0001835)
xzhayon (developer)
2008-12-21 03:12

issue fixed in one of the latest commits (2804?)

- Issue History
Date Modified Username Field Change
2008-12-09 23:27 zootrasgo New Issue
2008-12-09 23:27 zootrasgo File Added: wii.kdenlive
2008-12-09 23:27 zootrasgo Build/Install Method => Build Wizard
2008-12-10 22:23 cinephiliac Note Added: 0001606
2008-12-10 22:23 cinephiliac Status new => feedback
2008-12-14 13:13 zootrasgo Note Added: 0001643
2008-12-17 07:11 ddennedy Note Added: 0001739
2008-12-17 09:44 zootrasgo Note Added: 0001749
2008-12-17 21:04 xzhayon Note Added: 0001767
2008-12-17 22:52 ddennedy Note Added: 0001771
2008-12-18 19:02 xzhayon Note Added: 0001794
2008-12-19 20:46 zootrasgo Note Added: 0001818
2008-12-21 03:12 xzhayon Note Added: 0001835
2008-12-21 03:12 xzhayon Status feedback => resolved
2008-12-21 03:12 xzhayon Fixed in Version => Recent git
2008-12-21 03:12 xzhayon Resolution open => fixed
2008-12-21 03:12 xzhayon Assigned To => xzhayon
2008-12-21 03:12 xzhayon Assigned To xzhayon =>
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker