Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000474KdenliveUser Interfacepublic2008-12-15 12:232008-12-29 15:37
Reportermarcozambi 
Assigned Tomadsdyd 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.1 
Summary0000474: KDEnlive crashes adding a new track
DescriptionKDENlive crashes always when I try to add a new video or audio track on an existing project.
The crash is present both for audio and video tracks, and trying to add them in any position.

BUT adding a track works just on brand new projects, with no content placed on timelines.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filestxt file icon marcozambi.bt.txt [^] (50,243 bytes) 2008-12-15 13:19 [Show Content]
? file icon kbw.gdb.output.lkk18164 [^] (56,716 bytes) 2008-12-16 10:06
? file icon 4207.kdenlive [^] (10,084 bytes) 2008-12-16 10:07

- Relationships

-  Notes
(0001673)
cinephiliac (updater)
2008-12-15 13:09

Thanks for the backtrace. They're very useful to the developers when trying to solve your problem. What helps even more is when you copy and save it as a separate file and upload it using the "Upload File" button on the bug report page. This makes it faster and easier for everyone to read, skim and get back to fixing your bug. :)

I've taken the liberty of splitting it off and attaching it for you this time.

Could you post the .kdenlive file if you can, just in case it's only that file being corrupted. If that's a problem, just let us know and we'll do what we can.
(0001677)
madsdyd (administrator)
2008-12-15 13:55

If you could try with svn revision 2787 also, I would be glad. I added some code yesterday, that *may* be related to this crash? Of course, if it has been crashing for you for a long time... its probably something else.
(0001702)
marcozambi (reporter)
2008-12-16 10:14

Hi!
I've just updated to the latest snapshot (using wizard) available, at 09.50 CST of 16/12/2008.
Re-compiled but the glitch is still there, and the application crashes as I command to add a new audio or video track.
I have attached crash file and .kdenfile I've used. I opened also many other .kdenlive files but it always crashes.

Just to be clearer, as I wrote, crashes do not occour if one tries to add tracks in a freshly open new project, as you obtain starting kdenlive. This is wired :D
(0001703)
marcozambi (reporter)
2008-12-16 10:16

@madsdyd I don't think that crashes are related wiht recent updates. I have seen crashes since the "Add track" funcionality was added into the project. :(
(0001704)
marcozambi (reporter)
2008-12-16 10:19

And yes, I managed to read the revision numbers:
ffmpeg -> 16163
mlt -> 1265
mlt++ -> 1265
kdenlive -> 2789
(0001839)
xzhayon (developer)
2008-12-21 03:33

i can't test this at the moment (well, i've done with a simple project and got no crash), but can this be related to 501? since it crashes when calls track->producer, and since i think that 501 problem is a wrong relation between tracks and producers, they could match

?
(0001888)
marcozambi (reporter)
2008-12-22 16:20

I have upgraded via Wizard to these versions, and the crashes aren't present anymore.
FFMPEG: 16268
MLT and MLT++: 1286
KDENLIVE: 2812
Anyway, I have a lot of "phantom" transitions appearing here and there... but it's a different story. I am opening a new mantis ticket.
(0001889)
madsdyd (administrator)
2008-12-22 16:28

Must have been fixed along the way. (Recent track fix commits).

- Issue History
Date Modified Username Field Change
2008-12-15 12:23 marcozambi New Issue
2008-12-15 12:23 marcozambi Build/Install Method => Build Wizard
2008-12-15 13:09 cinephiliac Note Added: 0001673
2008-12-15 13:09 cinephiliac Status new => feedback
2008-12-15 13:09 cinephiliac Additional Information Updated
2008-12-15 13:19 cinephiliac File Added: marcozambi.bt.txt
2008-12-15 13:55 madsdyd Note Added: 0001677
2008-12-16 10:06 marcozambi File Added: kbw.gdb.output.lkk18164
2008-12-16 10:07 marcozambi File Added: 4207.kdenlive
2008-12-16 10:14 marcozambi Note Added: 0001702
2008-12-16 10:16 marcozambi Note Added: 0001703
2008-12-16 10:19 marcozambi Note Added: 0001704
2008-12-21 03:33 xzhayon Note Added: 0001839
2008-12-22 16:20 marcozambi Note Added: 0001888
2008-12-22 16:28 madsdyd Note Added: 0001889
2008-12-22 16:28 madsdyd Status feedback => resolved
2008-12-22 16:28 madsdyd Fixed in Version => Recent git
2008-12-22 16:28 madsdyd Resolution open => fixed
2008-12-22 16:28 madsdyd Assigned To => madsdyd
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker