Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000482KdenliveBuild Systempublic2008-12-17 06:372009-06-03 08:03
Reportercinephiliac 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000482: Render never starts and settings->config wizard reports "MLT's avformat (FFMPEG) module not found"
DescriptionWhen clicking render from the render dialogue, KUI server comes up, but no progress bar, icon or name for kdenlive ever appear in KUIserver and the file never renders.

Also, the settings -config wizard reports "Fatal error: MLT's avformat (FFMPEG) module not found. [...] MLT's SDL module not found.
Additional InformationI went back and checked I had all the packages listed at https://help.ubuntu.com/community/KdenliveSVN [^] installed and ran the wizard again to no effect.

All the usual binaries are in the bin folder, along with mlt-config.

I don't see any unusual output in the console, or get any crashes.

VERSIONS:
Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 16175 Last Changed Date: 2008-12-16 16:35:35 -0500 (Tue, 16 Dec 2008)
mlt: Revision: 1266 Last Changed Date: 2008-12-16 03:36:14 -0500 (Tue, 16 Dec 2008)
mlt++: Revision: 1266 Last Changed Date: 2008-12-04 17:31:49 -0500 (Thu, 04 Dec 2008)
kdenlive: Revision: 2802 Last Changed Date: 2008-12-16 16:54:56 -0500 (Tue, 16 Dec 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7

STEPS TO REPRODUCE:
1. Open any project in Kdenlive.
2. Click Render button.
3. Select any presets (last time I used mpeg4 on the default setting).
4. Click Render
5. See KUIserver come up and... nothing else happens.

Video screengrab of the config wizard and KUIserver attached.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon capture0008.ogv [^] (2,658,089 bytes) 2008-12-17 06:37
? file icon kbw.log.20081219.001113.gknF7497 [^] (497,724 bytes) 2008-12-19 06:55

- Relationships

-  Notes
(0001738)
ddennedy (developer)
2008-12-17 06:56

What sort of change or fix are you looking for? Of course, I can not reproduce the problem. Are you asking us to find a problem with the build that breaks on your specific environment? If so, we need more information about what went wrong. We need the log from the builder wizard. Also, if you updated an existing install using the wizard, please re-run it and clean the sources to see if that resolves it.
(0001808)
cinephiliac (updater)
2008-12-19 06:56

Hey Dan,

I was just reporting because I didn't know if it was a Kdenlive/MLT problem others would encounter or not. I figured it was probably a build wizard issue for Mads and didn't know about the log the KBW generates. I've attached the latest one now.

Turns out that updating my KDE from 4.1.3 to 4.2 Beta 2 today seems to have fixed KUIserver not showing rendering, but it complete's in about 1 second and renders no file.

I've only ever used the build wizard with clean sources turned on as I have no idea what it does.

If there's a way I can help better, just let me know.
(0001809)
cinephiliac (updater)
2008-12-19 07:12

The only console feedback between when I push the render button and when KUIserver indicates the render finishing is:

//STARTING RENDERING: true , "/home/user/Apps/Kdenlive/20081123/bin/inigo" , "hdv_1080_60i" , "avformat" , "-" , "/tmp/kde-user/kdenliveg24437.westley" , "/home/user/untitled.m2t" , () , ("f=mpegts", "ab=384k", "ar=48000", "vcodec=mpeg2video", "s=1440x1080", "b=19700k", "g=15", "profile=hdv_1080_60i") , -1 , -1

My versions are:
Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 16223 Last Changed Date: 2008-12-18 13:25:11 -0500 (Thu, 18 Dec 2008)
mlt: Revision: 1271 Last Changed Date: 2008-12-18 02:37:29 -0500 (Thu, 18 Dec 2008)
mlt++: Revision: 1271 Last Changed Date: 2008-12-04 17:31:49 -0500 (Thu, 04 Dec 2008)
kdenlive: Revision: 2808 Last Changed Date: 2008-12-18 08:31:46 -0500 (Thu, 18 Dec 2008)
Qt: 4.4.3
KDE: 4.1.85 (KDE 4.1.85 (KDE 4.2 Beta2))
Kdenlive: 0.7
(0001849)
madsdyd (administrator)
2008-12-21 11:28

Hi Cinephiliac.

Sorry to hear about you having troubles.

I can see from the kbw log that you are using the "append date" option. Do you have older Kdenlive installs that works?

Alternatively, I added some logging from kdenlive_render to Kdenlive SVN rev 2810. Perhaps this could shed some light on it?

Finally, if you run kdenlive_start -g it will create a log file even when *not* crashing. This log file (from a run that fails to render) would be good to have, because it contains some information about libraries, etc.
(0003078)
ddennedy (developer)
2009-06-03 08:03

not a kdenlive bug and not a reproducible issue with the build system

- Issue History
Date Modified Username Field Change
2008-12-17 06:37 cinephiliac New Issue
2008-12-17 06:37 cinephiliac File Added: capture0008.ogv
2008-12-17 06:37 cinephiliac Build/Install Method => Build Wizard
2008-12-17 06:56 ddennedy Note Added: 0001738
2008-12-19 06:55 cinephiliac File Added: kbw.log.20081219.001113.gknF7497
2008-12-19 06:56 cinephiliac Note Added: 0001808
2008-12-19 07:12 cinephiliac Note Added: 0001809
2008-12-21 11:28 madsdyd Note Added: 0001849
2008-12-21 11:28 madsdyd Status new => feedback
2009-06-03 08:03 ddennedy Note Added: 0003078
2009-06-03 08:03 ddennedy Status feedback => resolved
2009-06-03 08:03 ddennedy Resolution open => no change required
2009-06-03 08:03 ddennedy Assigned To => ddennedy
2009-06-03 08:03 ddennedy Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker