Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000487KdenliveMLTpublic2008-12-18 12:582009-06-11 00:14
Reporterxzhayon 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.3 
Summary0000487: empty slideshows result in a crash
Descriptionwhen trying to load as a slideshow (not through the "add slideshow" interface since it forbids this, but there are other ways) a folder without images that match the given wildcard, kdenlive crashes
Additional Informationit could be checked by kdenlive, but it should be possible to "leave as placeholder" an empty slideshow clip

crash report:
Program received signal SIGFPE, Arithmetic exception.
[Switching to Thread 0x2b401100 (LWP 100307)]
0x2ba18b53 in load_image (producer=) at producer_sdl_image.c:153
153 image_idx = ( int )floor( ( double )position / ttl ) % mlt_properties_count( filenames );

is % mlt_properties_count( filenames ) the problem (since it should be equal to % 0)?
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filestxt file icon empty_slideshows-gdb.txt [^] (5,416 bytes) 2008-12-18 12:58 [Show Content]

- Relationships
related to 0000310closed Add slideshow clip crashes kdenlive 

-  Notes
(0001804)
cinephiliac (updater)
2008-12-19 06:39

Hi xzhayon,

You mention that there "are other ways" to load a slideshow. Could you provide step by step instructions on how to recreate this, as the only user visible way of creating a slideshow is through the interface.

If you can do this I can try and confirm this bug.

Thanks!
(0001811)
xzhayon (developer)
2008-12-19 10:31

move the folder containing the images and load the project: a dialog will appear asking you to "search manually/leave as placeholder"
if you search it and select a folder without (for example) *.jpg images you'll get a crash
if you choose to leave as placeholder you'll get a crash

also, if you delete the images and leave the directory empty, and then load the project, you'll get no errors, but it will crash
(0001814)
administrator (administrator)
2008-12-19 15:41

I just submitted a patch on MLT's mailing list that will solve the MLT crash and allow clip as placeholder
(0001836)
xzhayon (developer)
2008-12-21 03:14

marking as acknowledged since jb confirmed and submitted a patch for the issue
(0001872)
madsdyd (administrator)
2008-12-21 19:32

Patch in MLT has made it in MLT svn rev 1281 - please test, thanks.
(0002671)
xzhayon (developer)
2009-04-08 20:29
edited on: 2009-04-08 20:40

management of this situation improved, but it's still crashing. here's what i get when i:

1. rename the directory of the slideshow
2. open the project
3. select "keep as placeholder" when prompted about the slideshow

...a dialog saying "Clip xxx/.all.jpg is invalid, will be removed from project." and the following crash:

kdenlive(18174) Render::getFileProperties: // LOOKING FORÂ H264 on: 0
kdenlive(18174) Render::getFileProperties: PROP: meta.media.0.codec.name = svq3
kdenlive(18174) Render::getFileProperties: REquested fuile info for: "/home/albi/kingdom_of_heaven-excl_m480.mov"
kdenlive(18174) Render::getFileProperties: / / / / / / / / ERROR / / / / // CANNOT LOAD PRODUCER:
kdenlive(18174) AddClipCommand::redo: ---- redoing action
[Thread 0x2da54cf0 (LWP 100282) exited]
[Thread 0x2da54e00 (LWP 100283) exited]
kdenlive: Fatal IO error: client killed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x2a501040 (LWP 100194)]
0x2bc38d69 in ?? ()

unfortunately i can't get a backtrace, the stack is corrupt..
it seems i can't reproduce this 100% of the times...

(0002673)
xzhayon (developer)
2009-04-09 02:45

fixed in revision 3265 introducing placeholders management (those, unfortunately, are still crashing: opening a new issue for that)

- Issue History
Date Modified Username Field Change
2008-12-18 12:58 xzhayon New Issue
2008-12-18 12:58 xzhayon File Added: empty_slideshows-gdb.txt
2008-12-18 12:58 xzhayon Build/Install Method => Manual build from SVN
2008-12-19 06:39 cinephiliac Note Added: 0001804
2008-12-19 06:39 cinephiliac Status new => feedback
2008-12-19 10:31 xzhayon Note Added: 0001811
2008-12-19 15:41 administrator Note Added: 0001814
2008-12-21 03:14 xzhayon Note Added: 0001836
2008-12-21 03:14 xzhayon Status feedback => acknowledged
2008-12-21 12:13 madsdyd Relationship added related to 0000310
2008-12-21 19:32 madsdyd Note Added: 0001872
2009-04-05 09:10 xzhayon Status acknowledged => feedback
2009-04-08 20:29 xzhayon Note Added: 0002671
2009-04-08 20:35 xzhayon Note Edited: 0002671
2009-04-08 20:40 xzhayon Note Edited: 0002671
2009-04-09 02:39 xzhayon Note Added: 0002672
2009-04-09 02:43 xzhayon Note Edited: 0002672
2009-04-09 02:44 xzhayon Note Deleted: 0002672
2009-04-09 02:45 xzhayon Note Added: 0002673
2009-04-09 02:45 xzhayon Status feedback => resolved
2009-04-09 02:45 xzhayon Fixed in Version => Recent git
2009-04-09 02:45 xzhayon Resolution open => fixed
2009-04-09 02:45 xzhayon Assigned To => xzhayon
2009-04-09 02:45 xzhayon Assigned To xzhayon =>
2009-04-15 13:07 madsdyd Fixed in Version Recent git => 0.7.3
2009-06-11 00:14 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker