Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000499KdenliveEffectspublic2008-12-19 22:352008-12-29 15:37
Reporterrudlavibizon 
Assigned Tomadsdyd 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.1 
Summary0000499: LADSPA audio effects not working
DescriptionWhen added to a clip nothing happens.

(This svn version updated on 17.12.2008.)
Additional InformationHere is the command line output:

kdenlive(8550) CustomTrackView::slotAddEffect: // REQUESTING EFFECT ON CLIP: 544 , TRK: 2 SELECTED ITEMS: 1
kdenlive(8550) AddEffectCommand::redo: ---- redoing action
kdenlive(8550) Render::mltAddEffect: / / INSERTING EFFECT: "ladspa"
kdenlive(8550) EffectStackEdit::transferParamDesc: in
kdenlive(8550) EffectStackEdit::transferParamDesc: in form
kdenlive(8550) EffectStackEdit::transferParamDesc: in form
kdenlive(8550) EffectStackEdit::transferParamDesc: in form
kdenlive(8550) EffectStackEdit::transferParamDesc: in form
QPainterPath::arcTo: Adding arc where a parameter is NaN, results are undefined
QPainterPath::arcTo: Adding arc where a parameter is NaN, results are undefined
QPainterPath::arcTo: Adding arc where a parameter is NaN, results are undefined
QPainterPath::arcTo: Adding arc where a parameter is NaN, results are undefined
QPainterPath::arcTo: Adding arc where a parameter is NaN, results are undefined
QPainterPath::arcTo: Adding arc where a parameter is NaN, results are undefined
QPainterPath::arcTo: Adding arc where a parameter is NaN, results are undefined
QPainterPath::arcTo: Adding arc where a parameter is NaN, results are undefined
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0001867)
madsdyd (administrator)
2008-12-21 14:54

Please provide a bit of information about the clip and the ladspa effect in question. Is this very general or only only some combinations? And, provide a named ladspa and/or sox effect so that we know which ones to try.
(0001868)
rudlavibizon (reporter)
2008-12-21 15:04

All ladspa and sox effects don't work (pitch shift, limiter, sox pitch shift, flanger...etc). Effects that work are (I guess) Kdenlives own, like volume, fade in and out, mute. This looks like something system specific to me. I use Xubuntu 8.10, amd64.
(0001870)
rudlavibizon (reporter)
2008-12-21 18:13

I see in this issue http://www.kdenlive.org/mantis/view.php?id=306 [^] that there is supposed to be an effects folder with "sox_pitch.xml". I dont have one, maybe that's the problem? I tried the ladspa and sox effects in other applications and they work.
(0001877)
ddennedy (developer)
2008-12-21 22:13

Since you said you did a manual build, then I assume you built mlt yourself. Then, you should know if the mlt build found and built the sox and ladspa plugins. Run 'inigo -query filters' and see the output to see if you see anything about sox or ladspa. If not, you need to check that you have the corresponding -dev packages for these audio frameworks and rebuild mlt. See the tail of mlt's config.log to see how you configured it previously to save yourself some time.
(0001882)
rudlavibizon (reporter)
2008-12-22 07:13
edited on: 2008-12-22 07:13

It looks like MLT built everything:


inigo -query filters
---
filters:
  .......
  - sox
  - volume
  - gtkrescale
  - jackrack
  - ladspa

(0001897)
ddennedy (developer)
2008-12-22 21:08

OK, good. Do you have any XML files in your $prefix/share/apps/kdenlive/effects that starts with sox_ or ladspa_ ?
I am suspecting that these were installed to the wrong place. Perhaps use 'locate' to look for sox_pitch.xml. Is this the place where KDE4 looks for resources on your system? I don't know right now how to best determine that. 'kde4-config --path data' ?
(0001901)
rudlavibizon (reporter)
2008-12-22 21:57

It says:

kde4-config --path data
/home/rudlavibizon/.kde/share/apps/:/usr/share/kde4/apps/

ls /usr/share/kde4/apps/kdenlive/effects/
automask.xml invert.xml normalise.xml
boxblur.xml ladspa_declipper.xml obscure.xml
brightness.xml ladspa_equalizer.xml rotation.xml
charcoal.xml ladspa_limiter.xml sepia.xml
chroma_hold.xml ladspa_phaser.xml sox_echo.xml
chroma.xml ladspa_pitch_scale.xml sox_flanger.xml
fadein.xml ladspa_pitch.xml sox_pitch.xml
fadeout.xml ladspa_rate_scale.xml sox_reverb.xml
freeze.xml ladspa_reverb.xml sox_vibro.xml
frei0r_distort0r.xml ladspa_room_reverb.xml threshold.xml
frei0r_squareblur.xml ladspa_vinyl.xml volume.xml
gamma.xml mirror.xml wave.xml
greyscale.xml mute.xml

Seems like its all there. I tried copying to the /home/rudlavibizon/.kde/share/apps/ but it just doubles the effect entries.
(0001944)
rudlavibizon (reporter)
2008-12-28 19:53

Please close this issue. I reinstalled the whole system, the problem is gone now. Thanks ddennedy & madsdyd!
(0001945)
madsdyd (administrator)
2008-12-28 21:17

Resolved - build issue user end.

Thanks for getting back on it :-)
(0001946)
madsdyd (administrator)
2008-12-28 21:19

Too quick there, turns out a fix was applied to Kdenlive SVN rev 2838.

There is a related patch pending for MLT, but the issue is solved in Kdenlive, the other patch just appears to "harden" MLT.

- Issue History
Date Modified Username Field Change
2008-12-19 22:35 rudlavibizon New Issue
2008-12-19 22:35 rudlavibizon Build/Install Method => Manual build from SVN
2008-12-21 14:54 madsdyd Note Added: 0001867
2008-12-21 14:54 madsdyd Status new => feedback
2008-12-21 15:04 rudlavibizon Note Added: 0001868
2008-12-21 18:13 rudlavibizon Note Added: 0001870
2008-12-21 22:13 ddennedy Note Added: 0001877
2008-12-22 07:13 rudlavibizon Note Added: 0001882
2008-12-22 07:13 rudlavibizon Note Edited: 0001882
2008-12-22 21:08 ddennedy Note Added: 0001897
2008-12-22 21:57 rudlavibizon Note Added: 0001901
2008-12-28 19:53 rudlavibizon Note Added: 0001944
2008-12-28 21:17 madsdyd Note Added: 0001945
2008-12-28 21:17 madsdyd Status feedback => resolved
2008-12-28 21:17 madsdyd Fixed in Version => Recent git
2008-12-28 21:17 madsdyd Resolution open => no change required
2008-12-28 21:17 madsdyd Assigned To => madsdyd
2008-12-28 21:19 madsdyd Note Added: 0001946
2008-12-28 21:19 madsdyd Resolution no change required => fixed
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker