Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000515KdenliveUser Interfacepublic2008-12-23 11:402009-05-30 12:01
Reportermadsdyd 
Assigned Toxzhayon 
PrioritylowSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSKubuntu LinuxOS Version8.04
Product VersionRecent git 
Target VersionFixed in Version0.7.4 
Summary0000515: Selection tool should allow dragging an unselected clip
DescriptionThe selection tool can be used to drag clips (obviously).

The currently selected clip can easily be dragged with the selection tool.

However, if the clip is not selected, one needs to select it before one can drag. This is tedious, and also, against the visual feedback from the cursor, which indicates a drag in both situations (a little hand grabbing the clip).

Very low priority, but at some point it would be nice to get fixed. I have set "feature" on this; one could argue it was a minor bug, really, because of the visual feedback from the cursor.
TagsNo tags attached.
Build/Install MethodNot Applicable
Attached Files

- Relationships
has duplicate 0000521closedmadsdyd can't click and drag immediately 
has duplicate 0000764closed Moving a clip needs 2 clicks 
has duplicate 0000826closed To move a clip you need to select it first 

-  Notes
(0002095)
rudlavibizon (reporter)
2009-01-09 14:29

A minor bug (feature) but extremely annoying for me. So I'm bumping this issue.
(0002708)
Cimmo (reporter)
2009-04-12 15:40

Definitly, number of clicks is double, pls fix :)
(0002823)
xzhayon (developer)
2009-05-08 15:29
edited on: 2009-05-08 16:35

this should be fixed in rev. 3368 (i've reassigned the issue to myself because it was unmaintained, hope i can do that!)
there are still some issues with groups dragging, but not introduced in this commit: i'll try to fix them

please, test for regressions

(0002827)
eurodrew555 (reporter)
2009-05-08 21:00

just upgraded to rev 3368

first time I opened a project and tested this out I was getting a seg fault, but after creating a new project and then testing again I can't get it to seg fault any more, even with the old project.
(0002833)
xzhayon (developer)
2009-05-09 17:19

yeah, i've got some random crashes too, but they were already there... i don't think this little patch has broken something
(0002876)
xzhayon (developer)
2009-05-17 15:43

so, marking as resolved (rev. 3368)
(0002893)
Granjow (developer)
2009-05-23 19:51

Oh. That's why it suddenly worked very smooth. Thanks!

- Issue History
Date Modified Username Field Change
2008-12-23 11:40 madsdyd New Issue
2008-12-23 11:40 madsdyd Build/Install Method => Not Applicable
2008-12-29 00:53 madsdyd Relationship added has duplicate 0000521
2009-01-09 14:29 rudlavibizon Note Added: 0002095
2009-01-27 20:23 Granjow Assigned To => Granjow
2009-01-27 20:23 Granjow Status new => assigned
2009-04-12 15:40 Cimmo Note Added: 0002708
2009-05-08 15:29 xzhayon Note Added: 0002823
2009-05-08 15:29 xzhayon Assigned To Granjow => xzhayon
2009-05-08 15:29 xzhayon Status assigned => feedback
2009-05-08 15:31 xzhayon Relationship added has duplicate 0000764
2009-05-08 16:35 xzhayon Note Edited: 0002823
2009-05-08 21:00 eurodrew555 Note Added: 0002827
2009-05-09 17:19 xzhayon Note Added: 0002833
2009-05-14 14:52 xzhayon Relationship added has duplicate 0000826
2009-05-17 15:43 xzhayon Note Added: 0002876
2009-05-17 15:43 xzhayon Status feedback => resolved
2009-05-17 15:43 xzhayon Fixed in Version => Recent git
2009-05-17 15:43 xzhayon Resolution open => fixed
2009-05-23 19:51 Granjow Note Added: 0002893
2009-05-30 11:58 administrator Fixed in Version Recent git => 0.7.4
2009-05-30 12:01 administrator Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker