Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000543KdenliveTranslationpublic2008-12-30 19:272009-02-02 23:49
Reporterthe-me 
Assigned Tomadsdyd 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.1 
Target VersionFixed in Version0.7.2 
Summary0000543: [PATCH] Escaping of hypens in manpages
DescriptionHello,

I attached the patch which I add to the Debian release.
Please merge it.

Thanks.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon 01-escape-hyphens-man.dpatch [^] (4,119 bytes) 2008-12-30 19:27

- Relationships

-  Notes
(0001994)
madsdyd (administrator)
2009-01-01 17:44

Thanks.

Could you perhaps explain why these escapes are needed?

Regards

Mads
(0001995)
the-me (reporter)
2009-01-01 17:53

From lintian (which should explain everything):

Manual page seems to contain a hyphen where a minus sign was intended. '-' chars are interpreted as hyphens (U+2010) by groff, not as minus signs (U+002D). Since options to programs use minus signs (U+002D), this means for example in UTF-8 locales that you cannot cut&paste options, nor search for them easily.

'-' must be escaped ('\-') to be interpreted as minus. If you really intend a hyphen, write it as '\(hy' to emphasise that fact. See groff(7) and especially groff_char(7) for details, and also the thread starting with http://lists.debian.org/debian-devel/2003/debian-devel-200303/msg01481.html [^]

If you use some tool that converts your documentation to groff format, it might be possible that this tool converts dashes of any kind to groff hyphens, while the safe way of converting dashes is usually to convert them to '\-'.
(0002106)
madsdyd (administrator)
2009-01-11 22:33

Applied in svn rev 2895 - thanks.

- Issue History
Date Modified Username Field Change
2008-12-30 19:27 the-me New Issue
2008-12-30 19:27 the-me File Added: 01-escape-hyphens-man.dpatch
2008-12-30 19:27 the-me Build/Install Method => Distribution package
2009-01-01 17:44 madsdyd Note Added: 0001994
2009-01-01 17:44 madsdyd Status new => feedback
2009-01-01 17:53 the-me Note Added: 0001995
2009-01-11 22:28 madsdyd Status feedback => assigned
2009-01-11 22:28 madsdyd Assigned To => madsdyd
2009-01-11 22:33 madsdyd Note Added: 0002106
2009-01-11 22:33 madsdyd Status assigned => resolved
2009-01-11 22:33 madsdyd Fixed in Version => Recent git
2009-01-11 22:33 madsdyd Resolution open => fixed
2009-02-02 23:42 xzhayon Fixed in Version Recent git => 0.7.2
2009-02-02 23:49 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker