Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000556KdenliveMLTpublic2009-01-03 05:182010-09-14 23:29
Reportergriphiam 
Assigned ToLeHomard 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000556: Can't move title clip between tracks if there are transitions attached
DescriptionCauses crash. Console output just says

kdenlive: Fatal IO error: client killed

Sometimes the clip can move and the transition is left behind.

TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon kbw.gdb.output.lXV26551 [^] (25,645 bytes) 2009-01-03 10:10
txt file icon gbd_output.txt [^] (25,645 bytes) 2009-01-03 10:12 [Show Content]

- Relationships

-  Notes
(0002025)
ddennedy (developer)
2009-01-03 07:40

Please provide more information about the arrangement you are describing. I tried to reproduce using the default transition kdenlive adds to a title to make it overlay video, and I could move the title to a different track with no problem (except, of course, the auto-transition not moving along with it).
(0002033)
griphiam (reporter)
2009-01-03 09:57

This may have been a combination of a bunch of factors. The file had many "floating" transitions that I wasn't able to remove (had to go into the xml manually and delete all the transitions and reapply them).

I can reproduce the crash doing the following steps:

1. Right click in "Project Tree" to add new "Title Clip"
2. Create title clip with text "This is a test"
3. Click and drag title to track 0
4. Click and drag clip to track 1 (not shifting time)
5. Click and drag clip to track 0 (not shifting time)

I can get it to crash every time this way.
(0002035)
griphiam (reporter)
2009-01-03 10:13

I uploaded a gdb output report from a crash done with the above steps (note, this time I had to repeat steps 4 & 5 about three times before it crashed... don't know if it had something to do with gdb being enabled).
(0002043)
ddennedy (developer)
2009-01-04 02:03

Still not able to reproduce using the above steps, even outside gdb.

Backtrace shows some crash in MLT that is difficult to understand because it is not obvious what the exact problem is or the conditions.
(0002046)
griphiam (reporter)
2009-01-04 09:22

Would it help if I recorded a video showing what I'm doing?
(0002052)
ddennedy (developer)
2009-01-04 20:25

The steps seem rather simple and straightforward, but a screencast will confirm. Thanks for the offer.
(0002056)
griphiam (reporter)
2009-01-04 22:04

Updated to the latest SVN last night -- the screencast is on blip.tv @

http://blip.tv/file/1635884/ [^]
(0002058)
ddennedy (developer)
2009-01-05 00:35

The screencast confirms the simplicity of the steps. Still, I do not reproduce it. I even tried with the same project setting as you: HDV 720 25p. Now, I am updating kdenlive, it was about a week old... works here. I even tested in gdb.

I am testing on dual core x86. I will try to remember to test on my MacBook next time I boot into Linux on it. It is x86-64 dual core.
(0002060)
griphiam (reporter)
2009-01-05 02:37

I started kdenlive in ddd and started poking around. Here's what I'm seeing (All this is in reference to the MLT project)

In moving the clip, mlt is trying to update the alpha transition on the title clip.

In mlt_service.c::mlt_service_get_frame it's trying to get the frame that is attached to the transition.

It then goes into mlt_transition.c::transition_get_frame and in line 0000297 it supposed to grab the frame, however, the frame it grabs is null (in fact all the frames in that array are null). When it then proceeds to get the "last_track" property from the frame, it segfaults.

From this analysis, it looks like the Clip+Transition combination isn't being assembled correctly or from the documentation above the transition_get_frame function, that frame isn't in the cache, and it needs to be.

Anything you'd like me to try?
(0002061)
griphiam (reporter)
2009-01-05 02:57

That should be line 297 in the above note -- My setup is a quad-core x86, if that makes any difference.

I am actually getting the same behavior with regular clips (doing some general testing). I haven't checked if the core point is the same or not, but it looks to be tied to the logic to get transitions to follow the clip move. There also looks to be no correlation between transition length (either smaller or equal to clip size).

I'm going to do a new build later to see if that helps at all. Let me know if there is any thing else I should try or any more data I should send to you.
(0004980)
LeHomard (developer)
2010-04-10 21:27

Is the issue still present with version 0.7.7 or latest svn ? If the issue isn't confirmed I'll go ahead and close the bug report.
(0005025)
griphiam (reporter)
2010-04-12 08:51

Tested and I can no longer recreate issue. Recommend closing.

- Issue History
Date Modified Username Field Change
2009-01-03 05:18 griphiam New Issue
2009-01-03 05:18 griphiam Build/Install Method => Build Wizard
2009-01-03 07:40 ddennedy Note Added: 0002025
2009-01-03 07:40 ddennedy Status new => feedback
2009-01-03 09:57 griphiam Note Added: 0002033
2009-01-03 10:10 griphiam File Added: kbw.gdb.output.lXV26551
2009-01-03 10:12 griphiam File Added: gbd_output.txt
2009-01-03 10:13 griphiam Note Added: 0002035
2009-01-04 02:03 ddennedy Note Added: 0002043
2009-01-04 09:22 griphiam Note Added: 0002046
2009-01-04 20:25 ddennedy Note Added: 0002052
2009-01-04 22:04 griphiam Note Added: 0002056
2009-01-05 00:35 ddennedy Note Added: 0002058
2009-01-05 02:37 griphiam Note Added: 0002060
2009-01-05 02:57 griphiam Note Added: 0002061
2010-04-10 21:27 LeHomard Note Added: 0004980
2010-04-12 08:51 griphiam Note Added: 0005025
2010-04-12 08:51 griphiam Status feedback => new
2010-04-12 09:08 LeHomard Status new => resolved
2010-04-12 09:08 LeHomard Resolution open => fixed
2010-04-12 09:08 LeHomard Assigned To => LeHomard
2010-09-14 23:29 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker