Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000559KdenliveUser Interfacepublic2009-01-03 15:252009-02-03 02:22
Reporterthe-me 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.1 
Target VersionFixed in Version0.7.2 
Summary0000559: Blacklist codecs which is activateable about cmake
DescriptionHello,

I discussed with madsdyd, that it would be a nice idea to implement the following:

On most distribution packaging ffmpeg lacks the support of some more or less {de,en}coders. If e.g. the user installs now kdenlive from Debian main with the respective ffmpeg (which has some codecs not available) and tries to render the project e.g. as mpeg2 or mpeg layer 3 it will for the user silently fail.

My idea to solve this problem for distribution package users would be, to implement a hardcoded blacklist which will be activated in the code by using some cmake vars, which the packagers have to use.

The list may define some codecs and their props, which define if the codec couldn't be decoded or/and encoded.

For the user itself there may be two possible solutions to tell him, that the encoding/decoding of it is not supported with his installation:

1) Barking with a dialog at him if he selected one of the blacklisted ones
2) Just do not display them
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0002054)
ddennedy (developer)
2009-01-04 20:57

I reject this approach. My suggestion is for MLT's avformat consumer to have options to list codecs and formats available and simply hide the unavailable ones in the kdenlive render dialog and file dialog filters.
(0002085)
administrator (administrator)
2009-01-06 19:22

A filtering feature was now added to Kdenlive svn (requires latest MLT svn too). The rendering profiles that use an codec that is not available on the system will now be hidden from user view. Waiting for some feedback to close the bug.
(0002105)
madsdyd (administrator)
2009-01-11 22:28

Reminder sent to: the-me

Please confirm that functionality that meets your wish is now present (as of svn rev. 2875 in kdenlive, you need at least mlt svn rev. 1308).

(0002107)
jmpoure (developer)
2009-01-12 10:49
edited on: 2009-01-12 10:56

I think we can close this bug. In many countries, patents cannot apply on codecs because codecs are algorithms and there is also a right for interoperability, especialy when you need to use your camcorder. Therefore, there wron't be any more discussion about would-be patents, which are presently only claims in certain countries and do not apply everywhere. So the best approach is to list the available codecs in FFmpeg and avoid proposing non-present codecs.

(0002108)
jmpoure (developer)
2009-01-12 10:55

Closing bug.

- Issue History
Date Modified Username Field Change
2009-01-03 15:25 the-me New Issue
2009-01-03 15:25 the-me Build/Install Method => Distribution package
2009-01-04 20:57 ddennedy Note Added: 0002054
2009-01-06 19:22 administrator Note Added: 0002085
2009-01-06 19:22 administrator Status new => feedback
2009-01-11 22:28 madsdyd Note Added: 0002105
2009-01-12 10:49 jmpoure Note Added: 0002107
2009-01-12 10:51 jmpoure Summary Blacklist for patented codecs which is activateable about cmake => Blacklist codecs which is activateable about cmake
2009-01-12 10:52 jmpoure Description Updated
2009-01-12 10:52 jmpoure Description Updated
2009-01-12 10:54 jmpoure Note Edited: 0002107
2009-01-12 10:55 jmpoure Note Edited: 0002107
2009-01-12 10:55 jmpoure Note Added: 0002108
2009-01-12 10:56 jmpoure Note Edited: 0002107
2009-01-12 10:56 jmpoure Status feedback => resolved
2009-01-12 10:56 jmpoure Resolution open => fixed
2009-02-03 02:22 xzhayon Status resolved => closed
2009-02-03 02:22 xzhayon Fixed in Version => 0.7.2


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker