Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000605KdenliveUser Interfacepublic2009-01-24 13:202010-09-14 23:00
Reportermehow 
Assigned ToGranjow 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version8.10
Product Version0.7.1 
Target VersionFixed in Version0.7.8 
Summary0000605: Kdenlive takes 50% of the CPU when idle
DescriptionKdenlive 0.7.1 takes about 50% of my CPU when idle. This however is true only if the application window is active. Switching to another application reduces CPU usage to 0% (well, almost). This happens right after Kdenlive is started with no project loaded. I didn't have this problem with Kdenlive 0.6. I don't have it with other KDE4 applications either (tested with KAddressBook and KSnapshot).
Steps To ReproduceStart Kdenlive and watch CPU usage. Switch to another application to see it dropping.
Additional InformationMy laptop is a 2GHz Intel Pentium M with 2GB of RAM and ATI Mobility Radeon 9700 (fglrx).
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
(0002220)
ddennedy (developer)
2009-01-27 08:05

unable to reproduce. anyone else?
(0002224)
mehow (reporter)
2009-01-27 09:54

It was reported before in the forum (although I haven't seen it when I was reporting this bug).

http://kdenlive.org/forum/cpu-usage-always-100-after-launch-no-other-operations-it-normal#comment-2185 [^]

The only difference is that I don't have "blinking letters" effect. However the problem indeed disappears after importing a clip and dragging it to the timeline.
(0002475)
Julian (reporter)
2009-02-26 15:21
edited on: 2009-02-26 15:23

I have more or less the same problem here using this version of Kdenlive 0.7.2.1-0.0 from Debian Unstable. Howver, I do have the blinking underline and dragging a clip into the timeline doesn't reduce the load Kdenlive places on on Xorg.

Just opening Kdenlive and bringing the window into focus with mouse-focus takes the Xorg process up to 95-98% on this Core Duo 2.4Ghz machine. Bringing another window into focus sends Xorg down to 1-2% again.

Worth noting is that I don't run a Desktop Environment, preferring a light window manager.

I greatly looking forward to being able to produce videos with Kdenlive in future.

(0003085)
ddennedy (developer)
2009-06-03 08:40

unable to reproduce - needs confirmation after kde4 and kdenlive updates
(0005225)
Granjow (developer)
2010-05-28 17:58

Still able to reproduce, mehow?
(0005229)
mehow (reporter)
2010-05-28 19:33

No, I cannot reproduce it anymore with Kdenlive 0.7.7.1 on Ubuntu 10.04.
(0005230)
Granjow (developer)
2010-05-28 20:41

Okay, thanks for your reply, closing.

- Issue History
Date Modified Username Field Change
2009-01-24 13:20 mehow New Issue
2009-01-24 13:20 mehow Build/Install Method => 3rd party package
2009-01-27 08:05 ddennedy Note Added: 0002220
2009-01-27 09:54 mehow Note Added: 0002224
2009-02-26 15:21 Julian Note Added: 0002475
2009-02-26 15:23 Julian Note Edited: 0002475
2009-06-03 08:40 ddennedy Note Added: 0003085
2009-06-03 08:40 ddennedy Status new => feedback
2010-05-28 17:58 Granjow Note Added: 0005225
2010-05-28 18:12 Granjow Tag Attached: old
2010-05-28 19:33 mehow Note Added: 0005229
2010-05-28 19:33 mehow Status feedback => new
2010-05-28 20:41 Granjow Note Added: 0005230
2010-05-28 20:41 Granjow Status new => resolved
2010-05-28 20:41 Granjow Fixed in Version => Recent git
2010-05-28 20:41 Granjow Resolution open => unable to reproduce
2010-05-28 20:41 Granjow Assigned To => Granjow
2010-05-28 20:41 Granjow Tag Detached: old
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:00 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker