Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000065KdenliveUser Interfacepublic2008-01-10 22:422008-12-29 16:28
Reporterforthy 
Assigned To 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.7.0 beta 
Summary0000065: Adding too many clips at once hangs GUI
DescriptionI usually import video with dvgrab --autosplit, so I get quite a lot of short clips. If I try to add them all in one go, Kdenlive's GUI hangs after importing them. Up to one row of the file select dialog (18 files) works fine; I haven't tried where the exact limit is.

What's worse: Even by adding clips step by step (each time below the 0000007:0000018 files limit), and then saving the project, Kdenlive will hang next time when it loads the project. I've split up my project now into several small projects, but it sucks.
Additional InformationI'm using the current SVN (Jan 2008) version.
TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0000128)
Espinosa (reporter)
2008-01-11 00:21

This is a potential duplicate of 0000057.

The project loading process should be refactored. Better to run it in a separate thread. Big projects can take longer time to load, user should be informed what's happening, give GUI chance to redraw itself, prepare and init monitors etc.
(0001209)
cinephiliac (updater)
2008-11-14 09:17

Hi there Forthy,

If you are still having this problem, could you please post the version number of your Kdenlive? You can see this by going to the Help -> About Kdenlive menu option in Kdenlive. Due to large changes in the codebase between version 0.6 and 0.7 bugfixing has currently moved to the 0.7 version, as this fixes most known 0.5 / 0.6 bugs. If you are on a 0.7.x version of Kdenlive, then posting version numbers for your install of ffmpeg and MLT would also be useful. These can be found in one of two ways:

If you installed through your distro: Just look up these packages in your package manager (eg Adept, Synaptic etc). Usually there is a "More Info" or "Details" type of button which will let you see these numbers.

If you installed with the Kdenlive Builder Wizard (KBW), just navigate to the folder you normally run Kdenlive from and post the output of: ./kdenlive_start --version


Many thanks


Cinephiliac
(0001220)
forthy (reporter)
2008-11-15 14:52

Hi Cinephillac,

Just updated to 0.7.0, and adding 172 clips in one go did work without problem. I consider this bug as fixed.
(0001224)
cinephiliac (updater)
2008-11-16 11:14

Glad to hear it.

Thanks for filing and feel free to let us know if you find anything else. I dare say you'll get a faster response from now on!

Cinephiliac

- Issue History
Date Modified Username Field Change
2008-01-10 22:42 forthy New Issue
2008-01-11 00:21 Espinosa Note Added: 0000128
2008-11-14 09:17 cinephiliac Note Added: 0001209
2008-11-14 09:17 cinephiliac Status new => feedback
2008-11-14 09:17 cinephiliac Additional Information Updated
2008-11-15 14:52 forthy Note Added: 0001220
2008-11-16 11:14 cinephiliac Note Added: 0001224
2008-11-16 11:14 cinephiliac Status feedback => resolved
2008-11-16 11:14 cinephiliac Resolution open => fixed
2008-12-22 22:12 madsdyd Fixed in Version => 0.7.0 beta
2008-12-29 16:28 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker