Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000657KdenliveRenderingpublic2009-02-03 12:022009-07-01 22:07
Reporteropensourcecat 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version 
Summary0000657: When exportin with one of the theora presets the export process crashes
DescriptionWhen exporting to Theora preset the render process crashes and aborts the rendering. This happens only if i try to export the clip including audio.

If i try to render the project without audio it works fine.
FFmpeg r16949
MLT r1334
Kdenlive r3027
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filestxt file icon kdenlive_render.txt [^] (3,506 bytes) 2009-02-03 12:02 [Show Content]

- Relationships
duplicate of 0000465closedddennedy exporting to ogg theora 720x576 blocks system 

-  Notes
(0002344)
opensourcecat (reporter)
2009-02-03 12:04

More:
If i try to export a clip with ffmpeg it works even with audio:

ffmpeg -i ./capture001.dv -acodec vorbis -ab 128k -ar 44100 -vcodec libtheora -r 25 -minrate 0 -b 1000k -aspect 4:3 -s 720x576 ./test.ogg
(0002470)
administrator (administrator)
2009-02-25 10:33

Do you still have this issue?

The only difference I can see is that when rendering through FFmpeg, you define a frame rate. Could you try to edit the theora rendering profile in Kdenlive and add " r=25" to see if rendering works better?
(0002471)
opensourcecat (reporter)
2009-02-25 16:23
edited on: 2009-02-25 16:33

Yes. The issue is still here. FFmpeg, MLT and Kdenlive updated today.

Theora exports doesn't crashes anymore but occupies 100% cpu(s) while rendering and produces a broken file, even if i add "r=25":

tore@tore-casa:~/kdenlive> mediainfo untitled.ogg
General
Complete name : untitled.ogg
Format : OGG
File size : 245 KiB

Video
ID : 0 (0x0)
Format : Theora
Bit rate : 1 000 Kbps
Width : 720 pixels
Height : 576 pixels
Display aspect ratio : 5/4
Frame rate : 25.000 fps
Standard : PAL
Bits/(Pixel*Frame) : 0.096
Writing library : libTheora 3.2.1 (UTC 2008-10-20)

Audio
ID : 1 (0x1)
Format : Vorbis
Channel(s) : 2 channels
Sampling rate : 44.1 KHz

If i try to play the result file with ffplay i can only listen the audio. No video window is opened.
If i try it with inigo i can just see the first frame of the video, but no audio.

FFmpeg is compiled with --enable-libtheora and libtheora version is 1.0

(0003190)
ddennedy (developer)
2009-06-13 10:27

Fixed in MLT git commit 21603d5.

- Issue History
Date Modified Username Field Change
2009-02-03 12:02 opensourcecat New Issue
2009-02-03 12:02 opensourcecat File Added: kdenlive_render.txt
2009-02-03 12:02 opensourcecat Build/Install Method => Manual build from SVN
2009-02-03 12:04 opensourcecat Note Added: 0002344
2009-02-25 10:33 administrator Note Added: 0002470
2009-02-25 10:33 administrator Status new => feedback
2009-02-25 16:23 opensourcecat Note Added: 0002471
2009-02-25 16:33 opensourcecat Note Edited: 0002471
2009-06-03 06:53 ddennedy Relationship added duplicate of 0000465
2009-06-13 10:27 ddennedy Note Added: 0003190
2009-06-13 10:27 ddennedy Status feedback => resolved
2009-06-13 10:27 ddennedy Resolution open => fixed
2009-06-13 10:27 ddennedy Assigned To => ddennedy
2009-06-19 09:32 xzhayon Status resolved => assigned
2009-06-19 09:32 xzhayon Duplicate ID 0 => 465
2009-06-19 09:32 xzhayon Status assigned => resolved
2009-06-19 09:32 xzhayon Resolution fixed => duplicate
2009-06-27 02:17 j-b-m Target Version => 0.7.5
2009-07-01 22:07 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker