Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000672KdenliveRenderingpublic2009-02-08 23:272009-06-18 01:51
Reporterrubikcube 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.2 
Target VersionFixed in Version0.7.3 
Summary0000672: Deinterlacing in one half of the image
DescriptionIn this version of kdenlive (0.7.2.1, on gentoo amd64, mlt:0.3.6), interlaced images are deinterlaced in the left half. I think this effect is best described by the attached screenshot, it also appears in rendered videos, not only in the preview window.

It doesn't matter which setting (progressive or interlaced) is chosen in the render dialog.
Additional InformationThe sample video for the screenshot was taken from
http://www.kdenlive.org/contribution-manual/footage: [^]
http://www.kdenlive.org/videos/rawdvpalwide-test-1.dv [^]
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Filespng file icon de_interlacing.png [^] (771,952 bytes) 2009-02-08 23:27

- Relationships

-  Notes
(0002394)
ddennedy (developer)
2009-02-10 08:04

This is fixed in MLT SVN r1348.
Please update, test and confirm when you get a chance.
(0002398)
rubikcube (reporter)
2009-02-10 13:34

There's no difference between the two image halves any more (that's expected and good) for me.

But the whole movie seems to be deinterlaced, no matter with which preferences or target format I render it. Is that intentional? If so, ok.
(0002399)
ddennedy (developer)
2009-02-10 21:01

It depends upon the project settings, the arrangement of the timeline, and the render settings. If your project is set for DV PAL Widescreen and all you do is place a DV PAL Widescreen clip on the timeline and render it to a DV PAL Widescreen file, the result should be interlaced. I just tested this with NTSC 4:3. The preview window in kdenlive is currently hardcoded to deinterlace because computer monitors are always progressive, but the rendered output should be interlace in the scenario I describe. After that, maybe we can look at what you are doing that might cause an automatic deinterlace such as compositing, some filters, or changing vertical resolution.
(0002401)
rubikcube (reporter)
2009-02-11 01:03

OK, you were right about working always in the same settings (PAL 16:9 for input, project and rendering). It's fine for me to close this bug as fixed. Keep up the good work!

- Issue History
Date Modified Username Field Change
2009-02-08 23:27 rubikcube New Issue
2009-02-08 23:27 rubikcube File Added: de_interlacing.png
2009-02-08 23:27 rubikcube Build/Install Method => Other Method?
2009-02-09 09:28 ddennedy Status new => assigned
2009-02-09 09:28 ddennedy Assigned To => ddennedy
2009-02-10 08:04 ddennedy Note Added: 0002394
2009-02-10 08:04 ddennedy Status assigned => feedback
2009-02-10 13:34 rubikcube Note Added: 0002398
2009-02-10 21:01 ddennedy Note Added: 0002399
2009-02-11 01:03 rubikcube Note Added: 0002401
2009-02-11 01:31 ddennedy Status feedback => resolved
2009-02-11 01:31 ddennedy Fixed in Version => Recent git
2009-02-11 01:31 ddennedy Resolution open => fixed
2009-04-15 13:07 madsdyd Fixed in Version Recent git => 0.7.3
2009-06-18 01:51 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker