Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000691KdenliveBuild Systempublic2009-02-23 20:062009-06-18 01:51
Reporterspansky_khroroll 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.1 
Target VersionFixed in Version0.7.3 
Summary0000691: It's impossible to run the programm. It crashes before start
DescriptionInstalled in OpenSuse with yast2, from ftp/skynet.be/pub/packman/suse/11.0

Additional InformationReport:

[?1034h[Thread debugging using libthread_db enabled]
[New Thread 0xb637c6d0 (LWP 5818)]
[KCrash handler]
0000006 0xb749b607 in pthread_join () from /lib/libpthread.so.0
0000007 0xb4b9d39e in ?? () from /usr/lib/mlt/libmltsdl.so
#0 0xffffe430 in __kernel_vsyscall ()





Repositories installed:

    Qt4-x11-tools
        libqt4-x11
        libqt4-sql
        libqt4-qt3support
        libqt4
        libqt4-devel
        libpoppler-qt4-3
        mlt
        mlt++
        mlt-devel
        mlt++-devel

        Gtk
        Gtk-devel
        qdvdauthor
    
    *
          o Gdk-Pixbuf (gdk-pixbuf, gdk-pixbuf-dev) (ya no es necesario)
          o libsamplerate (libsamplerate, libsamplerate-dev)
          o OGG (libogg, libogg-dev)
          o Vorbis (libvorbis, libvorbis-dev)
          o libdv (libdv, libdv-dev)
          o Ladspa (ladspa-sdk)
          o libJack (libjack-dev)
          o Ladspa plugins (swh-plugins)
          o SOX (sox, sox-dev)
          o libXML2 (libxml2, libxml2-dev)
          o libmad (libmad-dev)


TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0002453)
administrator (administrator)
2009-02-23 21:36

Which version of MLT is installed ? Also, MLT requires FFmpeg's libavformat to play videos...

Can you play a clip using MLT's command line player:

inigo video.mpg

You probably miss some libraries...
(0002463)
spansky_khroroll (reporter)
2009-02-24 13:42

libavformat52 version 0.4.9.15594svn is installed

MLT-unstable Version 0.3.1.1218.pm.svn20081030 is installed. It has been installed because MLT didn't serve for kde4-kdenlive

The command inigo video.mpg works correctly. And kdenlive continues crashing.
(0002464)
administrator (administrator)
2009-02-24 14:05

You need MLT 0.3.4 to run Kdenlive 0.7.1 correctly...
Please remove your old MLT and MLT++ and update to something newer.
(0002467)
spansky_khroroll (reporter)
2009-02-24 19:42

thank you very much for your patience.

Packets re-installed:

kdenlive 0.7.1-0.pm.2-i586

mlt 0.3.6-0.pm.1.i586.rpm
mlt-devel 0.3.6-0.pm.1.i586.rpm

java-mlt++-0.3.6-0.pm.1.i586.rpm
libmlt++1-0.3.6-0.pm.1.i586.rpm
perl-mlt++-0.3.6-0.pm.1.i586.rpm
python-mlt++-0.3.6-0.pm.1.i586.rpm
tcl-mlt++-0.3.6-0.pm.1.i586.rpm
mlt++-devel-0.3.6-0.pm.1.i586.rpm

the problem has not dissapeared: the crash is exactly the same as before.
(0002468)
spansky_khroroll (reporter)
2009-02-24 20:09

I have run it from console. New messages appear:

kdenlive(3007) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
mlt_repository_init: failed to dlopen /usr/lib/mlt/libmltavformat.so
  (/usr/lib/mlt/libmltavformat.so: undefined symbol: av_set_string3)
kdenlive(3007) initEffects::parseEffectFiles: // INIT EFFECT SEARCH
kdenlive(3007) Render::Render: ////////// USING PROFILE: /home/Spansky/.kde4/share/apps/kdenlive/profiles//customprofile0
kdenlive(3007) Monitor::Monitor: /////// BUILDING MONITOR, ID: 62914857
kdenlive(3007) Render::Render: ////////// USING PROFILE: /home/Spansky/.kde4/share/apps/kdenlive/profiles//customprofile0
kdenlive(3007) Monitor::Monitor: /////// BUILDING MONITOR, ID: 62914953
kdenlive(3007) RecMonitor::RecMonitor: /////// BUILDING MONITOR, ID: 62914990
QStatusBar::insertPermanentWidget: Index out of range (5), appending widget
QStatusBar::insertPermanentWidget: Index out of range (7), appending widget
Object::connect: No such signal KActionCollection::actionHovered(QAction*)
Object::connect: (sender name: 'KXMLGUIClient-KActionCollection')
kdenlive(3007) ProfilesDialog::getVideoProfile: // WARNING, COULD NOT FIND PROFILE "/home/Spansky/.kde4/share/apps/kdenlive/profiles//customprofile0"
kdenlive(3007) KdenliveDoc::setProfilePath: KDEnnlive document, init timecode from path: "/home/Spansky/.kde4/share/apps/kdenlive/profiles//customprofile0" , 25
kdenlive(3007) KdenliveDoc::KdenliveDoc: KDEnnlive document, init timecode: 25
kdenlive(3007) Render::setSceneList: // NEW SCENE LIST DURATION SET TO: 0
Failed to initialize SDL: No available video device
kdenlive(3007) Render::producersList: // PARSING SCENE TRACK: 1 , CLIPS: 0
kdenlive(3007) Render::producersList: // PARSING SCENE TRACK: 2 , CLIPS: 0
kdenlive(3007) Render::producersList: // PARSING SCENE TRACK: 3 , CLIPS: 0
kdenlive(3007) Render::producersList: // PARSING SCENE TRACK: 4 , CLIPS: 0
kdenlive(3007) Render::producersList: // PARSING SCENE TRACK: 5 , CLIPS: 0
kdenlive(3007) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK  4 , DURATION: 0
kdenlive(3007) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK  3 , DURATION: 0
kdenlive(3007) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK  2 , DURATION: 0
kdenlive(3007) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK  1 , DURATION: 0
kdenlive(3007) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK  0 , DURATION: 0
kdenlive(3007) TrackView::parseDocument: /////////// TOTAL PROJECT DURATION: 300
kdenlive(3007) MainWindow::connectDocument: /////////////////// CONNECTING DOC TO PROJECT VIEW ////////////////
kdenlive(3007) Render::stop: ///////////// RENDER STOPPED: "project"
KCrash: Application 'kdenlive' crashing...
sock_file=/home/Spansky/.kde4/socket-linux-iy5j/kdeinit4__0
(0002469)
administrator (administrator)
2009-02-25 10:05

mlt_repository_init: failed to dlopen /usr/lib/mlt/libmltavformat.so

Looks like your FFmpeg version (libavformat) is not compatible with this MLT version... is there an updated version ?
(0002472)
spansky_khroroll (reporter)
2009-02-25 20:06

I've re-install ffmpeg.

No succeed.

Here is the message.

kdenlive(1590) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
kdenlive(1590) initEffects::parseEffectFiles: // INIT EFFECT SEARCH
kdenlive(1590) Render::Render: ////////// USING PROFILE: /home/Spansky/.kde4/share/apps/kdenlive/profiles//customprofile0
kdenlive(1590) Monitor::Monitor: /////// BUILDING MONITOR, ID: 58720553
kdenlive(1590) Render::Render: ////////// USING PROFILE: /home/Spansky/.kde4/share/apps/kdenlive/profiles//customprofile0
kdenlive(1590) Monitor::Monitor: /////// BUILDING MONITOR, ID: 58720649
kdenlive(1590) RecMonitor::RecMonitor: /////// BUILDING MONITOR, ID: 58720686
QStatusBar::insertPermanentWidget: Index out of range (5), appending widget
QStatusBar::insertPermanentWidget: Index out of range (7), appending widget
Object::connect: No such signal KActionCollection::actionHovered(QAction*)
Object::connect: (sender name: 'KXMLGUIClient-KActionCollection')
kdenlive(1590) ProfilesDialog::getVideoProfile: // WARNING, COULD NOT FIND PROFILE "/home/Spansky/.kde4/share/apps/kdenlive/profiles//customprofile0"
kdenlive(1590) KdenliveDoc::setProfilePath: KDEnnlive document, init timecode from path: "/home/Spansky/.kde4/share/apps/kdenlive/profiles//customprofile0" , 25
kdenlive(1590) KdenliveDoc::KdenliveDoc: KDEnnlive document, init timecode: 25
kdenlive(1590) Render::setSceneList: // NEW SCENE LIST DURATION SET TO: 0
Failed to initialize SDL: No available video device
kdenlive(1590) Render::producersList: // PARSING SCENE TRACK: 1 , CLIPS: 0
kdenlive(1590) Render::producersList: // PARSING SCENE TRACK: 2 , CLIPS: 0
kdenlive(1590) Render::producersList: // PARSING SCENE TRACK: 3 , CLIPS: 0
kdenlive(1590) Render::producersList: // PARSING SCENE TRACK: 4 , CLIPS: 0
kdenlive(1590) Render::producersList: // PARSING SCENE TRACK: 5 , CLIPS: 0
kdenlive(1590) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK  4 , DURATION: 0
kdenlive(1590) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK  3 , DURATION: 0
kdenlive(1590) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK  2 , DURATION: 0
kdenlive(1590) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK  1 , DURATION: 0
kdenlive(1590) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK  0 , DURATION: 0
kdenlive(1590) TrackView::parseDocument: /////////// TOTAL PROJECT DURATION: 300
kdenlive(1590) MainWindow::connectDocument: /////////////////// CONNECTING DOC TO PROJECT VIEW ////////////////
kdenlive(1590) Render::stop: ///////////// RENDER STOPPED: "project"
KCrash: Application 'kdenlive' crashing...
sock_file=/home/Spansky/.kde4/socket-linux-iy5j/kdeinit4__0
(0002473)
administrator (administrator)
2009-02-25 20:11

Failed to initialize SDL: No available video device

There seems to be an issue with SDL now. Make sure you have installed the libsdl, libsdl-image and libsdl-alsa packages. You can also try to delete Kdenlive's config file: $HOME/.kde/share/config/kdenliverc
(0002476)
spansky_khroroll (reporter)
2009-02-26 22:08

It's impossible to install those packages in OpenSuse 11.0.

I've deleted that config file, and nothing has changed. The message is the same.
(0002477)
administrator (administrator)
2009-02-26 22:49

A quick search on the openSuse pages shows that the following packages are available(*): SDL, SDL_image, probably the SDL_mixer package provides sound output.

(*)http://software.opensuse.org/search?baseproject=openSUSE:11.0&p=1&q=sdl [^]
(0002478)
spansky_khroroll (reporter)
2009-02-27 10:48

I´m travelling, so I´ll do it on Monday.
(0002490)
spansky_khroroll (reporter)
2009-03-03 11:23

I´ve installed what you suggested.

Nothing new: kdenlive crashes at the startup.

I give up. I´m going to update OpenSuse 11.0 to OpenSuse 11.1. If nothing changes, I´ll have to continue working video editing with WinXP.

Thank you very much for your efforts.
(0002533)
spansky_khroroll (reporter)
2009-03-11 21:13

¡¡ Solved !!

We must remember the program crashed for all users I have in my system.

I've upgraded to OpenSuse 11.1 (I don't know if it's necessary).

Later, I've installed kdenlive as it's explained in this web:

http://forums.opensuse.org/how-faq-read-only/unreviewed-how-faq/403782-kdenlive-0-7-1-svn-installation-howto-opensuse-11-1-a.html [^]

The programm didn't run with my user (the original in which i found out all these problems), but it run on others.

I've changed my user, I deleted the original one and everything is correct.

Thank you very much for your efforts. Thanks a lot.

- Issue History
Date Modified Username Field Change
2009-02-23 20:06 spansky_khroroll New Issue
2009-02-23 20:06 spansky_khroroll Build/Install Method => Distribution package
2009-02-23 21:36 administrator Note Added: 0002453
2009-02-24 13:42 spansky_khroroll Note Added: 0002463
2009-02-24 14:05 administrator Note Added: 0002464
2009-02-24 14:06 administrator Status new => feedback
2009-02-24 19:42 spansky_khroroll Note Added: 0002467
2009-02-24 20:09 spansky_khroroll Note Added: 0002468
2009-02-25 10:05 administrator Note Added: 0002469
2009-02-25 20:06 spansky_khroroll Note Added: 0002472
2009-02-25 20:11 administrator Note Added: 0002473
2009-02-26 22:08 spansky_khroroll Note Added: 0002476
2009-02-26 22:49 administrator Note Added: 0002477
2009-02-27 10:48 spansky_khroroll Note Added: 0002478
2009-03-03 11:23 spansky_khroroll Note Added: 0002490
2009-03-11 21:13 spansky_khroroll Note Added: 0002533
2009-03-13 16:44 administrator Status feedback => resolved
2009-03-13 16:44 administrator Resolution open => fixed
2009-03-13 16:44 administrator Fixed in Version => Recent git
2009-04-15 13:07 madsdyd Fixed in Version Recent git => 0.7.3
2009-06-18 01:51 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker