Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000696KdenliveFile Loadingpublic2009-02-28 06:332010-09-14 23:00
Reportertesterus 
Assigned ToGranjow 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version0.7.2 
Target VersionFixed in Version0.7.8 
Summary0000696: crash when loading file
DescriptionWhen I try to open the project I get "Document project folder is invalid, setting it to the default one: /home/helge/kdenlive" and kdenlive crashes.

Application: Kdenlive (kdenlive), signal SIGSEGV
0x00007f8a7a949c31 in nanosleep () from /lib64/libc.so.6
Current language: auto; currently c
[Current thread is 1 (Thread 0x7f8a7e92e700 (LWP 24313))]

Thread 1 (Thread 0x7f8a7e92e700 (LWP 24313)):
[KCrash Handler]
0000005 mlt_properties_get_data (this=0x0, name=0x7f8a7e547d64 "_profile", length=0x0) at mlt_properties.c:348
0000006 0x00007f8a7e53e5a9 in mlt_producer_get_fps (this=0x0) at mlt_producer.c:383
0000007 0x00000000004c231f in Render::setSceneList (this=0x226cb40, playlist=<value optimized out>, position=0) at /usr/src/debug/kdenlive-0.7.2.1/src/renderer.cpp:832
0000008 0x00000000004da878 in KdenliveDoc::setSceneList (this=0x28b3ce0) at /usr/src/debug/kdenlive-0.7.2.1/src/kdenlivedoc.cpp:227
0000009 0x00000000004eb356 in TrackView (this=0x2832f80, doc=0x28b3ce0, parent=<value optimized out>) at /usr/src/debug/kdenlive-0.7.2.1/src/trackview.cpp:81
0000010 0x000000000048c243 in MainWindow::doOpenFile (this=0x1edd260, url=@0x7fff86965670, stale=0x28f9980) at /usr/src/debug/kdenlive-0.7.2.1/src/mainwindow.cpp:1271
0000011 0x000000000048d887 in MainWindow::openFile (this=0x1edd260, url=@0x7fff86965670) at /usr/src/debug/kdenlive-0.7.2.1/src/mainwindow.cpp:1256
0000012 0x000000000048da55 in MainWindow::openFile (this=0x1edd260) at /usr/src/debug/kdenlive-0.7.2.1/src/mainwindow.cpp:1209
0000013 0x0000000000495920 in MainWindow::qt_metacall (this=0x1edd260, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff869658c0)
    at /usr/src/debug/kdenlive-0.7.2.1/build/src/cmake_bindir/mainwindow.moc:248
0000014 0x00007f8a7c334822 in QMetaObject::activate (sender=0x2602370, from_signal_index=<value optimized out>, to_signal_index=6, argv=0x2916200) at kernel/qobject.cpp:3055
0000015 0x00007f8a7b569077 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
0000016 0x00007f8a7b56a4f4 in QAction::activate (this=0x2602370, event=<value optimized out>) at kernel/qaction.cpp:1155
0000017 0x00007f8a7b97b98c in QMenuPrivate::activateCausedStack (this=0x26388e0, causedStack=@0x7fff869659e0, action=0x2602370, action_e=QAction::Trigger, self=16) at widgets/qmenu.cpp:957
0000018 0x00007f8a7b98197e in QMenuPrivate::activateAction (this=0x26388e0, action=0x2602370, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1053
0000019 0x00007f8a7dd39864 in KMenu::mouseReleaseEvent (this=0x260e8c0, e=0x7fff869663a0) at /usr/src/debug/kdelibs-4.2.0/kdeui/widgets/kmenu.cpp:454
0000020 0x00007f8a7b5c011f in QWidget::event (this=0x260e8c0, event=0x7fff869663a0) at kernel/qwidget.cpp:7511
0000021 0x00007f8a7b98413b in QMenu::event (this=0x260e8c0, e=0x7fff869663a0) at widgets/qmenu.cpp:2346
0000022 0x00007f8a7b56f05d in QApplicationPrivate::notify_helper (this=0x1e03a10, receiver=0x260e8c0, e=0x7fff869663a0) at kernel/qapplication.cpp:4051
0000023 0x00007f8a7b5779c7 in QApplication::notify (this=<value optimized out>, receiver=0x260e8c0, e=0x7fff869663a0) at kernel/qapplication.cpp:3753
0000024 0x00007f8a7dc8115e in KApplication::notify (this=0x7fff869672d0, receiver=0x260e8c0, event=0x7fff869663a0) at /usr/src/debug/kdelibs-4.2.0/kdeui/kernel/kapplication.cpp:307
0000025 0x00007f8a7c31edac in QCoreApplication::notifyInternal (this=0x7fff869672d0, receiver=0x260e8c0, event=0x7fff869663a0) at kernel/qcoreapplication.cpp:597
0000026 0x00007f8a7b576bd8 in QApplicationPrivate::sendMouseEvent (receiver=0x260e8c0, event=0x7fff869663a0, alienWidget=0x0, nativeWidget=0x260e8c0, buttonDown=<value optimized out>,
    lastMouseReceiver=@0x7f8a7bfaecb0) at ../../src/corelib/kernel/qcoreapplication.h:211
0000027 0x00007f8a7b5e0834 in QETWidget::translateMouseEvent (this=0x260e8c0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4348
0000028 0x00007f8a7b5df2e8 in QApplication::x11ProcessEvent (this=0x7fff869672d0, event=0x7fff86966ee0) at kernel/qapplication_x11.cpp:3532
0000029 0x00007f8a7b606a04 in x11EventSourceDispatch (s=0x1e07840, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:141
0000030 0x00007f8a77023e31 in IA__g_main_context_dispatch (context=0x1e06560) at gmain.c:1814
0000031 0x00007f8a770274e0 in g_main_context_iterate (context=0x1e06560, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2448
0000032 0x00007f8a7702767c in IA__g_main_context_iteration (context=0x1e06560, may_block=1) at gmain.c:2511
0000033 0x00007f8a7c34842f in QEventDispatcherGlib::processEvents (this=0x1e004d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:318
0000034 0x00007f8a7b60618f in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:197
0000035 0x00007f8a7c31d652 in QEventLoop::processEvents (this=<value optimized out>, flags={i = -2036960816}) at kernel/qeventloop.cpp:144
0000036 0x00007f8a7c31da1d in QEventLoop::exec (this=0x7fff86967210, flags={i = -2036960736}) at kernel/qeventloop.cpp:195
0000037 0x00007f8a7c31fce4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:875
0000038 0x0000000000485b8d in main (argc=1, argv=0x7fff869676b8) at /usr/src/debug/kdenlive-0.7.2.1/src/main.cpp:81
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon kdenlive-test.kdenlive [^] (729 bytes) 2009-02-28 06:33

- Relationships

-  Notes
(0004958)
Granjow (developer)
2010-04-10 13:17

Still valid?
If yes, could you upload the project file?
(0005200)
Granjow (developer)
2010-05-24 11:45

No reply, closing.

- Issue History
Date Modified Username Field Change
2009-02-28 06:33 testerus New Issue
2009-02-28 06:33 testerus File Added: kdenlive-test.kdenlive
2009-02-28 06:33 testerus Build/Install Method => Distribution package
2010-04-10 13:17 Granjow Note Added: 0004958
2010-04-10 13:17 Granjow Assigned To => Granjow
2010-04-10 13:17 Granjow Status new => feedback
2010-04-10 13:33 Granjow Tag Attached: old
2010-05-24 11:45 Granjow Note Added: 0005200
2010-05-24 11:45 Granjow Status feedback => resolved
2010-05-24 11:45 Granjow Fixed in Version => Recent git
2010-05-24 11:45 Granjow Resolution open => unable to reproduce
2010-05-28 18:16 Granjow Tag Detached: old
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:00 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker