Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000704KdenliveUser Interfacepublic2009-03-06 22:582010-04-10 13:30
Reporterkarlhiramoto 
Assigned ToGranjow 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version0.7.2 
Target VersionFixed in Version0.7.3 
Summary0000704: segfault in MarkerDialog
DescriptionI just imported a video and tried to add a marker.

Using QT 4.5 with KDE 4.2.1 Kdenlive 0.7.2.1 on gentoo linux.

Application: Kdenlive (kdenlive), signal SIGSEGV
[Current thread is 0 (LWP 3693)]

Thread 4 (Thread 0xb1f11b90 (LWP 3696)):
#0 0xffffe424 in __kernel_vsyscall ()
#1 0xb68b2311 in select () from /lib/libc.so.6
0000002 0xb7423d9d in QProcessManager::run (this=0x8343ef0) at io/qprocess_unix.cpp:305
0000003 0xb7352e71 in QThreadPrivate::start (arg=0x8343ef0) at thread/qthread_unix.cpp:189
0000004 0xb72f1160 in start_thread (arg=0xb1f11b90) at pthread_create.c:297
0000005 0xb68b8f0e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xaeb23b90 (LWP 3818)):
#0 0xffffe424 in __kernel_vsyscall ()
#1 0xb72f4f12 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0xb7f8a104 in mlt_consumer_get_frame (this=0x8488aa8) at mlt_consumer.c:497
0000003 0xb7f8a378 in mlt_consumer_rt_frame (this=0x8488aa8) at mlt_consumer.c:895
0000004 0xb2e26e38 in consumer_thread (arg=0x8488aa8) at consumer_sdl_still.c:558
0000005 0xb72f1160 in start_thread (arg=0xaeb23b90) at pthread_create.c:297
0000006 0xb68b8f0e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xadd0fb90 (LWP 3819)):
#0 0xffffe424 in __kernel_vsyscall ()
#1 0xb72f4be5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0xb2e264fb in consumer_thread (arg=0x8ad34e0) at consumer_sdl_preview.c:381
0000003 0xb72f1160 in start_thread (arg=0xadd0fb90) at pthread_create.c:297
0000004 0xb68b8f0e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5f898e0 (LWP 3693)):
[KCrash Handler]
0000006 QHash<QString, QDomNodePrivate*>::findNode (this=0x8f2d314, akey=@0xbfae4acc, ahp=0x0) at ../../include/QtCore/../../src/corelib/tools/qhash.h:218
0000007 0xb7768873 in QDomNamedNodeMapPrivate::setNamedItem (this=0x8f2d310, arg=0x8ccae40) at ../../include/QtCore/../../src/corelib/tools/qhash.h:592
0000008 0xb7768b99 in QDomNamedNodeMapPrivate::clone (this=0x8fbb000, p=0x8f2d2c0) at dom/qdom.cpp:3071
0000009 0xb7768c0c in QDomElementPrivate (this=0x8f2d2c0, n=0x8fbcb50, deep=<value optimized out>) at dom/qdom.cpp:4424
0000010 0xb7768c96 in QDomDocumentPrivate::importNode (this=0x8cd2148, importedNode=0x8fbcb50, deep=<value optimized out>) at dom/qdom.cpp:6405
0000011 0xb776d822 in QDomDocument::importNode (this=0xbfae4c14, importedNode=@0xbfae4c34, deep=<value optimized out>) at dom/qdom.cpp:7111
0000012 0x08250c48 in MarkerDialog (this=0xbfae4c98, clip=0x8b26af8, t=
        {t = {m_time = -0.059182904623549554, static s_delta = 1.0000000000000001e-05}, c = {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 19183}, alloc = 0, size = 0, data = 0x833933a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, static shared_empty = {ref = {_q_value = 109}, alloc = 0, size = 0, data = 0xb74f946e, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0xbfae4da8, static codecForCStrings = 0x0}}, tc=
      {m_format = 3215871288, m_dropFrame = 168, m_displayedFramesPerSecond = 138623392}, caption=@0xbfae4da8, parent=0x84339a0)
    at /var/tmp/portage/media-video/kdenlive-0.7.2.1/work/kdenlive-0.7.2.1/src/markerdialog.cpp:44
0000013 0x080c2bdf in MainWindow::slotAddClipMarker (this=0x84339a0) at /var/tmp/portage/media-video/kdenlive-0.7.2.1/work/kdenlive-0.7.2.1/src/mainwindow.cpp:1766
0000014 0x080c364d in MainWindow::qt_metacall (this=0x84339a0, _c=QMetaObject::InvokeMetaMethod, _id=42, _a=0xbfae4f3c)
    at /var/tmp/portage/media-video/kdenlive-0.7.2.1/work/kdenlive_build/src/cmake_bindir/mainwindow.moc:283
0000015 0xb745aca9 in QMetaObject::activate (sender=0x89d1c28, from_signal_index=<value optimized out>, to_signal_index=6, argv=0xbfae4f3c) at kernel/qobject.cpp:3057
0000016 0xb745b031 in QMetaObject::activate (sender=0x89d1c28, m=0x8339400, from_local_signal_index=1, to_local_signal_index=2, argv=0xbfae4f3c) at kernel/qobject.cpp:3154
0000017 0xb6b6c4f2 in QAction::triggered (this=0x89d1c28, _t1=false) at .moc/debug-shared/moc_qaction.cpp:236
0000018 0xb6b6d3b3 in QAction::activate (this=0x89d1c28, event=QAction::Trigger) at kernel/qaction.cpp:1160
0000019 0xb6fc711a in QMenuPrivate::activateCausedStack (this=0x8a142e8, causedStack=@0xbfae5018, action=0x89d1c28, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:962
0000020 0xb6fce019 in QMenuPrivate::activateAction (this=0x8a142e8, action=0x89d1c28, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1058
0000021 0xb6fceda6 in QMenu::mouseReleaseEvent (this=0x8a13b08, e=0xbfae573c) at widgets/qmenu.cpp:2252
0000022 0xb7e0d28e in KMenu::mouseReleaseEvent (this=0x8a13b08, e=0xbfae573c) at /var/tmp/portage/kde-base/kdelibs-4.2.1/work/kdelibs-4.2.1/kdeui/widgets/kmenu.cpp:454
0000023 0xb6bcd0aa in QWidget::event (this=0x8a13b08, event=0xbfae573c) at kernel/qwidget.cpp:7516
0000024 0xb6fcf861 in QMenu::event (this=0x8a13b08, e=0xbfae573c) at widgets/qmenu.cpp:2351
0000025 0xb6b7278c in QApplicationPrivate::notify_helper (this=0x8340f70, receiver=0x8a13b08, e=0xbfae573c) at kernel/qapplication.cpp:4084
0000026 0xb6b7be7c in QApplication::notify (this=0xbfae5f68, receiver=0x8a13b08, e=0xbfae573c) at kernel/qapplication.cpp:3786
0000027 0xb7d337d4 in KApplication::notify (this=0xbfae5f68, receiver=0x8a13b08, event=0xbfae573c) at /var/tmp/portage/kde-base/kdelibs-4.2.1/work/kdelibs-4.2.1/kdeui/kernel/kapplication.cpp:307
0000028 0xb74444c2 in QCoreApplication::notifyInternal (this=0xbfae5f68, receiver=0x8a13b08, event=0xbfae573c) at kernel/qcoreapplication.cpp:598
0000029 0xb6b7aee0 in QApplicationPrivate::sendMouseEvent (receiver=0x8a13b08, event=0xbfae573c, alienWidget=0x0, nativeWidget=0x8a13b08, buttonDown=0xb72e7ae0, lastMouseReceiver=@0xb72e7ae4)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
0000030 0xb6be54bd in QETWidget::translateMouseEvent (this=0x8a13b08, event=0xbfae5c9c) at kernel/qapplication_x11.cpp:4359
0000031 0xb6be42e5 in QApplication::x11ProcessEvent (this=0xbfae5f68, event=0xbfae5c9c) at kernel/qapplication_x11.cpp:3543
0000032 0xb6c0c44a in x11EventSourceDispatch (s=0x8343d50, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000033 0xb61d80cf in IA__g_main_context_dispatch (context=0x8343058) at gmain.c:2144
0000034 0xb61db8ab in g_main_context_iterate (context=0x8343058, block=1, dispatch=1, self=0x8340b48) at gmain.c:2778
0000035 0xb61dba62 in IA__g_main_context_iteration (context=0x8343058, may_block=1) at gmain.c:2841
0000036 0xb746f479 in QEventDispatcherGlib::processEvents (this=0x833eb58, flags={i = -1079091624}) at kernel/qeventdispatcher_glib.cpp:323
0000037 0xb6c0bb96 in QGuiEventDispatcherGlib::processEvents (this=0x833eb58, flags={i = -1079091576}) at kernel/qguieventdispatcher_glib.cpp:202
0000038 0xb7442eab in QEventLoop::processEvents (this=0xbfae5ef0, flags={i = -1079091512}) at kernel/qeventloop.cpp:149
0000039 0xb744308a in QEventLoop::exec (this=0xbfae5ef0, flags={i = -1079091464}) at kernel/qeventloop.cpp:196
0000040 0xb7448211 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
0000041 0xb6b724a8 in QApplication::exec () at kernel/qapplication.cpp:3553
0000042 0x080a4fc5 in main (argc=6, argv=0xbfae60e4) at /var/tmp/portage/media-video/kdenlive-0.7.2.1/work/kdenlive-0.7.2.1/src/main.cpp:81

TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships
duplicate of 0000687closedj-b-m Qt 4.5: unable to save project 

-  Notes
(0002510)
administrator (administrator)
2009-03-08 00:07

Should now be fixed in svn

- Issue History
Date Modified Username Field Change
2009-03-06 22:58 karlhiramoto New Issue
2009-03-06 22:58 karlhiramoto Build/Install Method => Distribution package
2009-03-08 00:06 administrator Relationship added duplicate of 0000687
2009-03-08 00:07 administrator Note Added: 0002510
2009-03-08 00:07 administrator Status new => feedback
2010-04-10 13:29 Granjow Status feedback => resolved
2010-04-10 13:29 Granjow Fixed in Version => 0.7.3
2010-04-10 13:29 Granjow Resolution open => duplicate
2010-04-10 13:29 Granjow Assigned To => Granjow
2010-04-10 13:30 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker