Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000708KdenliveFile Loadingpublic2009-03-09 23:022010-09-01 14:37
Reporteraspiers 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformIntel 32-bitOSFedoraOS Version10
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000708: cannot load project file from version 0.7
DescriptionAfter a few months absence from kdenlive, I recompiled the latest svn trees and was very disappointed to find that my 0.7 project files are now unusable:

    // Opening a old Kdenlive document
    if (version == 0.5 || version == 0.7 || version > 0.81) {
        kDebug() << "Unable to open document with version " << version;
        // TODO: convert 0.7 (0.5?) files to the new document format.
        return false;
    }

You guys are doing a fantastic job with this project, but if you want to maintain community momentum I think it's a mistake to ostracize users like this. At very least the changes between format versions should be documented so that we can manually edit the XML into the latest format. Maybe I'm missing something obvious but I couldn't find any information about the format change in the 0.7.1 or 0.7.2 release announcement, mantis, the forums, or even the subversion commit logs!
Steps To Reproduce1. Create project with 0.7
2. Update to latest svn HEAD
3. Try to open 0.7 project
4. Observe debug error "KdenliveDoc::convertDocument: Unable to open document with version 0.7" and similar message in dialog box
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0002528)
administrator (administrator)
2009-03-09 23:34

I cannot reproduce the issue. I agree that our support for old documents is far from perfect. However you should know that the Kdenlive document version is not equal to the Kdenlive application version.

Kdenlive 0.7's document format is 0.8
Current svn Kdenlive format is 0.82

(You can find the document version by opening your .kdenlive project in a text editor and looking for the <kdenlivedoc ...> tag. There, you will find a version attribute that tells the Kdenlive document version.)

If I create a document with Kdenlive 0.7, the document's version is 0.8 and it can be opened correctly by current Kdenlive.

If you have a document with version "0.7", it means it was created with an unreleased and unstable version (maybe the 0.7 beta). You could maybe try to open it in a text editor and change version to "0.8" to see if things improve...
(0002529)
aspiers (reporter)
2009-03-09 23:55

Ah! OK editing the XML to 0.8 seems to have fixed it. When I created that 0.7 project file originally, I was running svn HEAD, as madsdyd will no doubt remember from the 100s of bugs I submitted at the time :-)

Maybe the code should be changed to suggest to the user to change the XML, or even automatically treat it as 0.8 with a warning?

Thanks!
(0005742)
LeHomard (developer)
2010-09-01 14:37

Closing report.

- Issue History
Date Modified Username Field Change
2009-03-09 23:02 aspiers New Issue
2009-03-09 23:02 aspiers Build/Install Method => Build Wizard
2009-03-09 23:34 administrator Note Added: 0002528
2009-03-09 23:35 administrator Status new => feedback
2009-03-09 23:55 aspiers Note Added: 0002529
2009-03-10 11:16 administrator Severity major => minor
2009-03-10 11:16 administrator Status feedback => acknowledged
2010-09-01 14:37 LeHomard Note Added: 0005742
2010-09-01 14:37 LeHomard Status acknowledged => resolved
2010-09-01 14:37 LeHomard Resolution open => no change required
2010-09-01 14:37 LeHomard Assigned To => LeHomard
2010-09-01 14:37 LeHomard Status resolved => closed
2010-09-01 14:37 LeHomard Assigned To LeHomard =>


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker