Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000727KdenliveUser Interfacepublic2009-03-20 16:362010-04-10 13:30
Reporterfacorread 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionduplicate 
Platform32 bit intel and alikeOSGentoo LinuxOS Version2008.0
Product Version0.7.2 
Target VersionFixed in Version0.7.3 
Summary0000727: Crash on saving
DescriptionKdenlive crahes with signal 11 (SIGSEV).
Steps To Reproduce- Open KDENLIVE
- Import a video file (In my case, a VOB file)
- Save it
Additional InformationBacktraces for two runs of kdenlive:

Aplicación: Kdenlive (kdenlive), señal SIGSEGV
[Current thread is 0 (LWP 2979)]

Thread 4 (Thread 0xb2e14b90 (LWP 2980)):
#0 0xb8006424 in __kernel_vsyscall ()
#1 0xb6905231 in select () from /lib/libc.so.6
0000002 0xb7430751 in QProcessManager::run (this=0x8c8e0e8) at io/qprocess_unix.cpp:305
0000003 0xb736c200 in QThreadPrivate::start (arg=0x8c8e0e8) at thread/qthread_unix.cpp:189
0000004 0xb72e9160 in start_thread () from /lib/libpthread.so.0
0000005 0xb690be2e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb0ec3b90 (LWP 3022)):
#0 0xb8006424 in __kernel_vsyscall ()
#1 0xb72ecf12 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0xb7ffc2d5 in mlt_consumer_get_frame (this=0x8e6d4b0) at mlt_consumer.c:497
0000003 0xb7ffc539 in mlt_consumer_rt_frame (this=0x8e6d4b0) at mlt_consumer.c:895
0000004 0xb2fc1b7a in consumer_thread (arg=0x8e6d4b0) at consumer_sdl_still.c:558
0000005 0xb72e9160 in start_thread () from /lib/libpthread.so.0
0000006 0xb690be2e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb16c4b90 (LWP 3023)):
#0 0xb8006424 in __kernel_vsyscall ()
#1 0xb72ecbe5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0xb2fc1303 in consumer_thread (arg=0x8e84450) at consumer_sdl_preview.c:381
0000003 0xb72e9160 in start_thread () from /lib/libpthread.so.0
0000004 0xb690be2e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5fe36d0 (LWP 2979)):
[KCrash Handler]
0000006 QHash<QString, QDomNodePrivate*>::findNode (this=0x9506524, akey=@0xbfd1faac, ahp=0x0) at ../../include/QtCore/../../src/corelib/tools/qhash.h:218
0000007 0xb7799639 in QDomNamedNodeMapPrivate::setNamedItem (this=0x9506520, arg=0x9817f18) at ../../include/QtCore/../../src/corelib/tools/qhash.h:592
0000008 0xb77998f2 in QDomNamedNodeMapPrivate::clone (this=0x9506578, p=0x98577c8) at dom/qdom.cpp:3071
0000009 0xb7799959 in QDomElementPrivate (this=0x98577c8, n=0x9506538, deep=<value optimized out>) at dom/qdom.cpp:4424
0000010 0xb77999cf in QDomDocumentPrivate::importNode (this=0x9370e60, importedNode=0x9506538, deep=<value optimized out>) at dom/qdom.cpp:6405
0000011 0xb779df15 in QDomDocument::importNode (this=0xbfd1fd74, importedNode=@0xbfd1fc28, deep=<value optimized out>) at dom/qdom.cpp:7111
0000012 0x081373a1 in KdenliveDoc::saveSceneList ()
0000013 0x080cb34e in MainWindow::saveFileAs ()
0000014 0x080cba60 in MainWindow::saveFileAs ()
0000015 0x080cbb7e in MainWindow::saveFile ()
0000016 0x080dbd19 in MainWindow::qt_metacall ()
0000017 0xb74634a9 in QMetaObject::activate (sender=0x9323510, from_signal_index=<value optimized out>, to_signal_index=6, argv=0xbfd2001c) at kernel/qobject.cpp:3057
0000018 0xb7463814 in QMetaObject::activate (sender=0x9323510, m=0x839e440, from_local_signal_index=1, to_local_signal_index=2, argv=0xbfd2001c) at kernel/qobject.cpp:3154
0000019 0xb6bbbd87 in QAction::triggered (this=0x9323510, _t1=false) at .moc/debug-shared/moc_qaction.cpp:236
0000020 0xb6bbcadb in QAction::activate (this=0x9323510, event=QAction::Trigger) at kernel/qaction.cpp:1160
0000021 0xb703094c in QToolButton::nextCheckState (this=0x9506524) at ../../include/QtGui/../../src/gui/kernel/qaction.h:203
0000022 0xb6f606d9 in QAbstractButtonPrivate::click (this=0x9369348) at widgets/qabstractbutton.cpp:525
0000023 0xb6f60919 in QAbstractButton::mouseReleaseEvent (this=0x9337c80, e=0xbfd2070c) at widgets/qabstractbutton.cpp:1115
0000024 0xb7030d30 in QToolButton::mouseReleaseEvent (this=0x9337c80, e=0xbfd2070c) at widgets/qtoolbutton.cpp:709
0000025 0xb6c14fc0 in QWidget::event (this=0x9337c80, event=0xbfd2070c) at kernel/qwidget.cpp:7516
0000026 0xb6f5ed0c in QAbstractButton::event (this=0x9337c80, e=0xbfd2070c) at widgets/qabstractbutton.cpp:1077
0000027 0xb70332c8 in QToolButton::event (this=0x9337c80, event=0xbfd2070c) at widgets/qtoolbutton.cpp:1151
0000028 0xb6bc1623 in QApplicationPrivate::notify_helper (this=0x8c8b050, receiver=0x9337c80, e=0xbfd2070c) at kernel/qapplication.cpp:4084
0000029 0xb6bca2ea in QApplication::notify (this=0xbfd20f80, receiver=0x9337c80, e=0xbfd2070c) at kernel/qapplication.cpp:3786
0000030 0xb7d95c15 in KApplication::notify (this=0xbfd20f80, receiver=0x9337c80, event=0xbfd2070c) at /var/tmp/paludis/kde-base-kdelibs-4.2.1-r2/work/kdelibs-4.2.1/kdeui/kernel/kapplication.cpp:307
0000031 0xb744e5ca in QCoreApplication::notifyInternal (this=0xbfd20f80, receiver=0x9337c80, event=0xbfd2070c) at kernel/qcoreapplication.cpp:598
0000032 0xb6bc942d in QApplicationPrivate::sendMouseEvent (receiver=0x9337c80, event=0xbfd2070c, alienWidget=0x9337c80, nativeWidget=0x9344bd0, buttonDown=0xb72dfb00, lastMouseReceiver=@0xb72dfb04)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
0000033 0xb6c2c117 in QETWidget::translateMouseEvent (this=0x9344bd0, event=0xbfd20c7c) at kernel/qapplication_x11.cpp:4425
0000034 0xb6c2b1cd in QApplication::x11ProcessEvent (this=0xbfd20f80, event=0xbfd20c7c) at kernel/qapplication_x11.cpp:3543
0000035 0xb6c51efe in x11EventSourceDispatch (s=0x8c8df48, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000036 0xb61f53f5 in IA__g_main_context_dispatch (context=0x8c8d458) at gmain.c:2144
0000037 0xb61f86a7 in g_main_context_iterate (context=0x8c8d458, block=1, dispatch=1, self=0x8c8b220) at gmain.c:2778
0000038 0xb61f8848 in IA__g_main_context_iteration (context=0x8c8d458, may_block=1) at gmain.c:2841
0000039 0xb7476260 in QEventDispatcherGlib::processEvents (this=0x8c78c48, flags={i = -1076752840}) at kernel/qeventdispatcher_glib.cpp:323
0000040 0xb6c516db in QGuiEventDispatcherGlib::processEvents (this=0x8c78c48, flags={i = -1076752792}) at kernel/qguieventdispatcher_glib.cpp:202
0000041 0xb744d230 in QEventLoop::processEvents (this=0xbfd20ed0, flags={i = -1076752728}) at kernel/qeventloop.cpp:149
0000042 0xb744d3d6 in QEventLoop::exec (this=0xbfd20ed0, flags={i = -1076752680}) at kernel/qeventloop.cpp:196
0000043 0xb7451ee6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
0000044 0xb6bc13b7 in QApplication::exec () at kernel/qapplication.cpp:3553
0000045 0x080c0f67 in main ()



----------------







Aplicación: Kdenlive (kdenlive), señal SIGSEGV
[Current thread is 0 (LWP 3063)]

Thread 4 (Thread 0xb201fb90 (LWP 3079)):
#0 0xb7fd8424 in __kernel_vsyscall ()
#1 0xb72bef12 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0xb7fce2d5 in mlt_consumer_get_frame (this=0xa1d43a8) at mlt_consumer.c:497
0000003 0xb7fce539 in mlt_consumer_rt_frame (this=0xa1d43a8) at mlt_consumer.c:895
0000004 0xb32c7b7a in consumer_thread (arg=0xa1d43a8) at consumer_sdl_still.c:558
0000005 0xb72bb160 in start_thread () from /lib/libpthread.so.0
0000006 0xb68dde2e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb181eb90 (LWP 3080)):
#0 0xb7fd8424 in __kernel_vsyscall ()
#1 0xb72bebe5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0xb32c7303 in consumer_thread (arg=0xa14fe90) at consumer_sdl_preview.c:381
0000003 0xb72bb160 in start_thread () from /lib/libpthread.so.0
0000004 0xb68dde2e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb01ffb90 (LWP 3081)):
#0 0xb7fc4f50 in mlt_properties_fetch (this=<value optimized out>, name=0xaaad718 "meta.media.1.codec.name") at mlt_properties.c:351
#1 0xb7fc5738 in mlt_properties_set (this=0xad18758, name=0xaaad718 "meta.media.1.codec.name", value=0xa7ed688 "mpeg2video") at mlt_properties.c:498
0000002 0xb7fca45e in producer_get_frame (service=0xa14ec90, frame=0xb01ff228, index=0) at mlt_producer.c:659
0000003 0xb7fc894d in mlt_service_get_frame (this=0xa14ec90, frame=0xb01ff228, index=0) at mlt_service.c:450
0000004 0xb7fac562 in Mlt::Service::get_frame (this=0xb01ff2ac, index=0) at MltService.cpp:95
0000005 0x081d6247 in MyThread::run ()
0000006 0xb733e200 in QThreadPrivate::start (arg=0xa8f0f18) at thread/qthread_unix.cpp:189
0000007 0xb72bb160 in start_thread () from /lib/libpthread.so.0
0000008 0xb68dde2e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5fb56d0 (LWP 3063)):
[KCrash Handler]
0000006 QHash<QString, QDomNodePrivate*>::findNode (this=0xb024bccc, akey=@0xbfff19cc, ahp=0x0) at ../../include/QtCore/../../src/corelib/tools/qhash.h:218
0000007 0xb776b639 in QDomNamedNodeMapPrivate::setNamedItem (this=0xb024bcc8, arg=0xb02530c8) at ../../include/QtCore/../../src/corelib/tools/qhash.h:592
0000008 0xb776b8f2 in QDomNamedNodeMapPrivate::clone (this=0xb024bd20, p=0xb0252f70) at dom/qdom.cpp:3071
0000009 0xb776b959 in QDomElementPrivate (this=0xb0252f70, n=0xb024bce0, deep=<value optimized out>) at dom/qdom.cpp:4424
0000010 0xb776b9cf in QDomDocumentPrivate::importNode (this=0xb024d150, importedNode=0xb024bce0, deep=<value optimized out>) at dom/qdom.cpp:6405
0000011 0xb776ff15 in QDomDocument::importNode (this=0xbfff1c94, importedNode=@0xbfff1b48, deep=<value optimized out>) at dom/qdom.cpp:7111
0000012 0x081373a1 in KdenliveDoc::saveSceneList ()
0000013 0x080cb34e in MainWindow::saveFileAs ()
0000014 0x080cba60 in MainWindow::saveFileAs ()
0000015 0x080cbb7e in MainWindow::saveFile ()
0000016 0x080dbd19 in MainWindow::qt_metacall ()
0000017 0xb74354a9 in QMetaObject::activate (sender=0xa620a78, from_signal_index=<value optimized out>, to_signal_index=6, argv=0xbfff1f3c) at kernel/qobject.cpp:3057
0000018 0xb7435814 in QMetaObject::activate (sender=0xa620a78, m=0x839e440, from_local_signal_index=1, to_local_signal_index=2, argv=0xbfff1f3c) at kernel/qobject.cpp:3154
0000019 0xb6b8dd87 in QAction::triggered (this=0xa620a78, _t1=false) at .moc/debug-shared/moc_qaction.cpp:236
0000020 0xb6b8eadb in QAction::activate (this=0xa620a78, event=QAction::Trigger) at kernel/qaction.cpp:1160
0000021 0xb700294c in QToolButton::nextCheckState (this=0xb024bccc) at ../../include/QtGui/../../src/gui/kernel/qaction.h:203
0000022 0xb6f326d9 in QAbstractButtonPrivate::click (this=0xa666e18) at widgets/qabstractbutton.cpp:525
0000023 0xb6f32919 in QAbstractButton::mouseReleaseEvent (this=0xa63aac8, e=0xbfff262c) at widgets/qabstractbutton.cpp:1115
0000024 0xb7002d30 in QToolButton::mouseReleaseEvent (this=0xa63aac8, e=0xbfff262c) at widgets/qtoolbutton.cpp:709
0000025 0xb6be6fc0 in QWidget::event (this=0xa63aac8, event=0xbfff262c) at kernel/qwidget.cpp:7516
0000026 0xb6f30d0c in QAbstractButton::event (this=0xa63aac8, e=0xbfff262c) at widgets/qabstractbutton.cpp:1077
0000027 0xb70052c8 in QToolButton::event (this=0xa63aac8, event=0xbfff262c) at widgets/qtoolbutton.cpp:1151
0000028 0xb6b93623 in QApplicationPrivate::notify_helper (this=0xa0562f8, receiver=0xa63aac8, e=0xbfff262c) at kernel/qapplication.cpp:4084
0000029 0xb6b9c2ea in QApplication::notify (this=0xbfff2ea0, receiver=0xa63aac8, e=0xbfff262c) at kernel/qapplication.cpp:3786
0000030 0xb7d67c15 in KApplication::notify (this=0xbfff2ea0, receiver=0xa63aac8, event=0xbfff262c) at /var/tmp/paludis/kde-base-kdelibs-4.2.1-r2/work/kdelibs-4.2.1/kdeui/kernel/kapplication.cpp:307
0000031 0xb74205ca in QCoreApplication::notifyInternal (this=0xbfff2ea0, receiver=0xa63aac8, event=0xbfff262c) at kernel/qcoreapplication.cpp:598
0000032 0xb6b9b42d in QApplicationPrivate::sendMouseEvent (receiver=0xa63aac8, event=0xbfff262c, alienWidget=0xa63aac8, nativeWidget=0xa638400, buttonDown=0xb72b1b00, lastMouseReceiver=@0xb72b1b04)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
0000033 0xb6bfe117 in QETWidget::translateMouseEvent (this=0xa638400, event=0xbfff2b9c) at kernel/qapplication_x11.cpp:4425
0000034 0xb6bfd1cd in QApplication::x11ProcessEvent (this=0xbfff2ea0, event=0xbfff2b9c) at kernel/qapplication_x11.cpp:3543
0000035 0xb6c23efe in x11EventSourceDispatch (s=0xa0591a0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000036 0xb61c73f5 in IA__g_main_context_dispatch (context=0xa057c98) at gmain.c:2144
0000037 0xb61ca6a7 in g_main_context_iterate (context=0xa057c98, block=1, dispatch=1, self=0xa0564e0) at gmain.c:2778
0000038 0xb61ca848 in IA__g_main_context_iteration (context=0xa057c98, may_block=1) at gmain.c:2841
0000039 0xb7448260 in QEventDispatcherGlib::processEvents (this=0xa043c48, flags={i = -1073795752}) at kernel/qeventdispatcher_glib.cpp:323
0000040 0xb6c236db in QGuiEventDispatcherGlib::processEvents (this=0xa043c48, flags={i = -1073795704}) at kernel/qguieventdispatcher_glib.cpp:202
0000041 0xb741f230 in QEventLoop::processEvents (this=0xbfff2df0, flags={i = -1073795640}) at kernel/qeventloop.cpp:149
0000042 0xb741f3d6 in QEventLoop::exec (this=0xbfff2df0, flags={i = -1073795592}) at kernel/qeventloop.cpp:196
0000043 0xb7423ee6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
0000044 0xb6b933b7 in QApplication::exec () at kernel/qapplication.cpp:3553
0000045 0x080c0f67 in main ()

Tagscrash
Build/Install MethodBuild Wizard
Attached Files

- Relationships
duplicate of 0000687closedj-b-m Qt 4.5: unable to save project 

-  Notes
(0002568)
facorread (reporter)
2009-03-20 16:37

My apologies. Next time I will attach the backtraces.

- Issue History
Date Modified Username Field Change
2009-03-20 16:36 facorread New Issue
2009-03-20 16:36 facorread Build/Install Method => Build Wizard
2009-03-20 16:37 facorread Note Added: 0002568
2009-03-20 16:37 facorread Tag Attached: crash
2009-03-23 23:16 administrator Relationship added duplicate of 0000687
2010-04-10 13:30 Granjow Status new => resolved
2010-04-10 13:30 Granjow Fixed in Version => 0.7.3
2010-04-10 13:30 Granjow Resolution open => duplicate
2010-04-10 13:30 Granjow Assigned To => j-b-m
2010-04-10 13:30 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker