Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000746KdenliveFile Loadingpublic2009-04-04 18:022009-06-18 01:51
ReporterMandrake 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.2 
Target VersionFixed in Version0.7.3 
Summary0000746: kdenlive 0.72 crashes when trying to open project; "Boken clip producer producer0"
Descriptionwhen trying to load a project I just created, it starts to load up to 66% then a "Sorry - Kdenlive" box appears saying "Boken clip producer producer0" then a box saying "The application Kdenlive (kdenlive) crashed and caused the signal 11 (SIGSEGV)
Additional Informationxzhayon suggested to do:
$ cd $project_file_directory && cp andreas.kdenlive andreas.kdenlive.orig && sed 's/producer0/4_3/g' andreas.kdenlive.orig > andreas.kdenlive

but still it seems to crash at 66%
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files? file icon andreas.kdenlive [^] (62,532 bytes) 2009-04-04 18:02
? file icon andreas_fixed2.kdenlive [^] (62,532 bytes) 2009-04-04 21:12

- Relationships
child of 0000607closedGranjow Title clip files (.kdenlivetitle) are stored in ASCII and not UTF-8 

-  Notes
(0002627)
administrator (administrator)
2009-04-04 20:09

Ok, I think I found the bug. It is caused by a bug in the titler module that does not correctly save special characters (for example accents like é, ü) in some cases.

In your file, there was a non utf-8 character at line 1021 just before the "Norwegian Carnage". I edited the file, removed the wrong character and uploaded it to andreas_fixed.kdenlive.

Can you try it?
(0002629)
Mandrake (reporter)
2009-04-04 20:42

Hi, I get an error box:

"This project type is unsupported and can't be loaded."

terminal says:
kdenlive(20660) KdenliveDoc::convertDocument: Opening a document with version 0.82
kdenlive(20660) KdenliveDoc::convertDocument: Unable to open document with version 0.82
(0002630)
administrator (administrator)
2009-04-04 21:12

Sorry, wrong file uploaded. Try again with andreas_fixed2
(0002631)
Mandrake (reporter)
2009-04-04 21:51

Hi, I can confirm that the file works now. Thanks!

- Issue History
Date Modified Username Field Change
2009-04-04 18:02 Mandrake New Issue
2009-04-04 18:02 Mandrake File Added: andreas.kdenlive
2009-04-04 18:02 Mandrake Build/Install Method => 3rd party package
2009-04-04 20:09 administrator Note Added: 0002627
2009-04-04 20:09 administrator Status new => feedback
2009-04-04 20:10 administrator File Added: andreas_fixed.kdenlive
2009-04-04 20:42 Mandrake Note Added: 0002629
2009-04-04 21:11 administrator File Deleted: andreas_fixed.kdenlive
2009-04-04 21:12 administrator File Added: andreas_fixed2.kdenlive
2009-04-04 21:12 administrator Note Added: 0002630
2009-04-04 21:51 Mandrake Note Added: 0002631
2009-04-06 08:44 administrator Relationship added child of 0000607
2009-04-08 19:13 administrator Status feedback => resolved
2009-04-08 19:13 administrator Resolution open => fixed
2009-04-08 19:13 administrator Fixed in Version => Recent git
2009-04-15 13:07 madsdyd Fixed in Version Recent git => 0.7.3
2009-06-18 01:51 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker