Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000079KdenliveBuild Systempublic2008-02-04 08:072008-10-23 00:22
Reporterjmpoure 
Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformAMD64OSGNU/LinuxOS VersionSID
Product Version 
Target VersionFixed in Version 
Summary0000079: Compilation with latest MLT svn fails
Description[ 53%] Building CXX object kdenlive/CMakeFiles/kdenlive.dir/kplacer.o
[ 53%] Building CXX object kdenlive/CMakeFiles/kdenlive.dir/krazorclipscommand.o
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krazorclipscommand.h: In constructor ‘Command::KRazorClipsCommand::KRazorClipsCommand(Gui::KdenliveApp*, KdenliveDoc*, DocTrackBase&, GenTime)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krazorclipscommand.h:54: warning: ‘Command::KRazorClipsCommand::m_app’ will be initialized after
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krazorclipscommand.h:53: warning: ‘KdenliveDoc* Command::KRazorClipsCommand::m_doc’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krazorclipscommand.cpp:33: warning: when initialized here
[ 53%] Building CXX object kdenlive/CMakeFiles/kdenlive.dir/krender.o
In file included from /home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:37:
/usr/share/qt3/include/qxml.h:224: warning: ‘class QXmlReader’ has virtual functions but non-virtual destructor
/usr/share/qt3/include/qxml.h:407: warning: ‘class QXmlContentHandler’ has virtual functions but non-virtual destructor
/usr/share/qt3/include/qxml.h:424: warning: ‘class QXmlErrorHandler’ has virtual functions but non-virtual destructor
/usr/share/qt3/include/qxml.h:433: warning: ‘class QXmlDTDHandler’ has virtual functions but non-virtual destructor
/usr/share/qt3/include/qxml.h:441: warning: ‘class QXmlEntityResolver’ has virtual functions but non-virtual destructor
/usr/share/qt3/include/qxml.h:448: warning: ‘class QXmlLexicalHandler’ has virtual functions but non-virtual destructor
/usr/share/qt3/include/qxml.h:461: warning: ‘class QXmlDeclHandler’ has virtual functions but non-virtual destructor
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.h: In constructor ‘KRender::KRender(const QString&, QWidget*, const char*)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.h:203: warning: ‘KRender::m_winid’ will be initialized after
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.h:184: warning: ‘double KRender::m_framePosition’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:61: warning: when initialized here
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.h:187: warning: ‘KRender::m_generateScenelist’ will be initialized after
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.h:159: warning: ‘bool KRender::isBlocked’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:61: warning: when initialized here
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:75: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: At global scope:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:120: warning: unused parameter ‘self’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::createVideoXWindow(WId, WId)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:145: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:179: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘int KRender::resetRendererProfile(char*)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:198: error: ‘mlt_consumer_profile’ was not declared in this scope
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘QPixmap KRender::extractFrame(int, int, int)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:256: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘QPixmap KRender::getVideoThumbnail(QString, int, int, int)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:305: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::getImage(KURL, int, QPoint)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:326: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::getFileProperties(KURL, uint)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:417: warning: converting to ‘int’ from ‘double’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:433: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::setSceneList(QDomDocument, int)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:559: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:596: error: cannot convert ‘const char*’ to ‘mlt_profile_s*’ for argument ‘1’ to ‘mlt_filter_s* mlt_factory_filter(mlt_profile_s*, const char*, void*)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:601: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘const GenTime& KRender::seekPosition() const’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:835: warning: returning reference to temporary
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:836: warning: returning reference to temporary
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: At global scope:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:865: warning: unused parameter ‘srcFileName’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:865: warning: unused parameter ‘port’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:865: warning: unused parameter ‘startTime’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:865: warning: unused parameter ‘endTime’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::exportCurrentFrame(KURL, bool)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:882: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltCheckLength()’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:930: warning: passing ‘double’ for argument 2 to ‘int Mlt::Playlist::remove_region(int, int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:932: warning: converting to ‘int’ from ‘double’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltInsertClip(int, GenTime, QString)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:965: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:969: warning: passing ‘double’ for argument 1 to ‘int Mlt::Playlist::insert_at(int, Mlt::Producer&, int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltCutClip(int, GenTime)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:990: warning: passing ‘double’ for argument 1 to ‘int Mlt::Playlist::split_at(int, bool)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltRemoveClip(int, GenTime)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1007: warning: passing ‘double’ for argument 1 to ‘int Mlt::Playlist::get_clip_index_at(int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltRemoveEffect(int, GenTime, QString, QString, int)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1023: warning: passing ‘double’ for argument 1 to ‘Mlt::Producer* Mlt::Playlist::get_clip_at(int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltAddEffect(int, GenTime, QString, QString, QMap<QString, QString>)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1063: warning: passing ‘double’ for argument 1 to ‘Mlt::Producer* Mlt::Playlist::get_clip_at(int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltEditEffect(int, GenTime, int, QString, QString, QMap<QString, QString>)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1127: warning: passing ‘double’ for argument 1 to ‘Mlt::Producer* Mlt::Playlist::get_clip_at(int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltResizeClipEnd(int, GenTime, GenTime, GenTime)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1165: warning: passing ‘double’ for argument 1 to ‘bool Mlt::Playlist::is_blank_at(int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1167: warning: passing ‘double’ for argument 1 to ‘int Mlt::Playlist::get_clip_index_at(int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1170: warning: converting to ‘int’ from ‘double’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1173: warning: passing ‘double’ for argument 2 to ‘int Mlt::Playlist::resize_clip(int, int, int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltResizeClipStart(int, GenTime, GenTime, GenTime, GenTime, GenTime)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1221: warning: converting to ‘int’ from ‘double’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1226: warning: passing ‘double’ for argument 1 to ‘bool Mlt::Playlist::is_blank_at(int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1228: warning: passing ‘double’ for argument 1 to ‘int Mlt::Playlist::get_clip_index_at(int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1231: warning: passing ‘double’ for argument 2 to ‘int Mlt::Playlist::resize_clip(int, int, int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1231: warning: passing ‘double’ for argument 3 to ‘int Mlt::Playlist::resize_clip(int, int, int)’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1234: warning: converting to ‘int’ from ‘double’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltMoveClip(int, int, int, int)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1274: warning: unused variable ‘multiprod’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltMoveTransition(QString, int, int, GenTime, GenTime, GenTime, GenTime)’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1311: warning: converting to ‘int’ from ‘double’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1313: warning: converting to ‘int’ from ‘double’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1314: warning: converting to ‘int’ from ‘double’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: In member function ‘void KRender::mltSavePlaylist()’:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:1374: warning: deprecated conversion from string constant to ‘char*’
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp: At global scope:
/home/jmpoure/logiciels/kdenlive/kdenlive/kdenlive/krender.cpp:120: warning: ‘void consumer_stopped(mlt_consumer_s*, KRender*, mlt_frame_s*)’ defined but not used
make[2]: *** [kdenlive/CMakeFiles/kdenlive.dir/krender.o] Erreur 1
make[1]: *** [kdenlive/CMakeFiles/kdenlive.dir/all] Erreur 2
make: *** [all] Erreur 2
TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0000146)
atomopawn (reporter)
2008-02-09 23:55

Same problem here. I'm going through the krender file now, adding *m_mltProfile to all the functions that seem to need it. If that's what really needs to be done, I'll post a patch here.....
(0000147)
atomopawn (reporter)
2008-02-10 00:29

Okay. Nevermind. Latest svn update seems to have fixed krender....
(0000148)
el_jefe (reporter)
2008-02-11 15:56

I am still unable to build the krender.o part, using the latest SVN checkouts as of 10 Feb '8... I'm not sure the revision number, but the build did fail after reading the above post ("Okay. Nevermind. Latest svn update seems to have fixed krender....") so, for me, it is still broken...
(0000149)
administrator (administrator)
2008-02-13 21:57

Compilation should work correctly now, please post the compilation output if you still have problems, otherwise I will close the bug in a couple of days.
(0000151)
jmpoure (developer)
2008-02-14 08:34

Thanks. My problem was due to old version of MLT and MLT++. Now compiles fine. I can only hope that Kdenlive supports latest MLT new syntax.

- Issue History
Date Modified Username Field Change
2008-02-04 08:07 jmpoure New Issue
2008-02-09 23:55 atomopawn Note Added: 0000146
2008-02-10 00:29 atomopawn Note Added: 0000147
2008-02-11 15:56 el_jefe Note Added: 0000148
2008-02-13 21:57 administrator Note Added: 0000149
2008-02-14 08:34 jmpoure Note Added: 0000151
2008-02-15 21:29 administrator Status new => resolved
2008-02-15 21:29 administrator Resolution open => fixed
2008-10-23 00:22 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker