Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000805KdenliveFile Loadingpublic2009-05-02 12:042009-07-01 21:57
ReporterGranjow 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000805: If path of audio clips has changed, kdenlive removes them
DescriptionI've got audio clips in one and video clips in an other directory. I guess both of them have changed recently (new PC, better directory structure, and so on. You'll know it.)

When I opened the project, kdenlive asked me whether to search for the clips automatically. I said yes and selected the directory containing the videos and they were added correctly. However, all audio clips (fortunately only two) weren't, and I couldn't adjust its path manually (unless I edit the .kdenlive file directly). Selecting «reload clip» just removes it because it is invalid.

Imho «Reload Clip» from the context menu shouldn't just remove the audio clip (with all its effects and so on in the timeline). And perhaps the «Search Automatically» function has to be adjusted?
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0002797)
administrator (administrator)
2009-05-03 11:36

i am currently working on a better way to check and fix missing clips, should be ready in 2-3 days...
(0002814)
administrator (administrator)
2009-05-04 22:29

Should be ok now (rev 3357). There is a dialog listing all broken clips with several options (search, use placeholder, remove), and reloading a missing clip now asks if you want to delete it.
(0002832)
xzhayon (developer)
2009-05-09 16:57

producers resources were incorrectly updated, now fixed in rev. 3370 (i'm not sure this belongs to this issue)
i still have crashes with placeholders, will investigate (but i think this issue should be closed)
(0003001)
Granjow (developer)
2009-05-30 15:44

Very nice dialogue! Thanks!

Still one problem however: When I first search recursively and select the Audio directory, then again for the Video directory, all is fine. The other way round, first Video and then Audio, does not work. Reproducable.
(0003004)
administrator (administrator)
2009-05-30 20:13

Damnit! Yes, that was caused by a stupid logic error. In fact, the recursive search only worked if the first item in the list was missing... Fixed now in svn with a speedup bonus.

As a workaround, you can set the search folder to a directory that contains both audio and video folders, you can even set it to the root folder, the search algorithm is rather fast.
(0003019)
Granjow (developer)
2009-06-01 15:16

Working perfectly. Rocks :)

- Issue History
Date Modified Username Field Change
2009-05-02 12:04 Granjow New Issue
2009-05-02 12:04 Granjow Build/Install Method => Manual build from SVN
2009-05-03 11:36 administrator Note Added: 0002797
2009-05-03 11:36 administrator Status new => acknowledged
2009-05-04 22:29 administrator Note Added: 0002814
2009-05-04 22:29 administrator Status acknowledged => feedback
2009-05-09 16:57 xzhayon Note Added: 0002832
2009-05-30 15:44 Granjow Note Added: 0003001
2009-05-30 20:13 administrator Note Added: 0003004
2009-06-01 15:16 Granjow Note Added: 0003019
2009-06-01 15:16 Granjow Status feedback => resolved
2009-06-01 15:16 Granjow Fixed in Version => Recent git
2009-06-01 15:16 Granjow Resolution open => fixed
2009-06-01 15:16 Granjow Assigned To => Granjow
2009-06-27 02:15 j-b-m Target Version => 0.7.5
2009-06-27 15:19 Granjow Status resolved => assigned
2009-06-27 15:19 Granjow Assigned To Granjow => j-b-m
2009-06-27 15:19 Granjow Status assigned => resolved
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:57 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker