Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000807KdenliveUser Interfacepublic2009-05-02 19:592009-07-01 22:03
Reporterjimmygilles 
Assigned Toadministrator 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version0.7.3 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000807: Modify Track Type
DescriptionWhen a user wants to change the track type (Video to audio or audio to video), there are 2 problems.

The first one:
- Right click on a audio track
- Select "Change Track Type"
 Result:
 - The button "video" is checked
 Expected result:
 - The button "audio" is checked



Second problem (related to the same dialog):
It seems more user friendly to let the ability to change only the selected track ; so in my patch, the index is hidden.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filespatch file icon mypatch.patch [^] (5,206 bytes) 2009-05-02 19:59 [Show Content]

- Relationships

-  Notes
(0002794)
jimmygilles (reporter)
2009-05-02 22:23

Hello,

I see that there is a menu "track" -> "change type" in the project menu. So my patch is not complete. Sorry.
(0002798)
administrator (administrator)
2009-05-03 16:35

Yes, the reason why the track is selectable is because the action is also available from main menu. So either we should hide the option only when called from context menu...
(0002818)
administrator (administrator)
2009-05-05 01:52

Patch for 1st problem was committed - slightly modified - to svn (rev. 3360).
(0002838)
xzhayon (developer)
2009-05-10 16:39

first issue solved, now waiting for the second one
(0003357)
administrator (administrator)
2009-06-21 02:31

The track number should not be hidden because that action can also be called from the main menu - or via a keyboard shortcut, then user must be able to select which track he wants to change.

- Issue History
Date Modified Username Field Change
2009-05-02 19:59 jimmygilles New Issue
2009-05-02 19:59 jimmygilles File Added: mypatch.patch
2009-05-02 19:59 jimmygilles Build/Install Method => Manual build from SVN
2009-05-02 22:23 jimmygilles Note Added: 0002794
2009-05-03 16:35 administrator Note Added: 0002798
2009-05-03 16:35 administrator Status new => acknowledged
2009-05-05 01:52 administrator Note Added: 0002818
2009-05-05 01:52 administrator Status acknowledged => feedback
2009-05-10 16:39 xzhayon Note Added: 0002838
2009-05-10 16:39 xzhayon Status feedback => acknowledged
2009-06-21 02:31 administrator Note Added: 0003357
2009-06-21 02:31 administrator Status acknowledged => resolved
2009-06-21 02:31 administrator Fixed in Version => Recent git
2009-06-21 02:31 administrator Resolution open => won't fix
2009-06-21 02:31 administrator Assigned To => administrator
2009-06-27 02:17 j-b-m Target Version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 22:03 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker