Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000834KdenliveRenderingpublic2009-05-18 20:502010-09-14 23:26
Reporterriksta 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.3 
Target VersionFixed in Version0.7.4 
Summary0000834: kdenlive crashes when using dvd creator and .m2s
DescriptionI created a dvd with menu, and added a single .m2s file (rendered by kdenlive) and I received this crash trace:

Additional InformationApplication: Kdenlive (kdenlive), signal SIGSEGV
[Current thread is 0 (LWP 8659)]

Thread 4 (Thread 0xa5941b90 (LWP 8772)):
#0 0xb8072430 in __kernel_vsyscall ()
#1 0xb67357b1 in select () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb73f8380 in ?? () from /usr/lib/libQtCore.so.4
0000003 0xb732696e in ?? () from /usr/lib/libQtCore.so.4
0000004 0xb66414ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xb673d49e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xac7e6b90 (LWP 10209)):
#0 0xb8072430 in __kernel_vsyscall ()
#1 0xb66450e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb674c2ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb2d8dd2c in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xadea9b90 (LWP 10476)):
#0 0xb8072430 in __kernel_vsyscall ()
#1 0xb6645412 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb674c344 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb8049a09 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.1
0000004 0xb66429ce in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xe8758bff in ?? ()

Thread 1 (Thread 0xb5e0f700 (LWP 8659)):
[KCrash Handler]
0000006 0xb736df6a in QString::operator= () from /usr/lib/libQtCore.so.4
0000007 0xb73b60fd in QIODevice::close () from /usr/lib/libQtCore.so.4
0000008 0xb73b7b24 in QProcess::close () from /usr/lib/libQtCore.so.4
0000009 0x08339825 in DvdWizard::~DvdWizard ()
0000010 0xb6f3c480 in QDialog::exec () from /usr/lib/libQtGui.so.4
0000011 0x080caf40 in MainWindow::slotDvdWizard ()
0000012 0x080ea17c in MainWindow::qt_metacall ()
0000013 0xb7430ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000014 0xb74310e0 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000015 0xb6a1b891 in QAction::triggered () from /usr/lib/libQtGui.so.4
0000016 0xb6a1ce0f in QAction::activate () from /usr/lib/libQtGui.so.4
0000017 0xb6e9701c in ?? () from /usr/lib/libQtGui.so.4
0000018 0xb6e9d76b in ?? () from /usr/lib/libQtGui.so.4
0000019 0xb6e9e242 in QMenu::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
0000020 0xb7ee47e5 in KMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.5
0000021 0xb6a78b43 in QWidget::event () from /usr/lib/libQtGui.so.4
0000022 0xb6ea0629 in QMenu::event () from /usr/lib/libQtGui.so.4
0000023 0xb6a21e9c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
0000024 0xb6a2ab11 in QApplication::notify () from /usr/lib/libQtGui.so.4
0000025 0xb7dfd94d in KApplication::notify () from /usr/lib/libkdeui.so.5
0000026 0xb741aa3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
0000027 0xb6a29b7e in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
0000028 0xb6a99c06 in ?? () from /usr/lib/libQtGui.so.4
0000029 0xb6a98ca7 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
0000030 0xb6ac3c6a in ?? () from /usr/lib/libQtGui.so.4
0000031 0xb6175b88 in IA__g_main_context_dispatch (context=0xa172a90) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
0000032 0xb61790eb in g_main_context_iterate (context=0xa172a90, block=1, dispatch=1, self=0xa170660) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
0000033 0xb6179268 in IA__g_main_context_iteration (context=0xa172a90, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
0000034 0xb7446438 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
0000035 0xb6ac3365 in ?? () from /usr/lib/libQtGui.so.4
0000036 0xb741906a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
0000037 0xb74194aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
0000038 0xb741b959 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
0000039 0xb6a21d17 in QApplication::exec () from /usr/lib/libQtGui.so.4
0000040 0x080ca8cc in main ()

TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0002883)
administrator (administrator)
2009-05-19 01:04

From the crash log, it looks like the crash happened when you tried to close the dvd Wizard... I just fixed that issue (0000833).

By the way, what is a m2s file? For DVD, you should use .vob files created by Kdenlive using the "DVD" category in render dialog...
(0002885)
riksta (reporter)
2009-05-19 01:40

Thanks, I was using the program incorrectly, now i choose the DVD from the dropdown and render that way.

Sorry.

- Issue History
Date Modified Username Field Change
2009-05-18 20:50 riksta New Issue
2009-05-18 20:50 riksta Build/Install Method => Distribution package
2009-05-19 01:04 administrator Note Added: 0002883
2009-05-19 01:04 administrator Status new => feedback
2009-05-19 01:40 riksta Note Added: 0002885
2010-05-28 18:07 Granjow Status feedback => resolved
2010-05-28 18:07 Granjow Fixed in Version => 0.7.4
2010-05-28 18:07 Granjow Resolution open => fixed
2010-05-28 18:07 Granjow Assigned To => j-b-m
2010-09-14 23:26 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker