Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000854KdenliveRenderingpublic2009-05-24 23:452011-11-01 18:56
ReporterArctures 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.3 
Target Version0.7.5Fixed in Version0.8.2 
Summary0000854: Jerky video when rendering to any format from Canon HV30 PAL m2t source
DescriptionJerky video looks like frames have no any fluid sequence at all. I am getting this problem when I am trying to render my m2t files captured by dvgrab to any of the following format types: HDV, MPEG-4, XVid4, H.264 with different bit rates. I did not check other format types but I suppose they are affected also as far as this looks as not codec-related issue. I am using kdenlive-0.7.3 compiled on Gentoo linux with the following dependencies:

- mlt-0.3.8-r1 (dv ffmpeg gtk kde qt4 quicktime sdl sse vorbis xine xml -compressed-lumas -jack -libsamplerate -mmx -qt3 -sox)

- ffmpeg-0.5-r1 (3dnow 3dnowext X alsa encode faac faad hardcoded-tables ieee1394 mmx mmxext mp3 oss sdl ssse3 theora threads vorbis x264 xvid zlib -altivec -amr -bindist -custom-cflags -debug -dirac -doc -gsm -ipv6 -jpeg2k -network -schroedinger -speex -test -v4l -v4l2 -vhook)

- Qt-4.5.1

- libsdl-1.2.13-r1 (X alsa arts audio directfb joystick opengl oss video xinerama xv -aalib -custom-cflags -dga -esd -fbcon -ggi -libcaca -nas -pulseaudio -svga)

I have chosen Severity==block because I really cannot use Kdenlive for any purpose to get acceptable video output.

If it will be necessary for testing I can upload some frame sequences to test it out.

How to reproduce:
Import Canon's m2t clip and drop it on the timeline. Press [Render] and choose output format you like. wait until rendering is finished.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon circus.mp4 [^] (4,057,814 bytes) 2009-05-30 05:19

- Relationships

-  Notes
(0002899)
piotr (reporter)
2009-05-25 02:00

Yes I have the same problem.
Also with m2t files
(0002900)
Arctures (reporter)
2009-05-25 09:05

piotr, would you like to post some details about the exact packages versions you use?
(0002902)
piotr (reporter)
2009-05-25 13:24
edited on: 2009-05-25 14:11

Version 0.7.2.1
Ubuntu 8.10

Also using m2t files from the canon hv 30 camera,
Also PAL files.

Instaled as told in:

http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/ubuntu-packages [^]

The same happens as in your case. After every (using every codec) rendering something is wrong.

(0002924)
piotr (reporter)
2009-05-26 02:59

Do you need more info?
(0002926)
administrator (administrator)
2009-05-26 09:08

could you please upload a video sample so that we can test? If you have no place to upload, mail it to me - jb at kdenlive org, and let us know if we can put the video file as a testing footage on our camcorder page:
http://kdenlive.org/video-editor [^]

regards

(0002941)
Arctures (reporter)
2009-05-27 11:47

Here is the download link:
http://rapidshare.com/files/237730570/Circus_footage_CanonHV30.PAL.25p.23MBps.m2t.html [^]
This link will work for 10 downloads only and will not be accessible after. You are welcome to share, test and use it for any purposes. I would like to see it on kdenlive.org's video footage page. If you need any assistance with some special debug attempts or so please reply or post a comment in the bug report.
(0002942)
gsking1 (reporter)
2009-05-27 12:35

FYI - I use the HV30 NTSC and it works fine. Geoff
(0002943)
Arctures (reporter)
2009-05-27 12:38

gsking1 would you like to provide some details about related packages you use? E.g. kdenlive version, mlt and ffmpeg and also yor linux distro.
(0002945)
gsking1 (reporter)
2009-05-27 14:55

System is Ubuntu Jaunty (9.04) with 2.6.29.4 kernel configured as desktop. Much of the multimedia stuff related to audio and video has been compiled from source. Most other are official packages.

Most of my rendering has been to MPEG-4 and DVD. Have not tried rendering to HDV, XVid4, or H.264.

I'll try to also post some example clips sometime soon (today or tomorrow).

Here's the main ones:

ffmpeg from official 0.5 release
./configure --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --extra-version=0.5-GSK --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-libgsm --enable-libschroedinger --disable-encoder=libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --disable-stripping --disable-vhook --enable-libdc1394 --disable-armv5te --disable-armv6 --disable-armv6t2 --disable-armvfp --disable-neon --disable-altivec --disable-vis --enable-shared --disable-static --enable-libmp3lame --enable-libfaad --enable-libfaac --enable-libxvid --enable-libx264 --enable-nonfree --enable-libdirac --disable-decoder=libdirac --enable-libamr-nb --enable-libamr-wb

mlt [4.0 source - released 5/18/2009]
./configure --enable-gpl --qimage-libdir=/usr/lib/ --qimage-includedir=/usr/include/qt4 --avformat-swscale --libdir=/usr/lib --libdir=/usr/local/lib

frei0r [using git source snapshot 4/25/2009]
sox [14.2.0 source]
kdenlive [svn 3421? 5/26/2009]

Hope this helps. Geoff
(0002946)
Arctures (reporter)
2009-05-27 15:20

gsking1 many thanks for detailed feedback. As I can see you did not try to render your output as HD. As for me I did not tried to render my HD to DVD and resized MPEG. Because HD is the main purpose of my camcorder and kdenlive for me. It would be great if you will try to render any small piece of video to HD and post your results here.
(0002953)
gsking1 (reporter)
2009-05-28 04:29

I'll try to find some good clips and post them somewhere. May take a day or two though.
(0002958)
gsking1 (reporter)
2009-05-29 03:44

Here's a few clips from my HV30 NTSC camera. These work great on my computer and I do NOT see any jerky video (except a little due to the slow processor).
Also feel free to use the original clips on the website as HV30 examples if you want.

The will only be available for a few days so get them while they are hot. Also it's a slow connection so please only download once.

http://bacon.no-ip.info/kdenlive/ [^]

Edited versions:
editedtestclipHV30-firstHD30P-lastHDV-720P.m2t = High Res 720p format

Original clips from camera:
HV30_ntsc_HD30P_format_example-wagon
HV30_ntsc_HDV_format_example-bear
(0002960)
Arctures (reporter)
2009-05-29 09:46

gsking1 many thanks for your feedback. Your video looks and plays very well. But I really don't know still where the problem is. May be someone could reproduce it and there will be enough info?
(0002969)
gsking1 (reporter)
2009-05-29 13:45

Arctures what is the format of your HV30 PAL video? Are these HDV, HDV30P, HV24P, etc (assuming yours are similar names). Note that I've never tried the 24P settings on my camera.

Also how did you download them. Via dvgrab command line? or kdenlive interface? or something else?

Any other thoughts of what the cause might be?

I'll try your clip in my system this evening (US EST -5).
(0002970)
Arctures (reporter)
2009-05-29 14:06

I am getting my video via dvgrab as I mentioned. Also I have PAL version of HV30 so I don't have 30P only 25P and 50i.
(0002980)
gsking1 (reporter)
2009-05-30 01:28

Hi Arctures - I tried your clip (Circus_footage_CanonHV30.PAL.25p.23MBps.m2t) and do see the Jerky video as you describe. I tried a several renders (mp4, m2t, and dvd) with various settings and they all had the problem. The original clip looks very good/smooth and plays fine in VLC and mplayer.

I placed a render example of the jerkiness here:
http://bacon.no-ip.info/kdenlive/ [^]
jerky-render-from-PAL-clip-4000k-prog-2pass-640x360.mp4

So to sum up my experience. I can confirm that the HV30 PAL clip has problems when rendering.

My system is Ubuntu 32bit Jaunty, ffmpeg (0.5), mlt git (0.4.1+), kdenlive (svn 3436).

Hope this helps. Geoff
(0002987)
ddennedy (developer)
2009-05-30 04:47

I downloaded Circus_footage_CanonHV30.PAL.25p.23MBps.m2t and FFmpeg has problems with it. During some playback with ffplay and melt, it looked to be skipping frames, so I used ffmpeg to dump it still frames and look at them:

$ ffmpeg -i Circus_footage_CanonHV30.PAL.25p.23MBps.m2t -s 480x270 -r 25 circus-%04d.jpg

gives the warning many times a second:
[mpegts @ 0x8d74ac0]Invalid timestamps stream=0, pts=2750400, dts=2754000, size=157

Viewing them frame-by-frame with gwenview, and they advance nicely.

Doing the equivalent with MLT:

$ melt Circus_footage_CanonHV30.PAL.25p.23MBps.m2t -consumeravformat:circus-%04d.jpg s=480x270 progressive=1

Viewing them shows repeated frames - rougly 1/3 framerate but not entirely consistent: choppy.

I am taking a deeper look now, but due to the frame-accurate seeking requirements of MLT, this file with these timestamp issues may not be supportable. ffmpeg/ffplay just needs to play sequentially. You might have to transcode them to make them usable. Kdenlive 0.7.4 has an option to make transcoding any clip in the Project Tree for the sake of an editable replacement very convenient. It comes with a high quality DNxHD preset.
(0002988)
ddennedy (developer)
2009-05-30 04:53

OK, I can see the impact of the timestamps in MLT:
[producer @ 0x908bd30]pkt.dts 158400 req_pos 88 cur_pos 86 pkt_pos 88 got_pic 32 key 1
[producer @ 0x908bd30]pkt.dts 18446744065119786224 req_pos 90 cur_pos 88 pkt_pos -4772091 got_pic 0 key 0
[producer @ 0x908bd30]pkt.dts 18446744065119789824 req_pos 90 cur_pos 88 pkt_pos -4772089 got_pic 0 key 0
[producer @ 0x908bd30]pkt.dts 176400 req_pos 90 cur_pos 88 pkt_pos 98 got_pic 32 key 0
[producer @ 0x908bd30]pkt.dts 18446744065119797024 req_pos 100 cur_pos 98 pkt_pos -4772085 got_pic 0 key 0
[producer @ 0x908bd30]pkt.dts 18446744065119797024 req_pos 100 cur_pos 98 pkt_pos -4772084 got_pic 0 key 0
[producer @ 0x908bd30]pkt.dts 187200 req_pos 100 cur_pos 98 pkt_pos 104 got_pic 32 key 0


The pkt.dts should advance 3600 for each frame. As you can see, there are wild timestamps. There is already code to deal with ffmpeg's AV_NOPTS_VALUE, but these are not them and these wild values do advance by 3600 when in succession. I am worried that if I put in some workaround, it can be triggered under the wrong conditions (regression) or not triggered by different files with a similar problem.
(0002989)
ddennedy (developer)
2009-05-30 05:21

I made a workaround that I am testing. I attached a sample made in kdenlive circus.mp4. As part of this test I trimmed the beginning of the Circus, and added another clip at the end that I was regression testing with at the time. I need to regression test this some more.
(0003107)
ddennedy (developer)
2009-06-05 07:32

This should be resolved now in MLT git (0.4.3). It would be nice if you can confirm. I am crossing my fingers that it has not caused any regressions, but it seems good so far. My hope is that this will get a fair amount of community testing by the next release.
(0005014)
Arctures (reporter)
2010-04-11 10:48

I haven't looked at this closely for some time. And yesterday I have tried to render some m2t 1080p/25p footage to a whole project. After the rendering was finished I have got exactly the same result as it was in earlier versions. Now I am spending tons of gigabytes for intermediate Huffyuv format which is handled correctly by kdenlive. I have tried several codecs/formats switching resize on/of and etc. The problem is where m2t being converted. May be it is possible to do some kind of preparation for m2t footage in order to get it handled correctly? There are many different video utilities and I am sure there might be something helpful.
(0005015)
ddennedy (developer)
2010-04-11 11:32

.m2t (HDV) in general is not a problem. This particular case does appear to be. There might have been a regression since the fix; the code changed a lot in this module in the past year. I will retest it.

 Kdenlive has a transcode feature you could have used to convert it to DNxHD.
(0005016)
Arctures (reporter)
2010-04-11 13:23

dden, I have tried plain DNxHD transcoding as well as many other formats. And I have got the same issue. In case of lossless formats video artifacts are less noticeable but they are still there.
(0005017)
Arctures (reporter)
2010-04-11 13:24

Just in case - kdenlive-0.7.7.1 and mlt-0.5.0
(0005038)
ddennedy (developer)
2010-04-16 05:06

I am not able to reproduce the problem using mlt 0.5.2 with the Circus sample provided with the original bug report. I do not believe there was any change between versions 0.5.0 and 0.5.2 that would have corrected it. Now, I just built 0.5.0 and tested it, and it works fine for me as well.
(0005875)
ddennedy (developer)
2010-09-22 05:02

reclosing. Just tested it again, and no problem here using MLT 0.5.10 with FFmpeg v0.6.

- Issue History
Date Modified Username Field Change
2009-05-24 23:45 Arctures New Issue
2009-05-24 23:45 Arctures Build/Install Method => Distribution package
2009-05-25 02:00 piotr Note Added: 0002899
2009-05-25 09:05 Arctures Note Added: 0002900
2009-05-25 13:24 piotr Note Added: 0002902
2009-05-25 14:11 piotr Note Edited: 0002902
2009-05-26 02:59 piotr Note Added: 0002924
2009-05-26 09:08 administrator Note Added: 0002926
2009-05-26 09:08 administrator Status new => feedback
2009-05-27 11:47 Arctures Note Added: 0002941
2009-05-27 12:35 gsking1 Note Added: 0002942
2009-05-27 12:38 Arctures Note Added: 0002943
2009-05-27 14:55 gsking1 Note Added: 0002945
2009-05-27 15:20 Arctures Note Added: 0002946
2009-05-28 04:29 gsking1 Note Added: 0002953
2009-05-29 03:44 gsking1 Note Added: 0002958
2009-05-29 09:46 Arctures Note Added: 0002960
2009-05-29 13:45 gsking1 Note Added: 0002969
2009-05-29 14:06 Arctures Note Added: 0002970
2009-05-30 01:28 gsking1 Note Added: 0002980
2009-05-30 04:47 ddennedy Note Added: 0002987
2009-05-30 04:47 ddennedy Status feedback => assigned
2009-05-30 04:47 ddennedy Assigned To => ddennedy
2009-05-30 04:53 ddennedy Note Added: 0002988
2009-05-30 05:19 ddennedy File Added: circus.mp4
2009-05-30 05:21 ddennedy Note Added: 0002989
2009-06-03 06:44 ddennedy Severity block => major
2009-06-05 07:32 ddennedy Note Added: 0003107
2009-06-05 07:32 ddennedy Status assigned => resolved
2009-06-05 07:32 ddennedy Fixed in Version => future version
2009-06-05 07:32 ddennedy Resolution open => fixed
2009-06-18 01:37 xzhayon Fixed in Version future version => Recent git
2009-06-19 02:24 xzhayon Target Version => future version
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:55 xzhayon Status resolved => closed
2010-04-11 10:48 Arctures Note Added: 0005014
2010-04-11 10:48 Arctures Status closed => feedback
2010-04-11 10:48 Arctures Resolution fixed => reopened
2010-04-11 11:32 ddennedy Note Added: 0005015
2010-04-11 13:23 Arctures Note Added: 0005016
2010-04-11 13:23 Arctures Status feedback => assigned
2010-04-11 13:24 Arctures Note Added: 0005017
2010-04-16 05:06 ddennedy Note Added: 0005038
2010-09-22 05:02 ddennedy Note Added: 0005875
2010-09-22 05:02 ddennedy Status assigned => resolved
2010-09-22 05:02 ddennedy Resolution reopened => fixed
2011-07-05 12:15 j-b-m Fixed in Version 0.7.5 => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker