Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000878KdenliveBuild Systempublic2009-05-29 23:022010-09-14 23:26
Reporterybecognee 
Assigned ToGranjow 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version0.7.3 
Target VersionFixed in Version 
Summary0000878: Stop reading video on timeline and can't restart reading
DescriptionWhen I'm reading a video on timeline (many types : mp2, mp4, Xvid), KDEnLive is stoping reading. The Program is not realy freezed (saving is possible) but I have to restart application to read video again. But it's hapen again every few second to few minits after start reading.

KDEnLivre arrête spontanément de lire la vidéo qui est sur la timeline. Cela arrive avec plusieurs types de vidéos (mp2, mp4 et XviD) Il refuse de recommencer la lecture et il est nécessaire de relancer l'application pour pouvoir lire à nouveau. Mais cela recommence de quelques secondes à quelques minutes plus tard.
Additional InformationI'm using UBUNTU (gnome) 9.04 on 2 machines (intel and AMD) and the bug is the same. It's a 9.04 updated from a 8.10 - KDEnLive was automaticaly updated from 0.7.2 to 0.7.3


Je suis UBUNTU (gnome) 9.4 et j'ai le même problèmes avec mes 2 ordi (un portable Intel et un fixe AMD)
Je suis sur un système mis à jour en 9.04 à partir d'une 8.10 (sur les deux machines) et la mise à jour s'est faite automatiquement de la 0.7.2 à la 0.7.3
Tagscrash
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0003011)
administrator (administrator)
2009-05-31 01:08

Can you create a project with the problematic clips, save it and try to play it with MLT's command line player:

inigo myproject.kdenlive

Does it also stop playing at some point?
Otherwise, the new MLT 0.4.x and the new Kdenlive 0.7.4 should be available shortly for Ubuntu, so maybe an upgrade might solve the issue.
(0003014)
ybecognee (reporter)
2009-05-31 09:31

Reading seems more stable with "inigo" command line.
He stopped only once for two consecutive readings of a 20 min project. Working with Kdenlive remains problematic.
I hope that 0.7.4 version will solve the issue. Thank you for all !
(0003150)
ybecognee (reporter)
2009-06-10 20:28

I have the same problem with 0.7.4 : The software stop reading video on timeline and can't restart reading.
I can't realy work with KDEnLive now.
I will try to re-install Ubuntu 9.04. May be it will be different than on a 9.04 updated from a 8.10.
(0003152)
jmpoure (developer)
2009-06-10 22:19

Don't reinstall Ubuntu 9.04. Upgrading is the same as installing from scratch.
(0003153)
jmpoure (developer)
2009-06-10 22:20

Could you upload media somewhere or register your camcorder so that we reproduce the crash.
(0003171)
ybecognee (reporter)
2009-06-11 23:13

My camcoder is a Canon FS100 ( http://www.canon.fr/For_Home/Product_Finder/Camcorders/flash_memory/FS100/index.asp?source=selector [^] )
Files are ".mod" renamed in ".mpg"
It's stop reading near 60s whenever sequence is on time line or in rushs
With a Samsung MX10 ( http://www.samsung.com/fr/consumer/detail/detail.do?group=camerascamcorders&type=camcorders&subtype=flashmemory&model_cd=VP-MX10/XEF [^] ) It happen the same problem.
It was reading good under Ubuntu 8.10 with 0.7.2

I will upload 2 files next time.
(0003172)
ybecognee (reporter)
2009-06-11 23:20

I have noticed that Processor is busy at 55% after bug (reading freezing), befor stopping KDEnLive. In normal reading, It's around 80%.

Mon processeur est bloqué à 55% de son utilisation tant que KDEnLive est bloqué. Il revient à 5% après l'avoir éteint. Il est autour de 80% en cours de lecture normale du'ne vidéo par KDEnLive.
(0003174)
jmpoure (developer)
2009-06-12 09:27

Please upload a file somewhere to reproduce or reproduce with the files available here: http://www.poure.com/footage/canon/hf100/ [^]
(0003241)
ybecognee (reporter)
2009-06-17 08:46

It's needing a password... (with fireftp) How can I upload it please ?
Thanks
(0003242)
administrator (administrator)
2009-06-17 10:24

I have set up a write only ftp repository and sent the infos to the reporter, will make the file available to developers as soon as it is available.
(0003304)
ybecognee (reporter)
2009-06-19 06:50

Sorry, I didn't realy anderstood how to do. Here is a file from my fs100.

http://yonnelb.free.fr/reportages/MOV020.mpg [^]

Put-it 4 or 5 times on timeline to have more than 1 min of video.

Thank you for help
(0003328)
administrator (administrator)
2009-06-19 18:14

I added 10 copies of the clip in timeline, played it several times and no problem here... I think it might be either:

* A configuration problem (old mlt version not removed from system)
* Broken version of FFmpeg (I am running latest svn)

Maybe someone else running debian or ubuntu packages can give more infos...
(0003371)
jmpoure (developer)
2009-06-22 15:47

Upgrade to Kdenlive 0.7.4 and MLT 0.4.2.

Although this seems like a minor release, the difference in precision and AVCHD handling is pretty important. A lot of work was done in this area.

Also install a recent FFmpeg version.

Sorry for the inconvenience.

Footage added to:
http://www.poure.com/footage/canon/fs100/ [^]
(0003377)
ybecognee (reporter)
2009-06-22 18:40

I'm allready runing 0.7.4 (post (0003150) ) Yesterday, I tryed to uninstall and reinstall ffmpeg (and KDEnLive) It does not change anything. I realy need KDEnLive this week. I will reinstall a pretty 9.04. If it does not work better, I will go back to 8.10 that was working well.

Thank you for all.
(0003388)
ybecognee (reporter)
2009-06-23 07:43

I have reinstalled 9.04. The problem still here !!! :-(
It was realy working with 0.7.2 under 8.10 and those files from the same cams... (7 movies but some other bugs). What is the difference betwin 0.7.2 and 0.7.(3 & 4) ?
I tried 0.7.4 under ubuntu 8.10 but I didn't found "melt" in synaptic after using this tutorial : http://kdenlive.org/forum/kdenlive-074-launchpad-debs-jaunty-and-intrepid [^]

I tried to erase /home/(votre nom)/.kde/share/config/kdenliverc
because I had some time : "The application KDEnlive (kdenlive) crashed and caused the signal 11 (SIGSEGV)."
I have seen here :
http://doc.ubuntu-fr.org/kdenlive [^]

It does not change a lot.

I have a problem to compile a project. It stoping during compilation and says :

[mp3 @ 0x9b98560]mdb:136, lastbuf:0 skipping granule 0 Last message repeated 1 times [mp3 @ 0x9b98560]mdb:136, lastbuf:0 skipping granule 1
Last message repeated 1 times [mp3 @ 0x9be7c50]mdb:136, lastbuf:0 skipping granule 0 Last message repeated 1 times
[mp3 @ 0x9be7c50]mdb:136, lastbuf:0 skipping granule 1
Last message repeated 1 times [mp3 @ 0x9be5300]mdb:136, lastbuf:0 skipping granule 0 Last message repeated 1 times [mp3 @ 0x9be5300]mdb:136, lastbuf:0 skipping granule 1
Last message repeated 1 times [mp3 @ 0x9ca79a0]mdb:136, lastbuf:0 skipping granule 0
Last message repeated 1 times [mp3 @ 0x9ca79a0]mdb:136, lastbuf:0 skipping granule 1
Last message repeated 1 times
Unable to parse option value "dv_pal": undefined constant or missing (
Last message repeated 1 times [mp3 @ 0xac0d6d0]mdb:303, lastbuf:0 skipping granule 0 Last message repeated 1 times [mp3 @ 0xac0d6d0]mdb:303, lastbuf:0 skipping granule 1
[mp3 @ 0xb23bca0]mdb:309, lastbuf:0 skipping granule 0 Last message repeated 1 times [mp3 @ 0xb23bca0]mdb:309, lastbuf:0 skipping granule 1


I'm realy despaired

I have a project to do for saturday...

Thank you for your help
(0003389)
jmpoure (developer)
2009-06-23 09:36
edited on: 2009-06-23 09:36

Did you try to uninstall everything and to use the build wizard.

apt-get remove --purge kdenlive* mlt*
Then use the build wizard.

If you still experience problems, please contact me on IRC (jmpoure), gmail (jmpoure@poure.com) so we can arrange a phone meeting. I am French like you.

(0003401)
ybecognee (reporter)
2009-06-23 20:03

I think I have resolved my problem with Kubuntu 9.04
I prefer Gnome but it's working now ! It seem's to be stable. The sound is better.

Thank you for all

You are in my gmail contacts.

If you want to see films made by my students (10 years old) :

"La brocante de Gennevilliers"
http://blip.tv/file/1676237 [^]

"Le rugby au CSMG"
http://blip.tv/file/1871800 [^]

"Les Pompiers de Gennevilliers"
http://blip.tv/file/1959544 [^]

"Le métier de vétérinaire"
http://blip.tv/file/1981831 [^]

"Un graphiste à Gennevilliers"
http://blip.tv/file/1984969 [^]

"La fête de l'internet 2009"
http://blip.tv/file/1912012 [^]

"YAGDOM, un artiste mystérieux"
http://blip.tv/file/2080135 [^]

"Le projet Globe2Child"
En cours de tentative de montage
(0003453)
ybecognee (reporter)
2009-06-25 06:57

I worked well with 0.7.4 under kubuntu 9.04. But, one time, Pulse had a problem and I had no sound.
I read on a forum that I have to install Alsa. I did it and I have found again my first problem : KDEnLive is stopping reading regularly.
I reinstall all (sorry but it's faster for me at all 45min and I'm impatient)

So, may be the bug come from alsa...

I hope that my adventures should help someboby...

Thankyou for your help.

I hope that I will come back under Gnome
(0003455)
jmpoure (developer)
2009-06-25 08:56

Glad to see you solved your problems. Kdenlive does not support PulseAudio. If you get back to Gnome and register Alsa support, Kdenlive should work as usual.

Also, keep in mind that Kdenlive 0.7.3 is deprecated.

To publish your video:
http://kdenlive.org/forum/users-forums/kdenlive-theatre [^]

Bye.
(0003519)
ybecognee (reporter)
2009-06-29 06:35

With the first maj of KDEnLive 0.7.4 under Kubuntu 9.04, it wasn't start. With the second, there is no sound :-(
I have a movie to finish with children for the 2 june...
help !
(0003524)
j-b-m (administrator)
2009-06-29 11:29

If you have no sound, the first thing to try is to change the audio driver in "Kdenlive Settings" dialog, page "Playback" you can select an audio driver (try Alsa or Pulse audio).

You should also check which SDL packages are installed: sdl-alsa, sdl-pulsaudio,...

If that does not work, have a look at bug 0000934, which suggests editing file:
$HOME/.kde/share/config/kdenliverc

and adding:
[sdl]
audiodrivername=alsa

at the end of the file.
(0003546)
ybecognee (reporter)
2009-06-29 19:42

No change with Aslsa or pulse in setting.
However, I found a solution :

Reinitializing alsa / pulse (I do not understand really the difference) :

sudo /etc/init.d/alsa-utils reset
then
sudo /etc/init.d/alsa-utils restart

(found in a forum)

And the sound is back !

Thank you very much for your help
(0003659)
ybecognee (reporter)
2009-07-11 19:03

I'm back from RMLL. I talked about my problem. Some one said me to remove PulseAudio. So I found this tutorial :
________________________________________________________________
"Je ne sais pas pour vous mais moi sous Ubuntu, j’ai un problème avec PulseAudio, surtout [...]. Voici donc une méthode pour enlever Pulse Audio et remettre la configuration Alsa par défaut !

On supprime déjà PulseAudio :

    sudo apt-get remove pulseaudio
    sudo apt-get install esound

Ensuite on fait une sauvegarde du fichier 70pulseaudio et on le supprime

sudo cp /etc/X11/Xsession.d/70pulseaudio /etc/X11/Xsession.d/70pulseaudio.back
sudo rm /etc/X11/Xsession.d/70pulseaudio

Et pour finir, on va « expliquer» à Gnome qu’on n’utilise plus PulseAudio mais Alsa… Il faut donc aller dans le menu

    Système -> Préférences -> Son

Et de repositionner dans « Conférence Audio» , la capture du son sur « ALSA»

Rendez vous ensuite dans

    Système -> Préférences -> Applications au démarrage

Et déselectionnez le « PulseAudio Session Management«

Et pour terminer, un peu de ménage dans vos fichiers perso… Rendez vous dans votre répertoire home et faites une sauvegarde / suppression des fichiers asoundrc afin que tout ceci se reconfigure avec ALSA :

    cd ~
    cp .asound* nomdefichier
    rm .asound*

Et voilàààààààààà !"
_________________________________________________________

It was here :
http://www.korben.info/desinstaller-pulse-audio-ubuntu.html [^]

Now KDEnLive works very well under Ubuntu 9.04

Thank's for all

Best regards
(0003664)
ybecognee (reporter)
2009-07-12 12:00

I made publicity for KDEnLive at RMLL... :-)
(0005228)
Granjow (developer)
2010-05-28 18:11

Thanks :)
Closing.

- Issue History
Date Modified Username Field Change
2009-05-29 23:02 ybecognee New Issue
2009-05-29 23:02 ybecognee Build/Install Method => Distribution package
2009-05-30 08:54 ybecognee Tag Attached: crash
2009-05-31 01:08 administrator Note Added: 0003011
2009-05-31 01:08 administrator Status new => feedback
2009-05-31 09:31 ybecognee Note Added: 0003014
2009-06-10 20:28 ybecognee Note Added: 0003150
2009-06-10 22:19 jmpoure Note Added: 0003152
2009-06-10 22:20 jmpoure Note Added: 0003153
2009-06-11 23:13 ybecognee Note Added: 0003171
2009-06-11 23:20 ybecognee Note Added: 0003172
2009-06-12 09:27 jmpoure Note Added: 0003174
2009-06-17 08:46 ybecognee Note Added: 0003241
2009-06-17 10:24 administrator Note Added: 0003242
2009-06-19 06:50 ybecognee Note Added: 0003304
2009-06-19 18:14 administrator Note Added: 0003328
2009-06-22 15:47 jmpoure Note Added: 0003371
2009-06-22 18:40 ybecognee Note Added: 0003377
2009-06-23 07:43 ybecognee Note Added: 0003388
2009-06-23 09:36 jmpoure Note Added: 0003389
2009-06-23 09:36 jmpoure Note Edited: 0003389
2009-06-23 20:03 ybecognee Note Added: 0003401
2009-06-25 06:57 ybecognee Note Added: 0003453
2009-06-25 08:56 jmpoure Note Added: 0003455
2009-06-29 06:35 ybecognee Note Added: 0003519
2009-06-29 11:29 j-b-m Note Added: 0003524
2009-06-29 19:42 ybecognee Note Added: 0003546
2009-07-11 19:03 ybecognee Note Added: 0003659
2009-07-12 12:00 ybecognee Note Added: 0003664
2010-05-28 18:11 Granjow Note Added: 0005228
2010-05-28 18:11 Granjow Status feedback => resolved
2010-05-28 18:11 Granjow Resolution open => no change required
2010-05-28 18:11 Granjow Assigned To => Granjow
2010-09-14 23:26 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker