Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000886KdenliveBuild Systempublic2009-06-02 11:272009-06-04 18:48
Reportervolker_holthaus 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000886: Start after compiling crashes
Descriptionkdenlive crashes after building from svn/git sources. I removed all old packages (mlt and ffmpeg). But everytime i want to start kdenlive, it crashes.

Distribution: Kubuntu Jaunty Jackealope
Additional InformationThread 1 (Thread 0xb5ce7920 (LWP 12050)):
#0 0xb80bf430 in __kernel_vsyscall ()
#1 0xb672b780 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb672b5be in sleep () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb7ed58b2 in ?? () from /usr/lib/libkdeui.so.5
0000004 0xb7ed6274 in KCrash::defaultCrashHandler () from /usr/lib/libkdeui.so.5
0000005 <signal handler called>
0000006 0xb3a63974 in ?? () from /lib/libselinux.so.1
0000007 0xb3a5cb8e in ?? () from /lib/libselinux.so.1
0000008 0xb3a551d8 in ?? () from /lib/libselinux.so.1
0000009 0xb3a65350 in _fini () from /lib/libselinux.so.1
0000010 0xb80d305f in ?? () from /lib/ld-linux.so.2
0000011 0xb80d3937 in ?? () from /lib/ld-linux.so.2
0000012 0xb6687c84 in ?? () from /lib/tls/i686/cmov/libdl.so.2
0000013 0xb80ce036 in ?? () from /lib/ld-linux.so.2
0000014 0xb668801c in ?? () from /lib/tls/i686/cmov/libdl.so.2
0000015 0xb6687cba in dlclose () from /lib/tls/i686/cmov/libdl.so.2
0000016 0xb434cb1d in mlt_register (repository=0x9eee638) at factory.c:329
0000017 0xb80b7a7b in mlt_repository_init (directory=0xb80ba51e "/usr/lib/mlt") at mlt_repository.c:99
0000018 0xb80b70b0 in mlt_factory_init (directory=0xb80ba51e "/usr/lib/mlt") at mlt_factory.c:131
0000019 0xb8087e5d in Mlt::Factory::init () from /usr/lib/libmlt++.so.2
0000020 0x0816c35a in initEffects::parseEffectFiles () at /home/volker/programme/kdenlive/kdenlive/src/initeffects.cpp:117
0000021 0x080934f8 in MainWindow (this=0x9e86b30, MltPath=@0xbfadcb88, Url=@0xbfadcb68, parent=0x0) at /home/volker/programme/kdenlive/kdenlive/src/mainwindow.cpp:140
0000022 0x0807c66c in main (argc=1, argv=0xbfadcd14) at /home/volker/programme/kdenlive/kdenlive/src/main.cpp:83
#0 0xb80bf430 in __kernel_vsyscall ()
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003047)
administrator (administrator)
2009-06-02 23:19

Can you play a clip with MLT's command line player:

melt myvideo.mpg
(0003091)
volker_holthaus (reporter)
2009-06-03 09:30

No, i get the error segmentation fault.

Greatings

Volker
(0003098)
ddennedy (developer)
2009-06-03 19:25

Works for me on jaunty. Do you have the frei0r facedetect plugin installed (locate facedetect.so)? It is a known issue that just loading that .so causes a crash.
(0003105)
volker_holthaus (reporter)
2009-06-04 10:13

I have deleted this libary, now i see the first configuration dialog, after this kdenlive crashes again. Here is the error:

Anwendung: Kdenlive (kdenlive), Signal SIGSEGV
[Current thread is 0 (LWP 7744)]

Thread 2 (Thread 0xb39e7b90 (LWP 7745)):
#0 0xb80b4430 in __kernel_vsyscall ()
#1 0xb675d7b1 in select () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb748e380 in ?? () from /usr/lib/libQtCore.so.4
0000003 0xb73bc96e in ?? () from /usr/lib/libQtCore.so.4
0000004 0xb66694ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xb676549e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb5cdc920 (LWP 7744)):
[KCrash Handler]
0000006 mlt_properties_fetch (this=0x0, name=0xb4351c44 "forced") at mlt_properties.c:348
0000007 0xb809f94f in mlt_properties_set_int (this=0x0, name=0xb4351c44 "forced", value=3) at mlt_properties.c:738
0000008 0xb434fc76 in consumer_start (parent=0x8767a50) at consumer_sdl_still.c:159
0000009 0xb80a8ac9 in mlt_consumer_start (this=0x8767a50) at mlt_consumer.c:420
0000010 0xb434f0f8 in consumer_start (parent=0x8765fa8) at consumer_sdl_preview.c:208
0000011 0xb80a8ac9 in mlt_consumer_start (this=0x8765fa8) at mlt_consumer.c:420
0000012 0xb807be50 in Mlt::Consumer::start () from /usr/lib/libmlt++.so.2
0000013 0x080b878c in Render::connectPlaylist (this=0x881fd40) at /home/volker/programme/kdenlive/kdenlive/src/renderer.cpp:968
0000014 0x080d13e2 in Render::setSceneList (this=0x881fd40, playlist=
      {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 23255}, alloc = 0, size = 0, data = 0x82b345a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, static shared_empty = {ref = {_q_value = 109}, alloc = 0, size = 0, data = 0xb75a5a6e, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0xbfcd1948, static codecForCStrings = 0x0}, position=0) at /home/volker/programme/kdenlive/kdenlive/src/renderer.cpp:868
0000015 0x080dca2b in KdenliveDoc::setSceneList (this=0x91c5b08) at /home/volker/programme/kdenlive/kdenlive/src/kdenlivedoc.cpp:257
0000016 0x080f2399 in TrackView (this=0x91c60c8, doc=0x91c5b08, parent=0x83df1c0) at /home/volker/programme/kdenlive/kdenlive/src/trackview.cpp:83
0000017 0x08092cb8 in MainWindow::newFile (this=0x83df1c0, showProjectSettings=false) at /home/volker/programme/kdenlive/kdenlive/src/mainwindow.cpp:1228
0000018 0x080965e0 in MainWindow (this=0x83df1c0, MltPath=@0xbfcd1da8, Url=@0xbfcd1d88, parent=0x0) at /home/volker/programme/kdenlive/kdenlive/src/mainwindow.cpp:368
0000019 0x0807c66c in main (argc=1, argv=0xbfcd1f34) at /home/volker/programme/kdenlive/kdenlive/src/main.cpp:83
(0003106)
volker_holthaus (reporter)
2009-06-04 10:54

I use the Build Wizard, then i can use kdenlive.

Thank you for your support.

Greatings

Volker

- Issue History
Date Modified Username Field Change
2009-06-02 11:27 volker_holthaus New Issue
2009-06-02 11:27 volker_holthaus Build/Install Method => Manual build from SVN
2009-06-02 23:19 administrator Note Added: 0003047
2009-06-02 23:19 administrator Status new => feedback
2009-06-03 09:30 volker_holthaus Note Added: 0003091
2009-06-03 19:25 ddennedy Note Added: 0003098
2009-06-04 10:13 volker_holthaus Note Added: 0003105
2009-06-04 10:54 volker_holthaus Note Added: 0003106
2009-06-04 18:48 ddennedy Status feedback => resolved
2009-06-04 18:48 ddennedy Resolution open => no change required
2009-06-04 18:48 ddennedy Assigned To => ddennedy
2009-06-04 18:48 ddennedy Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker