Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000892KdenliveUser Interfacepublic2009-06-03 11:472010-09-22 17:54
ReporterGranjow 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.8Fixed in Version0.7.8 
Summary0000892: Transitions: Random results when selecting automatic track selection
DescriptionActually, random is the wrong word because it follows a rule, but for the user it looks like random.


_How to reproduce:

I have
* A transparent PNG (Track 0)
* A video clip (Track 1)
* A colour clip, here black. (Track 2)

What I want is to always have the transparent PNG on top of the clip and to fade the clip from black (taken from the colour clip).

Only way to achive this:
1. Add video clip
2. Add PNG and select Composite transition
3. Add colour clip and add the luma transition

Does not work:
1. Add video clip
2. Add colour clip and luma transition
3. Add PNG + Composite
or
1. Add colour clip
2. Add video clip and luma
3. Add PNG and Composite


The optical timeline result is exactly the same. The rendering/preview/... result however is not.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships
related to 0000847closedj-b-m Transition: Switching track to Ā«AutomaticĀ» should update the selected track 

-  Notes
(0003094)
Granjow (developer)
2009-06-03 18:15

Sometimes it cannot even be fixed by manually setting the track, only removing the clip and adding it again works.
(0003095)
Granjow (developer)
2009-06-03 18:27

To correct the transitions as described in the note above it worked to remove the PNG and add it and Composite again.

Did that twice in the following two diffs:

===================================================================
--- AC-Fighting-2.kdenlive (Revision 336)
+++ AC-Fighting-2.kdenlive (Arbeitskopie)
@@ -266,8 +266,8 @@
   <blank length="108" />
   <entry in="0" out="103" producer="7" />
   <blank length="44" />
- <entry in="0" out="76" producer="7" />
- <blank length="45" />
+ <entry in="28" out="104" producer="7" />
+ <blank length="47" />
   <entry in="0" out="119" producer="7" />
   <blank length="28" />
   <entry in="0" out="114" producer="7" />
@@ -342,24 +342,6 @@
    <property name="reverse" >0</property>
    <property name="softness" >0</property>
   </transition>
- <transition in="303" out="379" id="transition6" >
- <property name="a_track" >3</property>
- <property name="b_track" >5</property>
- <property name="start" >0,0:100%x100%</property>
- <property name="factory" >loader</property>
- <property name="aligned" >0</property>
- <property name="mlt_type" >transition</property>
- <property name="mlt_service" >composite</property>
- <property name="automatic" >1</property>
- <property name="deinterlace" >0</property>
- <property name="distort" >0</property>
- <property name="fill" >0</property>
- <property name="geometry" >0,0:840x474:100</property>
- <property name="luma_invert" >0</property>
- <property name="operator" >over</property>
- <property name="progressive" >1</property>
- <property name="softness" >0</property>
- </transition>
   <transition in="425" out="439" id="transition7" >
    <property name="a_track" >3</property>
    <property name="b_track" >4</property>
@@ -568,8 +550,28 @@
    <property name="reverse" >1</property>
    <property name="softness" >0</property>
   </transition>
+ <transition in="303" out="379" id="transition6" >
+ <property name="a_track" >3</property>
+ <property name="b_track" >5</property>
+ <property name="start" >0,0:100%x100%</property>
+ <property name="factory" >loader</property>
+ <property name="aligned" >1</property>
+ <property name="mlt_type" >transition</property>
+ <property name="mlt_service" >composite</property>
+ <property name="automatic" >1</property>
+ <property name="deinterlace" >0</property>
+ <property name="distort" >0</property>
+ <property name="fill" >0</property>
+ <property name="geometry" >0%,0%:100%x100%:100</property>
+ <property name="luma_invert" >0</property>
+ <property name="operator" >over</property>
+ <property name="progressive" >1</property>
+ <property name="softness" >0</property>
+ <property name="force_track" >1</property>
+ <property name="luma" />
+ </transition>
  </tractor>
- <kdenlivedoc profile="/home/simon/.kde/share/apps/kdenlive/profiles//customprofile0" kdenliveversion="0.7.4 (rev. 3476)" version="0.82" zonein="0" zoneout="100" zoom="5" projectfolder="/data/video" position="165" >
+ <kdenlivedoc profile="/home/simon/.kde/share/apps/kdenlive/profiles//customprofile0" kdenliveversion="0.7.4 (rev. 3476)" version="0.82" zonein="0" zoneout="100" zoom="5" projectfolder="/data/video" position="424" >
   <tracksinfo>
    <trackinfo blind="1" mute="0" locked="0" type="audio" />
    <trackinfo blind="1" mute="0" locked="0" type="audio" />





--- AC-Fighting-2.kdenlive (Revision 337)
+++ AC-Fighting-2.kdenlive (Arbeitskopie)
@@ -267,9 +267,9 @@
   <entry in="0" out="103" producer="7" />
   <blank length="44" />
   <entry in="28" out="104" producer="7" />
- <blank length="47" />
+ <blank length="45" />
   <entry in="0" out="119" producer="7" />
- <blank length="28" />
+ <blank length="32" />
   <entry in="0" out="114" producer="7" />
   <blank length="43" />
   <entry in="0" out="236" producer="7" />
@@ -446,24 +446,6 @@
    <property name="force_track" >1</property>
    <property name="luma" />
   </transition>
- <transition in="425" out="544" id="transition15" >
- <property name="a_track" >3</property>
- <property name="b_track" >5</property>
- <property name="start" >0,0:100%x100%</property>
- <property name="factory" >loader</property>
- <property name="aligned" >0</property>
- <property name="mlt_type" >transition</property>
- <property name="mlt_service" >composite</property>
- <property name="automatic" >1</property>
- <property name="deinterlace" >0</property>
- <property name="distort" >0</property>
- <property name="fill" >0</property>
- <property name="geometry" >0,0:840x474:100</property>
- <property name="luma_invert" >0</property>
- <property name="operator" >over</property>
- <property name="progressive" >1</property>
- <property name="softness" >0</property>
- </transition>
   <transition in="366" out="379" id="transition16" >
    <property name="a_track" >3</property>
    <property name="b_track" >4</property>
@@ -570,8 +552,28 @@
    <property name="force_track" >1</property>
    <property name="luma" />
   </transition>
+ <transition in="425" out="544" id="transition15" >
+ <property name="a_track" >3</property>
+ <property name="b_track" >5</property>
+ <property name="start" >0,0:100%x100%</property>
+ <property name="factory" >loader</property>
+ <property name="aligned" >1</property>
+ <property name="mlt_type" >transition</property>
+ <property name="mlt_service" >composite</property>
+ <property name="automatic" >1</property>
+ <property name="deinterlace" >0</property>
+ <property name="distort" >0</property>
+ <property name="fill" >0</property>
+ <property name="geometry" >0%,0%:100%x100%:100</property>
+ <property name="luma_invert" >0</property>
+ <property name="operator" >over</property>
+ <property name="progressive" >1</property>
+ <property name="softness" >0</property>
+ <property name="force_track" >1</property>
+ <property name="luma" />
+ </transition>
  </tractor>
- <kdenlivedoc profile="/home/simon/.kde/share/apps/kdenlive/profiles//customprofile0" kdenliveversion="0.7.4 (rev. 3476)" version="0.82" zonein="0" zoneout="100" zoom="5" projectfolder="/data/video" position="424" >
+ <kdenlivedoc profile="/home/simon/.kde/share/apps/kdenlive/profiles//customprofile0" kdenliveversion="0.7.4 (rev. 3476)" version="0.82" zonein="0" zoneout="100" zoom="5" projectfolder="/data/video" position="431" >
   <tracksinfo>
    <trackinfo blind="1" mute="0" locked="0" type="audio" />
    <trackinfo blind="1" mute="0" locked="0" type="audio" />




Hope that helps.
(0003158)
administrator (administrator)
2009-06-11 00:52

Strange, I never noticed that... wondering if that is due to changes in MLT or was always present. The thing is that the order in which transitions are inserted changes the result.

We need to find a way to insert transitions in the correct place, that means all transitions for track 0, then all transitions for track 1, etc... will look into it.
(0003245)
Granjow (developer)
2009-06-17 10:54

Thank you.
(0005040)
j-b-m (administrator)
2010-04-18 12:36

I finally managed to (hopefully) solve that issue (svn rev. 4389). Please test and let me know if you find any corner case or side effect.
(0005341)
LeHomard (developer)
2010-07-03 13:52

Can anyone reproduce the issue ? If not I'll close the report.
(0005342)
Granjow (developer)
2010-07-03 14:13

I will check in a few days, didn't have time so far.
(0005640)
Granjow (developer)
2010-08-17 10:24

Could check now. Cannot reproduce the wrong results anymore. Thanks for fixing!

- Issue History
Date Modified Username Field Change
2009-06-03 11:47 Granjow New Issue
2009-06-03 11:47 Granjow Build/Install Method => Manual build from SVN
2009-06-03 11:48 Granjow Relationship added related to 0000847
2009-06-03 18:15 Granjow Note Added: 0003094
2009-06-03 18:27 Granjow Note Added: 0003095
2009-06-11 00:52 administrator Note Added: 0003158
2009-06-11 00:52 administrator Status new => acknowledged
2009-06-17 10:54 Granjow Note Added: 0003245
2009-06-19 02:32 xzhayon Target Version => future version
2010-04-18 12:36 j-b-m Note Added: 0005040
2010-04-18 12:36 j-b-m Assigned To => j-b-m
2010-04-18 12:36 j-b-m Status acknowledged => feedback
2010-07-03 13:52 LeHomard Note Added: 0005341
2010-07-03 14:13 Granjow Note Added: 0005342
2010-07-03 14:13 Granjow Status feedback => assigned
2010-08-17 10:24 Granjow Note Added: 0005640
2010-08-17 10:24 Granjow Status assigned => resolved
2010-08-17 10:24 Granjow Fixed in Version => Recent git
2010-08-17 10:24 Granjow Resolution open => fixed
2010-09-14 11:00 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed
2010-09-22 17:54 Granjow Target Version future version => 0.7.8


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker