Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000907KdenliveMLTpublic2009-06-10 18:042010-09-14 23:26
ReporterGranjow 
Assigned ToGranjow 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000907: Playing a video makes kdenlive crashing
DescriptionLink:
http://granjow.net/uploads/bugs/kdenlive-crashy-clip.avi [^] (5 MB)



Output of melt after I closed the window: (only once seen, perhaps also something else)
*** glibc detected *** melt: free(): invalid pointer: 0xb3ad7020 ***
======= Backtrace: =========
/lib/i686/cmov/libc.so.6[0xb7e4f1d4]
/lib/i686/cmov/libc.so.6(cfree+0x96)[0xb7e51186]
/usr/lib/libmlt.so.1[0xb7f77b9b]
======= Memory map: ========
08048000-0804d000 r-xp 00000000 08:06 1240716 /usr/bin/melt
0804d000-0804e000 rw-p 00004000 08:06 1240716 /usr/bin/melt
0962d000-099a2000 rw-p 0962d000 00:00 0 [heap]
b1974000-b1af6000 rw-p b1974000 00:00 0
b1af6000-b1af7000 ---p b1af6000 00:00 0
b1af7000-b2378000 rw-p b1af7000 00:00 0
b2479000-b267c000 rw-p b2479000 00:00 0
b277d000-b27fe000 rw-p b277d000 00:00 0
b2a00000-b2af8000 rw-p b2a00000 00:00 0
b2af8000-b2b00000 ---p b2af8000 00:00 0
b2b7f000-b2c00000 rw-p b2b7f000 00:00 0
b2c00000-b2c01000 ---p b2c00000 00:00 0
b2c01000-b3482000 rw-p b2c01000 00:00 0
b3583000-b3604000 rw-p b3583000 00:00 0
b3705000-b3807000 rw-p b3705000 00:00 0
b39d5000-b3bd8000 rw-p b39d5000 00:00 0
b3db7000-b3db8000 ---p b3db7000 00:00 0
b3db8000-b45b8000 rw-p b3db8000 00:00 0
b45b8000-b45b9000 ---p b45b8000 00:00 0
b45b9000-b4db9000 rw-p b45b9000 00:00 0
b501b000-b5025000 r-xp 00000000 08:06 558794 /lib/i686/cmov/libnss_files-2.9.so
b5025000-b5026000 r--p 00009000 08:06 558794 /lib/i686/cmov/libnss_files-2.9.so
b5026000-b5027000 rw-p 0000a000 08:06 558794 /lib/i686/cmov/libnss_files-2.9.so
b5027000-b5030000 r-xp 00000000 08:06 559643 /lib/i686/cmov/libnss_nis-2.9.so
b5030000-b5031000 r--p 00008000 08:06 559643 /lib/i686/cmov/libnss_nis-2.9.so
b5031000-b5032000 rw-p 00009000 08:06 559643 /lib/i686/cmov/libnss_nis-2.9.so
b5032000-b5047000 r-xp 00000000 08:06 558797 /lib/i686/cmov/libnsl-2.9.so
b5047000-b5048000 r--p 00014000 08:06 558797 /lib/i686/cmov/libnsl-2.9.so
b5048000-b5049000 rw-p 00015000 08:06 558797 /lib/i686/cmov/libnsl-2.9.so
b5049000-b504b000 rw-p b5049000 00:00 0
b504b000-b5052000 r-xp 00000000 08:06 558750 /lib/i686/cmov/libnss_compat-2.9.so
b5052000-b5053000 r--p 00006000 08:06 558750 /lib/i686/cmov/libnss_compat-2.9.so
b5053000-b5054000 rw-p 00007000 08:06 558750 /lib/i686/cmov/libnss_compat-2.9.so
b506f000-b526f000 r--p 00000000 08:06 1908791 /usr/lib/locale/locale-archive
b5434000-b5438000 r-xp 00000000 08:06 1240492 /usr/lib/libXfixes.so.3.1.0
b5438000-b5439000 rw-p 00003000 08:06 1240492 /usr/lib/libXfixes.so.3.1.0
b543f000-b5447000 r-xp 00000000 08:06 1240488 /usr/lib/libXcursor.so.1.0.2
b5447000-b5448000 rw-p 00007000 08:06 1240488 /usr/lib/libXcursor.so.1.0.2
b6805000-b680d000 r-xp 00000000 08:06 1240501 /usr/lib/libXrender.so.1.3.0
b680d000-b680e000 rw-p 00007000 08:06 1240501 /usr/lib/libXrender.so.1.3.0
b688c000-b68b7000 r-xp 00000000 08:06 557169 /lib/libgcc_s.so.1
b68b7000-b68b8000 rw-p 0002a000 08:06 557169 /lib/libgcc_s.so.1
b79cf000-b79d6000 r-xp 00000000 08:06 559641 /lib/i686/cmov/librt-2.9.so
b79d6000-b79d7000 r--p 00006000 08:06 559641 /lib/i686/cmov/librt-2.9.so
b79d7000-b79d8000 rw-p 00007000 08:06 559641 /lib/i686/cmov/librt-2.9.so
b7ac9000-b7b8d000 r-xp 00000000 08:06 1238312 /usr/lib/libasound.so.2.0.0
b7b8d000-b7b91000 rw-p 000c4000 08:06 1238312 /usr/lib/libasound.so.2.0.0
b7b91000-b7ba9000 r-xp 00000000 08:06 1237047 /usr/lib/libxcb.so.1.1.0
b7ba9000-b7baa000 rw-p 00017000 08:06 1237047 /usr/lib/libxcb.so.1.1.0
b7c61000-b7d7b000 r-xp 00000000 08:06 1237051 /usr/lib/libX11.so.6.2.0
b7d7b000-b7d7f000 rw-p 00119000 08:06 1237051 /usr/lib/libX11.so.6.2.0
b7d9a000-b7dbe000 r-xp 00000000 08:06 557401 /lib/i686/cmov/libm-2.9.so
b7dbe000-b7dbf000 r--p 00023000 08:06 557401 /lib/i686/cmov/libm-2.9.so
b7dbf000-b7dc0000 rw-p 00024000 08:06 557401 /lib/i686/cmov/libm-2.9.so
b7dc5000-b7dc9000 r-xp 00000000 08:06 1240490 /usr/lib/libXdmcp.so.6.0.0
b7dc9000-b7dca000 rw-p 00003000 08:06 1240490 /usr/lib/libXdmcp.so.6.0.0
b7ddb000-b7ddc000 rw-p b7ddb000 00:00 0
b7ddc000-b7dde000 r-xp 00000000 08:06 559740 /lib/i686/cmov/libdl-2.9.so
b7dde000-b7ddf000Abgebrochen
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003163)
administrator (administrator)
2009-06-11 14:04

No crash here with FFmpeg from svn build 2 days ago. Maybe that is related to your FFmpeg version. Can you play the clip with ffplay? Can you try updating FFmpeg?
(0003185)
ddennedy (developer)
2009-06-13 05:02

General media support troubleshooting consists of trying in order to see where it fails:
1) ffplay (click around on window to test seeking)
2) melt thefile
3) melt thefile in=100
(tests trimming, initial seek)
4) test in kdenlive clip monitor including seeking
5) add to timeline and test playback
(0003188)
ddennedy (developer)
2009-06-13 09:48

works fine for me with mlt git trunk and FFmpeg v0.5. I do not think this is resolvable.
(0003407)
Granjow (developer)
2009-06-23 21:32

Sorry for replying so late.
* ffplay: What exactly means Ā«seekingĀ»?
* melt: What does trimming mean? With in=100


Using a value around 200 or higher for melt makes it crash (memory access error). However the clip length is at least 300 frames.

When I run the whole clip with melt and press q I'm getting a backtrace:
Current Position: 305
*** glibc detected *** melt: free(): invalid pointer: 0xb3aa7020 ***
======= Backtrace: =========
/lib/i686/cmov/libc.so.6[0xb7e81af4]
/lib/i686/cmov/libc.so.6(cfree+0x96)[0xb7e83a96]
/usr/lib/libmlt.so.1[0xb7fa89fb]
======= Memory map: ========
08048000-0804d000 r-xp 00000000 08:06 1239992 /usr/bin/melt
0804d000-0804e000 rw-p 00004000 08:06 1239992 /usr/bin/melt
09ea1000-0a20c000 rw-p 00000000 00:00 0 [heap]
b1900000-b192a000 rw-p 00000000 00:00 0
b192a000-b1a00000 ---p 00000000 00:00 0
b1b02000-b1c84000 rw-p 00000000 00:00 0
b1c84000-b1c85000 ---p 00000000 00:00 0
b1c85000-b2506000 rw-p 00000000 00:00 0
b2607000-b280a000 rw-p 00000000 00:00 0
b290b000-b298c000 rw-p 00000000 00:00 0
b2a8d000-b2b0e000 rw-p 00000000 00:00 0
b2c0f000-b2c90000 rw-p 00000000 00:00 0
b2d91000-b2e12000 rw-p 00000000 00:00 0
b2f13000-b2f94000 rw-p 00000000 00:00 0
b2f94000-b2f95000 ---p 00000000 00:00 0
b2f95000-b3795000 rw-p 00000000 00:00 0
b37c5000-b3846000 rw-p 00000000 00:00 0
b39a5000-b3ca9000 rw-p 00000000 00:00 0
b3df6000-b3df7000 ---p 00000000 00:00 0
b3df7000-b45f7000 rw-p 00000000 00:00 0
b45f7000-b45f8000 ---p 00000000 00:00 0
b45f8000-b4df8000 rw-p 00000000 00:00 0
b505a000-b5064000 r-xp 00000000 08:06 557333 /lib/i686/cmov/libnss_files-2.9.so
b5064000-b5065000 r--p 00009000 08:06 557333 /lib/i686/cmov/libnss_files-2.9.so
b5065000-b5066000 rw-p 0000a000 08:06 557333 /lib/i686/cmov/libnss_files-2.9.so
b5066000-b506f000 r-xp 00000000 08:06 557366 /lib/i686/cmov/libnss_nis-2.9.so
b506f000-b5070000 r--p 00008000 08:06 557366 /lib/i686/cmov/libnss_nis-2.9.so
b5070000-b5071000 rw-p 00009000 08:06 557366 /lib/i686/cmov/libnss_nis-2.9.so
b5071000-b5086000 r-xp 00000000 08:06 557343 /lib/i686/cmov/libnsl-2.9.so
b5086000-b5087000 r--p 00014000 08:06 557343 /lib/i686/cmov/libnsl-2.9.so
b5087000-b5088000 rw-p 00015000 08:06 557343 /lib/i686/cmov/libnsl-2.9.so
b5088000-b508a000 rw-p 00000000 00:00 0
b508a000-b5091000 r-xp 00000000 08:06 557328 /lib/i686/cmov/libnss_compat-2.9.so
b5091000-b5092000 r--p 00006000 08:06 557328 /lib/i686/cmov/libnss_compat-2.9.so
b5092000-b5093000 rw-p 00007000 08:06 557328 /lib/i686/cmov/libnss_compat-2.9.so
b50ae000-b52ae000 r--p 00000000 08:06 1253414 /usr/lib/locale/locale-archive
b5473000-b5477000 r-xp 00000000 08:06 1240492 /usr/lib/libXfixes.so.3.1.0
b5477000-b5478000 rw-p 00003000 08:06 1240492 /usr/lib/libXfixes.so.3.1.0
b547e000-b5486000 r-xp 00000000 08:06 1240488 /usr/lib/libXcursor.so.1.0.2
b5486000-b5487000 rw-p 00007000 08:06 1240488 /usr/lib/libXcursor.so.1.0.2
b6844000-b684c000 r-xp 00000000 08:06 1240501 /usr/lib/libXrender.so.1.3.0
b684c000-b684d000 rw-p 00007000 08:06 1240501 /usr/lib/libXrender.so.1.3.0
b68cb000-b68f5000 r-xp 00000000 08:06 557084 /lib/libgcc_s.so.1
b68f5000-b68f6000 rw-p 00029000 08:06 557084 /lib/libgcc_s.so.1
b7a02000-b7a09000 r-xp 00000000 08:06 557365 /lib/i686/cmov/librt-2.9.so
b7a09000-b7a0a000 r--p 00006000 08:06 557365 /lib/i686/cmov/librt-2.9.so
b7a0a000-b7a0b000 rw-p 00007000 08:06 557365 /lib/i686/cmov/librt-2.9.so
b7afc000-b7bc0000 r-xp 00000000 08:06 1238312 /usr/lib/libasound.so.2.0.0
b7bc0000-b7bc4000 rw-p 000c4000 08:06 1238312 /usr/lib/libasound.so.2.0.0
b7bc4000-b7bdc000 r-xp 00000000 08:06 1237047 /usr/lib/libxcb.so.1.1.0
b7bdc000-b7bdd000 rw-p 00017000 08:06 1237047 /usr/lib/libxcb.so.1.1.0
b7c94000-b7dae000 r-xp 00000000 08:06 1237051 /usr/lib/libX11.so.6.2.0
b7dae000-b7db2000 rw-p 00119000 08:06 1237051 /usr/lib/libX11.so.6.2.0
b7dcd000-b7df1000 r-xp 00000000 08:06 557326 /lib/i686/cmov/libm-2.9.so
b7df1000-b7df2000 r--p 00023000 08:06 557326 /lib/i686/cmov/libm-2.9.so
b7df2000-b7df3000 rw-p 00024000 08:06 557326 /lib/i686/cmov/libm-2.9.so
b7df8000-b7dfc000 r-xp 00000000 08:06 1240490 /usr/lib/libXdmcp.so.6.0.0
b7dfc000-b7dfd000 rw-p 00003000 08:06 1240490 /usr/lib/libXdmcp.so.6.0.0
b7e0e000-b7e0f000 rw-p 00000000 00:00 0
b7e0f000-b7e11000 r-xp 00000000 08:06 557393 /lib/i686/cmov/libdl-2.9.so
b7eAbgebrochen
(0005231)
Granjow (developer)
2010-05-28 21:00

Closing now.

ffplay has become quite cool in the meantime. Seems to be a faulty video file.

Thanks for your help, Dan.

[mpeg4 @ 0xeffd60]Invalid and inefficient vfw-avi packed B frames detected
[mp3 @ 0xebee50]Header missing 249KB vq= 3097KB sq= 0B f=0/0
    Last message repeated 2 times0KB vq= 0KB sq= 0B f=0/0
[mp3 @ 0xebee50]incomplete frame
Seek to 83% ( 0:00:13) of total duration ( 0:00:16) f=0/0
[mpeg4 @ 0xeffd60]Invalid and inefficient vfw-avi packed B frames detected
[mp3 @ 0xebee50]Header missing
ALSA lib pcm.c:7236:(snd_pcm_recover) underrun occured
    Last message repeated 2 times0KB vq= 71KB sq= 0B f=0/0
[mp3 @ 0xebee50]incomplete frame
  16.22 A-V: -4.455 s:0.0 aq= 0KB vq= 0KB sq= 0B f=0/0

- Issue History
Date Modified Username Field Change
2009-06-10 18:04 Granjow New Issue
2009-06-10 18:04 Granjow Build/Install Method => Manual build from SVN
2009-06-11 14:04 administrator Note Added: 0003163
2009-06-11 14:04 administrator Status new => feedback
2009-06-13 05:02 ddennedy Note Added: 0003185
2009-06-13 09:48 ddennedy Note Added: 0003188
2009-06-23 21:32 Granjow Note Added: 0003407
2010-05-28 20:53 Granjow Description Updated View Revisions
2010-05-28 21:00 Granjow Note Added: 0005231
2010-05-28 21:00 Granjow Status feedback => new
2010-05-28 21:00 Granjow Status new => resolved
2010-05-28 21:00 Granjow Resolution open => no change required
2010-05-28 21:00 Granjow Assigned To => Granjow
2010-09-14 23:26 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker