Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000924KdenliveUser Interfacepublic2009-06-17 22:352009-07-01 21:56
ReporterGranjow 
Assigned Toadministrator 
PriorityimmediateSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000924: Resizing clip causes 2 frames offset
Description(read notes)
In fact it has moved EVERY SINGLE CLIP on my track 0, although I've used the spacer tool about at the end of the project.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships
has duplicate 0000904closedj-b-m Position of clip changes magically 

-  Notes
(0003264)
Granjow (developer)
2009-06-17 22:41

Additional Information: They have been moved by 2 frames to the right. Their effects not.

Clips on track 2 have moved too. Maybe only all clips on track 1?
(0003268)
Granjow (developer)
2009-06-17 22:57

I think this time I'm wrong: Occurs over and over again, but I only used the Spacer Tool once. After closing and re-opening the project.

Who's gonna pay me a new mouse wheel for scrolling through the timeline over and over again?
(0003269)
Granjow (developer)
2009-06-17 23:04

God I'm fucking getting mad! I just moved over 40 clips back to their correct position, saved the project and loaded it again just to make sure.

Now All clips on track 1 have moved two frames rightwards.

I'd already be rendering without this bug. Dammit.
At least now I know a situation where unlocking the Logitech G9's mouse wheel allows to work faster.

Transitions still at the same place.
(0003271)
Granjow (developer)
2009-06-17 23:15

SVN diff: In r368 I've adjusted ALL clips on track 1 (which were about 20 or 30). Are there 20 or 30 changes in the .kdenlive file? NO! In fact, nothing at all has changed, after just loading the project again, all clips were at the same position as before adjusting.

--- AC-Fighting-2.kdenlive (Revision 367)
+++ AC-Fighting-2.kdenlive (Revision 368)
@@ -2123,7 +2123,7 @@
     <property name="end" >0</property>
    </filter>
   </entry>
- <blank length="13" />
+ <blank length="11" />
   <entry in="124" out="209" producer="120_1" >
    <filter in="205" out="210" id="filter5" >
     <property name="track" >0</property>
@@ -3208,7 +3208,7 @@
   <entry in="0" out="48" producer="37" />
   <blank length="112" />
   <entry in="0" out="150" producer="39_1" />
- <blank length="115" />
+ <blank length="113" />
   <entry in="0" out="600" producer="41_1" />
   <blank length="198" />
   <entry in="0" out="172" producer="43_4" />
@@ -3294,7 +3294,7 @@
   <entry in="0" out="96" producer="7" />
   <blank length="17" />
   <entry in="0" out="129" producer="7" />
- <blank length="16" />
+ <blank length="14" />
   <entry in="0" out="174" producer="7" />
   <blank length="11" />
   <entry in="0" out="83" producer="7" />
@@ -4928,7 +4928,7 @@
    <property name="softness" >0</property>
   </transition>
  </tractor>
- <kdenlivedoc profile="/home/simon/.kde/share/apps/kdenlive/profiles//customprofile0" kdenliveversion="0.7.4 (rev. 3556)" version="0.83" zonein="0" zoneout="100" zoom="3" projectfolder="/data/video/Fighting2" position="14928" >
+ <kdenlivedoc profile="/home/simon/.kde/share/apps/kdenlive/profiles//customprofile0" kdenliveversion="0.7.4 (rev. 3556)" version="0.83" zonein="0" zoneout="100" zoom="10" projectfolder="/data/video/Fighting2" position="6643" >
   <profileinfo width="840" display_aspect_den="79" frame_rate_den="1" description="AC Special" height="474" frame_rate_num="30" display_aspect_num="140" progressive="1" sample_aspect_num="1" sample_aspect_den="1" />
   <tracksinfo>
    <trackinfo blind="1" mute="0" locked="0" type="audio" />
(0003273)
Granjow (developer)
2009-06-17 23:39

Okay, this was too fast now. All but 2 clips were at the correct position. Didn't have to change a lot. For the moment it seems to be okay ...

--- AC-Fighting-2.kdenlive (Revision 368)
+++ AC-Fighting-2.kdenlive (Arbeitskopie)
@@ -9,7 +9,7 @@
   <property name="mlt_service" >colour</property>
  </producer>
  <playlist id="black_track" >
- <entry in="0" out="25589" producer="black" />
+ <entry in="0" out="14999" producer="black" />
  </playlist>
  <producer in="0" out="4611" id="115_3" >
   <property name="mlt_type" >producer</property>
@@ -3204,11 +3204,11 @@
   <entry in="0" out="95" producer="35" />
   <blank length="236" />
   <entry in="0" out="226" producer="130" />
- <blank length="61" />
+ <blank length="59" />
   <entry in="0" out="48" producer="37" />
   <blank length="112" />
   <entry in="0" out="150" producer="39_1" />
- <blank length="113" />
+ <blank length="115" />
   <entry in="0" out="600" producer="41_1" />
   <blank length="198" />
   <entry in="0" out="172" producer="43_4" />
@@ -4928,7 +4928,7 @@
    <property name="softness" >0</property>
   </transition>
  </tractor>
- <kdenlivedoc profile="/home/simon/.kde/share/apps/kdenlive/profiles//customprofile0" kdenliveversion="0.7.4 (rev. 3556)" version="0.83" zonein="0" zoneout="100" zoom="10" projectfolder="/data/video/Fighting2" position="6643" >
+ <kdenlivedoc profile="/home/simon/.kde/share/apps/kdenlive/profiles//customprofile0" kdenliveversion="0.7.4 (rev. 3556)" version="0.83" zonein="0" zoneout="100" zoom="4" projectfolder="/data/video/Fighting2" position="6334" >
   <profileinfo width="840" display_aspect_den="79" frame_rate_den="1" description="AC Special" height="474" frame_rate_num="30" display_aspect_num="140" progressive="1" sample_aspect_num="1" sample_aspect_den="1" />
   <tracksinfo>
    <trackinfo blind="1" mute="0" locked="0" type="audio" />
(0003274)
administrator (administrator)
2009-06-18 00:23

I just fixed a bug that caused a 2 frame offset when resizing a clip end, that was maybe your issue...
(0003275)
Granjow (developer)
2009-06-18 00:29

Great! :)
That suits perfectly; I've added a new text clip at 3:22 and that's where the mess has started.

- Issue History
Date Modified Username Field Change
2009-06-17 22:35 Granjow New Issue
2009-06-17 22:35 Granjow Build/Install Method => Manual build from SVN
2009-06-17 22:41 Granjow Note Added: 0003264
2009-06-17 22:57 Granjow Note Added: 0003268
2009-06-17 23:04 Granjow Note Added: 0003269
2009-06-17 23:15 Granjow Note Added: 0003271
2009-06-17 23:15 Granjow Priority normal => immediate
2009-06-17 23:39 Granjow Note Added: 0003273
2009-06-18 00:23 administrator Note Added: 0003274
2009-06-18 00:29 Granjow Note Added: 0003275
2009-06-18 00:33 Granjow Summary Spacer Tool moves clips => Resizing clip causes 2 frames offset
2009-06-18 00:33 Granjow Description Updated
2009-06-18 00:34 Granjow Status new => resolved
2009-06-18 00:34 Granjow Fixed in Version => Recent git
2009-06-18 00:34 Granjow Resolution open => fixed
2009-06-18 00:34 Granjow Assigned To => Granjow
2009-06-19 02:25 xzhayon Target Version => future version
2009-06-19 08:56 Granjow Status resolved => assigned
2009-06-19 08:56 Granjow Assigned To Granjow => administrator
2009-06-19 08:57 Granjow Status assigned => resolved
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-06-27 15:39 Granjow Relationship added has duplicate 0000904
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:56 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker