Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000934KdenliveMLTpublic2009-06-19 09:092010-02-02 10:38
Reporterrico 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.6 
Summary0000934: no sound at all from around r3553
Descriptioni load any kind of movie format, video plays fine but i get no sound at at all,
terminal says:

SDL failed to open audio: No available audio device

it was working fine untill now

ubuntu 9.04_64
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0003491)
CedricR (reporter)
2009-06-26 15:06

If it is can help you,
I have exactly problem with an ArchLinux distribution, when in I have svn sources since the R3500.

With kind regards,

CedricR
(0003492)
administrator (administrator)
2009-06-26 21:25

Can you hear the sound when playing a video from a terminal using MLT's player:

melt myvideo.mpg
(0003501)
rico (reporter)
2009-06-27 12:42

yes using melt from the terminal the sound is working.
(0003502)
j-b-m (administrator)
2009-06-27 13:08

Ok, then you probably have a bad sdl config somewhere in Kdenlive. Can you please open the file:

$HOME/.kde/share/config/kdenliverc in a text editor. There is probably a section called [sdl]. What do you have in it?

For example, something like:

[sdl]
audiodrivername=alsa

Please paste your infos here. Removing the file $HOME/.kde/share/config/kdenliverc will probably bring the sound back in Kdenlive
(0003503)
rico (reporter)
2009-06-27 13:51

there's no section called [sdl] in my kdenliverc file..
removing the file doesn't change anything..

here's the full kdenliverc content:

[DownloadDialog Settings]
Height 1200=400
Width 1920=700

[Locale]
Language=en_US

[MainWindow]
Height 1200=795
State=AAAA/wAAAAD9AAAAAQAAAAIAAATjAAABwfwBAAAABPwAAAAAAAABbwAAATMA////+gAAAAEBAAAAA/sAAAAYAHAAcgBvAGoAZQBjAHQAXwB0AHIAZQBlAQAAAAD/////AAAATQEAAAX7AAAAGABlAGYAZgBlAGMAdABfAHMAdABhAGMAawEAAAAA/////wAAAPcBAAAF+wAAABQAdAByAGEAbgBzAGkAdABpAG8AbgEAAAAA/////wAAATMBAAAF+wAAABYAZQBmAGYAZQBjAHQAXwBsAGkAcwB0AQAAAXIAAAEMAAAAkwEAAAX8AAACgQAAAWAAAADhAP////oAAAABAQAAAAP7AAAAGABjAGwAaQBwAF8AbQBvAG4AaQB0AG8AcgEAAAAA/////wAAAE0BAAAF+wAAAB4AcAByAG8AagBlAGMAdABfAG0AbwBuAGkAdABvAHIBAAAAAP////8AAABNAQAABfsAAAAcAHIAZQBjAG8AcgBkAF8AbQBvAG4AaQB0AG8AcgEAAAAA/////wAAAOEBAAAF+wAAABgAdQBuAGQAbwBfAGgAaQBzAHQAbwByAHkBAAAD5AAAAP8AAABNAQAABQAABOMAAAD5AAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAIAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAA/////wAAAAAAAAAAAAAAGABlAHgAdAByAGEAVABvAG8AbABCAGEAcgEAAAFP/////wAAAAAAAAAA
Width 1920=1251

[MainWindow][Toolbar extraToolBar]
Index=1
ToolButtonStyle=TextBesideIcon

[MainWindow][Toolbar mainToolBar]
Index=0

[Project Tree]
columns=\x00\x00\x00ÿ\x00\x00\x00\x00\x00\x00\x00\x01\x00\x00\x00\x00\x00\x00\x00\x01\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x04\x08\x00\x00\x00\x01\x00\x00\x00\x03\x00\x00\x00d\x00\x00\x01q\x00\x00\x00\x04\x01\x01\x00\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00dÿÿÿÿ\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x03\x00\x00\x00È\x00\x00\x00\x02\x00\x00\x00\x00\x00\x00\x00©\x00\x00\x00\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x01\x00\x00\x00\x00

[capture]
dvgrab_path=/usr/bin/dvgrab
video4capture=-f oss -i /dev/dsp -f video4linux2 -s 320x240 -r 15 -i /dev/video0

[display]
audiothumbnails=false

[env]
mltpath[$e]=$HOME/kdenlive/share/mlt/profiles/
rendererpath[$e]=$HOME/kdenlive/bin/melt

[unmanaged]
audiocodecs=ac3,alac,flac,mp2,nellymoser,sonic,sonicls,wmav1,wmav2,pcm_alaw,pcm_f32be,pcm_f32le,pcm_f64be,pcm_f64le,pcm_mulaw,pcm_s8,pcm_s16be,pcm_s16le,pcm_s24be,pcm_s24daud,pcm_s24le,pcm_s32be,pcm_s32le,pcm_u8,pcm_u16be,pcm_u16le,pcm_u24be,pcm_u24le,pcm_u32be,pcm_u32le,pcm_zork,roq_dpcm,adpcm_adx,g726,adpcm_ima_qt,adpcm_ima_wav,adpcm_ms,adpcm_swf,adpcm_yamaha,libfaac,libmp3lame,libvorbis
autoaudiodrivername=pulse
producerslist=melt,melt_file,libdv,frei0r.ising0r,frei0r.lissajous0r,frei0r.nois0r,frei0r.onecol0r,frei0r.partik0l,vorbis,avformat,sdl_image,qimage,color,colour,consumer,loader,hold,noise,ppm,framebuffer,slowmotion,kino,pango,pixbuf,xml,xml-string,pgm
project_display_ratio=1.77777777777778
supportedformats=ac3,adts,aiff,amr,asf,ass,asf_stream,au,avi,avm2,crc,daud,dirac,dnxhd,dts,dv,eac3,ffm,flac,flv,framecrc,gif,gxf,h261,h263,h264,image2,image2pipe,ipod,m4v,matroska,matroska,mjpeg,mlp,mmf,mov,mp2,mp3,mp4,mpeg,vcd,mpeg1video,dvd,svcd,mpeg2video,vob,mpegts,mpjpeg,mxf,mxf_d10,null,nut,ogg,alaw,mulaw,f64be,f64le,f32be,f32le,s32be,s32le,s24be,s24le,s16be,s16le,s8,u32be,u32le,u24be,u24le,u16be,u16le,u8,psp,rawvideo,rm,roq,sox,swf,3g2,3gp,truehd,rcv,voc,wav,yuv4mpegpipe
videocodecs=asv1,asv2,bmp,dnxhd,dvvideo,ffv1,ffvhuff,flashsv,flv,gif,h261,h263,h263p,huffyuv,jpegls,ljpeg,mjpeg,mpeg1video,mpeg2video,mpeg4,msmpeg4v1,msmpeg4v2,msmpeg4,pam,pbm,pcx,pgm,pgmyuv,png,ppm,qtrle,rawvideo,roqvideo,rv10,rv20,sgi,snow,svq1,targa,tiff,v210,wmv1,wmv2,zlib,zmbv,libtheora,libx264,libxvid

[version]
version=0.7.4
(0003504)
rico (reporter)
2009-06-27 13:55

deleting the file doesn't solve the problem, it keeps on omitting the [sdl] section.
I added manually to the file the line you proposed

[sdl]
audiodrivername=alsa

and the sound came back... but that's a workaround not a fix..
(0003505)
rico (reporter)
2009-06-27 14:06

ok,

the playback preferences in kdenlive was set to "automatic" = no [sdl] section in the kdenliverc file.

switching it to "alsa" and restarting kdenlive added the "[sdl]audiodrivername=alsa" to the kdenliverc file and the sound was working again.

the thing is that selecting "automatic" for the audio in the prefs was working until recently, so maybe something changed in the automatic audio driver selector.

Anyway thank you for your help, my sound is working again!
(0003516)
CedricR (reporter)
2009-06-28 18:48

Dear Rico,

Thank you for this workaround, it is working for me too !
I hope it will be fix.
Thank you all for your effort.

With kind regards,

CedricR
(0003525)
j-b-m (administrator)
2009-06-29 11:37

Ok, I found the problem. It is caused by commit 3519, which tries to autodetect your video driver. In you case, it detected the pulseaudio driver (there is an entry in your config file saying: autoaudiodrivername=pulse).

I will try to see what's the best fix for that...
(0003528)
xzhayon (developer)
2009-06-29 12:42
edited on: 2009-06-29 12:43

yes, i'm sorry for this, i noticed this problem last night on irc
i think the best solution at the moment would be commenting out the detection part and see if it can be fixed or it has to be removed. unfortunately kdenlive can crash without it, but it's an sdl problem i guess, then if we have to choose i vote for removing it

(p.s.: sorry for not making it into [sdl], noticed that last night too)

(0003549)
j-b-m (administrator)
2009-06-30 01:38

I am wondering if Rico and cedricR have the pulseaudio server running, but their system sound still going through alsa?

Anyways, SDL sound should be working by default without having to set any special audio driver (which is the way the "automatic" option did before). If that does not work, I consider it to be a distro bug. So for the moment I will comment out the audio "autodetection" code that was added in rev, 3519.
(0003551)
rico (reporter)
2009-06-30 01:51

i'm using ubuntu, so i think it runs with pulseaudio server, i didn't change anything to the default config of ubuntu.. all system sound is on autodetect.. so i don't know exactly which one it is using... or how to check it.
(0003576)
CedricR (reporter)
2009-07-01 21:11

I have also pulseaudio server installed but, if I change alsa to auto or pulseaudio with the kdenlive setup menu nothing change after.
autoaudiodrivername property still equal to alsa in kdenliverc file (svn 3716).
(0003594)
xzhayon (developer)
2009-07-03 18:03

the issue should be fixed now... setting the audio driver to auto should work, unless sdl has problems (which, understand, cannot be addressed to us)
can you reproduce?
(0003595)
CedricR (reporter)
2009-07-03 18:52
edited on: 2009-07-03 19:04

I have droped my kdenliverc file, compiled the last svn release 3726 and it is working now with default auto mode.

Thank you very much for your nice work !

I think you can close this issue.


- Issue History
Date Modified Username Field Change
2009-06-19 09:09 rico New Issue
2009-06-19 09:09 rico Build/Install Method => Build Wizard
2009-06-26 15:06 CedricR Note Added: 0003491
2009-06-26 21:25 administrator Note Added: 0003492
2009-06-27 12:42 rico Note Added: 0003501
2009-06-27 13:08 j-b-m Note Added: 0003502
2009-06-27 13:08 j-b-m Status new => feedback
2009-06-27 13:51 rico Note Added: 0003503
2009-06-27 13:55 rico Note Added: 0003504
2009-06-27 14:06 rico Note Added: 0003505
2009-06-28 18:48 CedricR Note Added: 0003516
2009-06-29 11:37 j-b-m Note Added: 0003525
2009-06-29 11:37 j-b-m Status feedback => acknowledged
2009-06-29 11:39 j-b-m Target Version => 0.7.5
2009-06-29 12:42 xzhayon Note Added: 0003528
2009-06-29 12:43 xzhayon Note Edited: 0003528 View Revisions
2009-06-30 01:38 j-b-m Note Added: 0003549
2009-06-30 01:51 rico Note Added: 0003551
2009-07-01 21:11 CedricR Note Added: 0003576
2009-07-03 18:03 xzhayon Note Added: 0003594
2009-07-03 18:03 xzhayon Status acknowledged => feedback
2009-07-03 18:52 CedricR Note Added: 0003595
2009-07-03 18:53 CedricR Note Edited: 0003595 View Revisions
2009-07-03 19:03 CedricR Note Edited: 0003595 View Revisions
2009-07-03 19:04 CedricR Note Edited: 0003595 View Revisions
2009-10-02 13:05 j-b-m Status feedback => resolved
2009-10-02 13:05 j-b-m Resolution open => fixed
2009-10-02 13:05 j-b-m Assigned To => j-b-m
2009-10-08 20:21 j-b-m Fixed in Version => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker