Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000952KdenliveRenderingpublic2009-06-22 14:242010-12-26 10:40
Reportergsking1 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionopen 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000952: Scripts do not run after clicking start.
DescriptionI have a problem where the script does not run/render after queuing it. For example:
-I select the render options and then click on the generate script button.
-I can do that a few times to set up different renders and it queues up separate scripts for each as expected.
-Then I switch tab and start a few of the scripts, still okay.
-The first script usually runs, but the next script that is queued indicates it's waiting never starts when the first one ends. I also cannot re-start the script after it doesn't work the first time.

Currently on most recent SVN/GIT of kdenlive and mlt as of June 21, 2009
Thanks, Geoff
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003369)
gsking1 (reporter)
2009-06-22 14:25

I think the category should be classified as "rendering" rather than MLT. Sorry for that.
(0003406)
administrator (administrator)
2009-06-23 21:27

Ok, I could reproduce the problem when the script has a wrong command in it. I just committed a few checks that should help prevent such issues in the future (at least it indicates a wrong script with a special icon).
(0003452)
gsking1 (reporter)
2009-06-25 02:16

I tried again using rev. 3633. This time it stopped on the second file and said something like 'rendering crashed' on the line and had the red icon which is nice. The next 3 files queued did not start and had the paused icon.

I then went into the script folder and manually ran each of the scripts (for example sh script003.sh) and each ran fine and generated files seem okay. There were no crash messages they do not appear to crash. Why would the script job queue think rendering was not successful and stop?

Also, it may be better to continue on to the next queued job in the event of an error.

Thanks for all your effort. Geoff
(0003496)
gsking1 (reporter)
2009-06-27 03:23

I wanted to add that it works as expected if I use the "Render to File" option.
(0003806)
gsking1 (reporter)
2009-08-17 03:57

FYI - I'm still having problems with the generate script option. The script file shows up under the Scripts tab, but the only option that is clickable is "Close". The "Start Script" and "Delete Script" options are grayed out.

As noted above, rendering works as expected if I use the "Render to File" option.

System is now using latest kdenlive svn (rev3831) and latest mlt.

Thanks, Geoff
(0006228)
Granjow (developer)
2010-12-26 10:40

I can confirm that. The problem still exists in current SVN.

- Issue History
Date Modified Username Field Change
2009-06-22 14:24 gsking1 New Issue
2009-06-22 14:24 gsking1 Build/Install Method => Manual build from SVN
2009-06-22 14:25 gsking1 Note Added: 0003369
2009-06-23 19:08 administrator Category MLT => Rendering
2009-06-23 21:27 administrator Note Added: 0003406
2009-06-23 21:27 administrator Status new => feedback
2009-06-25 02:16 gsking1 Note Added: 0003452
2009-06-27 03:23 gsking1 Note Added: 0003496
2009-08-17 03:57 gsking1 Note Added: 0003806
2010-12-26 10:40 Granjow Note Added: 0006228
2010-12-26 10:40 Granjow Target Version => future version


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker