Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000954KdenliveCapturepublic2009-06-23 13:392011-04-27 23:55
Reporternadavkav 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000954: unable to record with v4l2
Descriptioni use the default setting for video4linux2
and after a sec or two of tring to initialize i get a dialog
that says "clip XX is invalid, will be removing from project..."
i can not start a new recording session. i have to quit kdenline and start it again. (still not recording)
Tagsold
Build/Install MethodManual build from SVN
Attached Files

- Relationships
parent of 0000726closed needed: libv4l and associated application patches (or "gspca stopped working in 2.6.27") 

-  Notes
(0003466)
administrator (administrator)
2009-06-26 00:14

Could you try to see if suggestion of bug 726 solves your problem, by starting kdenlive from a terminal with the following command:

LD_PRELOAD="/usr/lib/libv4l/v4l2convert.so" kdenlive
(0003511)
nadavkav (reporter)
2009-06-27 22:21

it did not :-(

here is the output of mplayer after it crashed (while initializing)

MPlayer dev-SVN-r29358Terminal type `unknown' is not defined.

mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x333b9a0]moov atom not found
LAVF_header: av_open_input_stream() failed
ID_VIDEO_ID=0
libavformat file format detected.
LAVF_header: av_open_input_stream() failed
RAWDV file format detected.
ID_VIDEO_ID=0
ID_AUDIO_ID=0
VIDEO: [DVSD] 720x480 24bpp 29.970 fps 0.0 kbps ( 0.0 kbyte/s)
ID_FILENAME=/root/capture0000.mp4
ID_DEMUXER=rawdv
ID_VIDEO_FORMAT=DVSD
ID_VIDEO_BITRATE=0
ID_VIDEO_FPS=29.970
ID_AUDIO_FORMAT=RADV
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=0
ID_AUDIO_NCH=0
ID_SEEKABLE=1
ID_CHAPTERS=0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat -1
Selected video codec: [ffdv] vfm: ffmpeg (FFmpeg DV)
==========================================================================
ID_VIDEO_CODEC=ffdv
==========================================================================
Opening audio decoder: [libdv] Raw DV Audio Decoder
Unknown/missing audio format -> no sound
ADecoder init failed :(
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
Cannot find codec 'dvaudio' in libavcodec...
ADecoder init failed :(
ADecoder init failed :(
Cannot find codec for audio format 0x56444152.
Audio: no sound
Starting playback...
VDec: vo config request - 720 x 480 (preferred colorspace: Planar 411P)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar 411P as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
SwScaler: reducing / aligning filtersize 1 -> 4
SwScaler: reducing / aligning filtersize 5 -> 4
SwScaler: reducing / aligning filtersize 1 -> 1
SwScaler: reducing / aligning filtersize 9 -> 8
[swscaler @ 0xe11f80]BICUBIC scaler, from yuv411p to yuv420p using MMX2
[swscaler @ 0xe11f80]using 4-tap MMX scaler for horizontal luminance scaling
[swscaler @ 0xe11f80]using 4-tap MMX scaler for horizontal chrominance scaling
[swscaler @ 0xe11f80]using 1-tap MMX "scaler" for vertical scaling (YV12 like)
[swscaler @ 0xe11f80]720x480 -> 720x480
VO: [xv] 720x480 => 720x480 Planar YV12
AC EOB marker is absent pos=64
AC EOB marker is absent pos=71
AC EOB marker is absent pos=69
AC EOB marker is absent pos=71
AC EOB marker is absent pos=64
AC EOB marker is absent pos=74
AC EOB marker is absent pos=89
AC EOB marker is absent pos=70
AC EOB marker is absent pos=64
AC EOB marker is absent pos=75
AC EOB marker is absent pos=69
AC EOB marker is absent pos=64
AC EOB marker is absent pos=64
AC EOB marker is absent pos=66
AC EOB marker is absent pos=98
AC EOB marker is absent pos=73
AC EOB marker is absent pos=85
AC EOB marker is absent pos=66
AC EOB marker is absent pos=64
AC EOB marker is absent pos=64
AC EOB marker is absent pos=65
AC EOB marker is absent pos=64
AC EOB marker is absent pos=64
AC EOB marker is absent pos=64
AC EOB marker is absent pos=74
AC EOB marker is absent pos=64
AC EOB marker is absent pos=68
AC EOB marker is absent pos=68
AC EOB marker is absent pos=81
AC EOB marker is absent pos=64
AC EOB marker is absent pos=69
AC EOB marker is absent pos=64
AC EOB marker is absent pos=64
AC EOB marker is absent pos=106
AC EOB marker is absent pos=81
AC EOB marker is absent pos=64
AC EOB marker is absent pos=70
AC EOB marker is absent pos=64
AC EOB marker is absent pos=64
.
.
.
(0006220)
Granjow (developer)
2010-12-26 10:30

Does this problem still exist?
(0006235)
nadavkav (reporter)
2010-12-26 11:11

solved :-)
(0006236)
Granjow (developer)
2010-12-26 11:12

Okay, thank you :) Closing now.

- Issue History
Date Modified Username Field Change
2009-06-23 13:39 nadavkav New Issue
2009-06-23 13:39 nadavkav Build/Install Method => Manual build from SVN
2009-06-26 00:12 administrator Relationship added parent of 0000726
2009-06-26 00:14 administrator Note Added: 0003466
2009-06-26 00:14 administrator Status new => feedback
2009-06-27 22:21 nadavkav Note Added: 0003511
2010-12-26 10:29 Granjow Tag Attached: old
2010-12-26 10:30 Granjow Note Added: 0006220
2010-12-26 11:11 nadavkav Note Added: 0006235
2010-12-26 11:11 nadavkav Status feedback => new
2010-12-26 11:12 Granjow Note Added: 0006236
2010-12-26 11:12 Granjow Status new => resolved
2010-12-26 11:12 Granjow Resolution open => unable to reproduce
2010-12-26 11:12 Granjow Assigned To => Granjow
2011-04-27 23:55 ttill Status resolved => closed
2011-04-27 23:55 ttill Assigned To Granjow =>


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker