Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000993KdenliveUser Interfacepublic2009-07-02 22:072010-02-02 10:38
Reporternadavkav 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version0.7.5 
Target VersionFixed in Version0.7.6 
Summary0000993: dragging a clip onto the timeline crashes kdenlive
Descriptiondragging a clip onto the timeline crashes kdenlive
(any kind of video file)

i notice...
running the setup wizard, i am unable to detect the libavcodecs codecs !
i think it has some thing to do with that ?

here is the crash report:

Application: Kdenlive (kdenlive), signal SIGSEGV
0x00007f361dbb68e1 in nanosleep () from /lib/libc.so.6
Current language: auto; currently c
[Current thread is 1 (Thread 0x7f3621e4e750 (LWP 19706))]

Thread 4 (Thread 0x7f35ffbfe950 (LWP 19717)):
#0 0x00007f361dbdfb72 in select () from /lib/libc.so.6
#1 0x00007f361f5e2936 in QProcessManager::run (this=0x129af80) at io/qprocess_unix.cpp:305
0000002 0x00007f361f51b742 in QThreadPrivate::start (arg=0x129af80) at thread/qthread_unix.cpp:189
0000003 0x00007f361d6fffaa in start_thread (arg=<value optimized out>) at pthread_create.c:297
0000004 0x00007f361dbe631d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000005 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f36054db950 (LWP 19740)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1 0x00007f3611e98e5b in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007f361d6fffaa in start_thread (arg=<value optimized out>) at pthread_create.c:297
0000003 0x00007f361dbe631d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000004 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f35fd37e950 (LWP 19745)):
#0 pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:217
#1 0x00007f3621b6e9c3 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.1
0000002 0x00007f3621b6ec0d in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.1
0000003 0x00007f3611e9971c in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007f361d6fffaa in start_thread (arg=<value optimized out>) at pthread_create.c:297
0000005 0x00007f361dbe631d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000006 0x0000000000000000 in ?? ()
Current language: auto; currently asm

Thread 1 (Thread 0x7f3621e4e750 (LWP 19706)):
[KCrash Handler]
0000005 0x00007f3621b6530e in mlt_properties_get_data () from /usr/lib/libmlt.so.1
0000006 0x00007f362194db52 in Mlt::Tractor::count() () from /usr/lib/libmlt++.so.1
0000007 0x00000000004951be in Render::mltInsertClip (this=0x192f240, info=
    {startPos = {m_time = 6.9531783998456502e-310, static s_delta = 1.0000000000000001e-05}, endPos = {m_time = 6.9531783997998009e-310, static s_delta = 1.0000000000000001e-05}, cropStart = {m_time = 1.3095830489473416e-316, static s_delta = 1.0000000000000001e-05}, track = 21}, element={<QDomNode> = {impl = 0x7fff29f91540}, <No data fields>}, prod=0x1c41440)
    at /root/sources/kdenlive/src/renderer.cpp:1419
0000008 0x00000000004e7a38 in CustomTrackView::dropEvent (this=0x1b3b520, event=<value optimized out>) at /root/sources/kdenlive/src/customtrackview.cpp:1768
0000009 0x00007f361e839229 in QWidget::event (this=0x1b3b520, event=0x7fff29f91d00) at kernel/qwidget.cpp:7703
0000010 0x00007f361ebd583b in QFrame::event (this=0x1b3b520, e=0x7fff29f91d00) at widgets/qframe.cpp:559
0000011 0x00007f361edf838b in QGraphicsView::viewportEvent (this=0x1b3b520, event=0x7fff29f91d00) at graphicsview/qgraphicsview.cpp:2897
0000012 0x00007f361f603158 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1b5bb00, event=0x7fff29f91d00) at kernel/qcoreapplication.cpp:726
0000013 0x00007f361e7e84cc in QApplicationPrivate::notify_helper (this=0x1296980, receiver=0x1b5bb00, e=0x7fff29f91d00) at kernel/qapplication.cpp:4053
0000014 0x00007f361e7f0cc0 in QApplication::notify (this=<value optimized out>, receiver=0x1b5bb00, e=0x7fff29f91d00) at kernel/qapplication.cpp:4010
0000015 0x00007f36212d138b in KApplication::notify (this=0x7fff29f971e0, receiver=0x1b5bb00, event=0x7fff29f91d00) at ../../kdeui/kernel/kapplication.cpp:307
0000016 0x00007f361f603e4c in QCoreApplication::notifyInternal (this=0x7fff29f971e0, receiver=0x1b5bb00, event=0x7fff29f91d00) at kernel/qcoreapplication.cpp:610
0000017 0x00007f361e866a3b in QX11Data::xdndHandleDrop (this=<value optimized out>, xe=<value optimized out>, passive=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
0000018 0x00007f361e86b277 in QDragManager::drop (this=0x1c51f40) at kernel/qdnd_x11.cpp:1709
0000019 0x00007f361e86b40c in QDragManager::eventFilter (this=0x1c51f40, o=<value optimized out>, e=<value optimized out>) at kernel/qdnd_x11.cpp:1302
0000020 0x00007f361f60321c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x1296980, receiver=0x2501ee0, event=0x7fff29f92640) at kernel/qcoreapplication.cpp:707
0000021 0x00007f361e7e8466 in QApplicationPrivate::notify_helper (this=0x0, receiver=0x7f3621b7452b, e=0x0) at kernel/qapplication.cpp:4032
0000022 0x00007f361e7f0eda in QApplication::notify (this=<value optimized out>, receiver=0x2501ee0, e=0x7fff29f92640) at kernel/qapplication.cpp:3759
0000023 0x00007f36212d138b in KApplication::notify (this=0x7fff29f971e0, receiver=0x2501ee0, event=0x7fff29f92640) at ../../kdeui/kernel/kapplication.cpp:307
0000024 0x00007f361f603e4c in QCoreApplication::notifyInternal (this=0x7fff29f971e0, receiver=0x2501ee0, event=0x7fff29f92640) at kernel/qcoreapplication.cpp:610
0000025 0x00007f361e7f0128 in QApplicationPrivate::sendMouseEvent (receiver=0x2501ee0, event=0x7fff29f92640, alienWidget=0x0, nativeWidget=0x2501ee0, buttonDown=<value optimized out>, lastMouseReceiver=
    @0x7f361f252c30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
0000026 0x00007f361e85a009 in QETWidget::translateMouseEvent (this=0x2501ee0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4448
0000027 0x00007f361e858d4d in QApplication::x11ProcessEvent (this=0x7fff29f971e0, event=0x7fff29f94010) at kernel/qapplication_x11.cpp:3566
0000028 0x00007f361e8814d4 in x11EventSourceDispatch (s=0x129a680, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000029 0x00007f361a5cff7a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000030 0x00007f361a5d35f8 in ?? () from /usr/lib/libglib-2.0.so.0
0000031 0x00007f361a5d37bc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000032 0x00007f361f62d4bf in QEventDispatcherGlib::processEvents (this=0x1283400, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:324
0000033 0x00007f361e880c7f in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
0000034 0x00007f361f6026f2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 704201472}) at kernel/qeventloop.cpp:149
0000035 0x00007f361f602abd in QEventLoop::exec (this=0x24f8400, flags={i = 704201808}) at kernel/qeventloop.cpp:200
0000036 0x00007f361e86ac04 in QDragManager::drag (this=0x1c51f40, o=<value optimized out>) at kernel/qdnd_x11.cpp:1969
0000037 0x00007f361e7fafc8 in QDrag::exec (this=0x2306d60, supportedActions={i = 704201968}, defaultDropAction=Qt::IgnoreAction) at kernel/qdrag.cpp:282
0000038 0x00007f361e7fb073 in QDrag::exec (this=0x0, supportedActions=<value optimized out>) at kernel/qdrag.cpp:239
0000039 0x00000000004ae776 in ProjectListView::mouseMoveEvent (this=0x15ac4d0, event=<value optimized out>) at /root/sources/kdenlive/src/projectlistview.cpp:261
0000040 0x00007f361e8395e8 in QWidget::event (this=0x15ac4d0, event=0x7fff29f95450) at kernel/qwidget.cpp:7506
0000041 0x00007f361ebd583b in QFrame::event (this=0x15ac4d0, e=0x7fff29f95450) at widgets/qframe.cpp:559
0000042 0x00007f361ed0a96d in QAbstractItemView::viewportEvent (this=0x15ac4d0, event=0x7fff29f95450) at itemviews/qabstractitemview.cpp:1471
0000043 0x00007f361ed416f9 in QTreeView::viewportEvent (this=0x15ac4d0, event=0x7fff29f95450) at itemviews/qtreeview.cpp:1264
0000044 0x00007f361f603158 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1523b60, event=0x7fff29f95450) at kernel/qcoreapplication.cpp:726
0000045 0x00007f361e7e84cc in QApplicationPrivate::notify_helper (this=0x1296980, receiver=0x1523b60, e=0x7fff29f95450) at kernel/qapplication.cpp:4053
0000046 0x00007f361e7f0eda in QApplication::notify (this=<value optimized out>, receiver=0x1523b60, e=0x7fff29f95450) at kernel/qapplication.cpp:3759
0000047 0x00007f36212d138b in KApplication::notify (this=0x7fff29f971e0, receiver=0x1523b60, event=0x7fff29f95450) at ../../kdeui/kernel/kapplication.cpp:307
0000048 0x00007f361f603e4c in QCoreApplication::notifyInternal (this=0x7fff29f971e0, receiver=0x1523b60, event=0x7fff29f95450) at kernel/qcoreapplication.cpp:610
0000049 0x00007f361e7f0128 in QApplicationPrivate::sendMouseEvent (receiver=0x1523b60, event=0x7fff29f95450, alienWidget=0x1523b60, nativeWidget=0x1499510, buttonDown=<value optimized out>,
    lastMouseReceiver=@0x7f361f252c30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
0000050 0x00007f361e85a009 in QETWidget::translateMouseEvent (this=0x1499510, event=<value optimized out>) at kernel/qapplication_x11.cpp:4448
0000051 0x00007f361e858d4d in QApplication::x11ProcessEvent (this=0x7fff29f971e0, event=0x7fff29f96e20) at kernel/qapplication_x11.cpp:3566
0000052 0x00007f361e8814d4 in x11EventSourceDispatch (s=0x129a680, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000053 0x00007f361a5cff7a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000054 0x00007f361a5d35f8 in ?? () from /usr/lib/libglib-2.0.so.0
0000055 0x00007f361a5d37bc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000056 0x00007f361f62d4bf in QEventDispatcherGlib::processEvents (this=0x1283400, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:324
0000057 0x00007f361e880c7f in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#58 0x00007f361f6026f2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 704213264}) at kernel/qeventloop.cpp:149
0000059 0x00007f361f602abd in QEventLoop::exec (this=0x7fff29f97150, flags={i = 704213344}) at kernel/qeventloop.cpp:200
0000060 0x00007f361f604d84 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
0000061 0x0000000000441bd5 in main (argc=1, argv=0x7fff29f97738) at /root/sources/kdenlive/src/main.cpp:90
Current language: auto; currently c

Additional Informationwhile running kdenlive i get the following messages into console:
laptop:~/sources/kdenlive/build# kdenlive
link XMLID_45_ hasn't been detected!
link XMLID_41_ hasn't been detected!
link XMLID_39_ hasn't been detected!
link XMLID_37_ hasn't been detected!
link XMLID_35_ hasn't been detected!
link XMLID_33_ hasn't been detected!
link XMLID_30_ hasn't been detected!
link XMLID_28_ hasn't been detected!
link XMLID_26_ hasn't been detected!
link XMLID_24_ hasn't been detected!
link XMLID_21_ hasn't been detected!
link XMLID_19_ hasn't been detected!
link XMLID_17_ hasn't been detected!
link XMLID_15_ hasn't been detected!
link XMLID_13_ hasn't been detected!
link XMLID_11_ hasn't been detected!
link XMLID_9_ hasn't been detected!
link XMLID_7_ hasn't been detected!
link XMLID_5_ hasn't been detected!
link XMLID_3_ hasn't been detected!
KCrash: Application 'kdenlive' crashing...
sock_file=/root/.kde/socket-laptop/kdeinit4__0
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003585)
j-b-m (administrator)
2009-07-02 22:16

This is usually because you have one of the following issue:

* you have not installed the required FFmpeg libraries (unstripped versions of libavformat, libavcodec,...)
* you have several versions of MLT installed
* you have an old version of MLT

You should first try playing a video with MLT's command line player:
melt myvideo.mpg
(0003599)
nadavkav (reporter)
2009-07-04 13:13

i have deleted all mlt (from git sources and bin) and all the kdenlive packages (.deb) and the compiled from svn builds too.

cleaned every thing ! (i hope)

and installed mlt 0.4.4 and kdenlive 0.7.5 from debian's repos

now, i get the following crash on start:


Application: Kdenlive (kdenlive), signal SIGSEGV
0x00007f0044e338b0 in __nanosleep_nocancel () from /lib/libc.so.6
Current language: auto; currently c
[Current thread is 1 (Thread 0x7f00490ca750 (LWP 14292))]

Thread 1 (Thread 0x7f00490ca750 (LWP 14292)):
[KCrash Handler]
0000005 0x00007f0048de0aa0 in ?? () from /usr/lib/libmlt.so.1
0000006 0x00007f0048de25cc in mlt_properties_set_int () from /usr/lib/libmlt.so.1
0000007 0x0000000000482c8c in Render::buildConsumer (this=0x2e22120) at /tmp/buildd/kdenlive-0.7.5/src/renderer.cpp:137
0000008 0x000000000048429e in Render (this=0x2e22120, rendererName=<value optimized out>, winid=<value optimized out>, parent=<value optimized out>) at /tmp/buildd/kdenlive-0.7.5/src/renderer.cpp:88
0000009 0x000000000047b2d7 in Monitor (this=0x2e0d520, name=
    {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 14367}, alloc = 0, size = 0, data = 0x8a4e9a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, static shared_empty = {ref = {_q_value = 104}, alloc = 0, size = 0, data = 0x7f0046b76ada, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0x7fff51211280, static codecForCStrings = 0x0}, manager=<value optimized out>, parent=<value optimized out>) at /tmp/buildd/kdenlive-0.7.5/src/monitor.cpp:126
0000010 0x00000000004567bc in MainWindow (this=0x298dab0, MltPath=<value optimized out>, Url=@0x7fff512114e0, parent=<value optimized out>) at /tmp/buildd/kdenlive-0.7.5/src/mainwindow.cpp:183
0000011 0x00000000004419e9 in main (argc=1, argv=0x7fff512119c8) at /tmp/buildd/kdenlive-0.7.5/src/main.cpp:83
(0004029)
j-b-m (administrator)
2009-09-28 12:12

Can we close this issue or are you still stuck with that problem?
(0004030)
nadavkav (reporter)
2009-09-28 12:19

j-b-m, you were right with your suggestion. i had a mixed MLT versions installed.

now. all works fine.
please close.

10xs :-)

- Issue History
Date Modified Username Field Change
2009-07-02 22:07 nadavkav New Issue
2009-07-02 22:07 nadavkav Build/Install Method => Manual build from SVN
2009-07-02 22:16 j-b-m Note Added: 0003585
2009-07-02 22:16 j-b-m Status new => feedback
2009-07-04 13:13 nadavkav Note Added: 0003599
2009-09-28 12:12 j-b-m Note Added: 0004029
2009-09-28 12:19 nadavkav Note Added: 0004030
2009-09-28 12:23 j-b-m Status feedback => resolved
2009-09-28 12:23 j-b-m Resolution open => no change required
2009-09-28 12:23 j-b-m Assigned To => j-b-m
2009-10-08 20:21 j-b-m Fixed in Version => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker