Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000997KdenliveFile Loadingpublic2009-07-04 14:142011-06-10 10:49
Reportermcfrisk 
Assigned Tottill 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0000997: kdenlive really slow to open a big project
DescriptionMy project takes over 20 minutes to open. After opening kdenlive is responsive and works just fine, but opening the project takes too long to my taste. This is especially annoying since kdenlive does crash quite often. I have disabled audio and video thumbnails, though I'd like to see an option to enable or disable the thumbnails on clip basis on the timeline. For example the main audio track thumbnail would be nice.

My project has quite a number of clips:

$ grep -i kdenlive_producer kooste_38.kdenlive | grep -i \.JPG | wc -l
421
$ grep -i kdenlive_producer kooste_38.kdenlive | grep -i \.mov | wc -l
194

During slow startup, I can see with strace that kdenlive likes to stat64 all clips and then starts opening and reading them one by one. The stat'ing seems slow, since kdenlive only manages to stat about 1-3 files per second:

$ strace -t -p 20201
Process 20201 attached - interrupt to quit
13:05:09 stat64("/home/mcfrisk/video/2009/niseko_2009/mikko/20090127/p1000905_1.jpg", {st_mode=S_IFREG|0644, st_size=128657, ...}) = 0
13:05:11 stat64("/home/mcfrisk/video/2009/niseko_2009/mikko/20090127/p1000918_1.jpg", {st_mode=S_IFREG|0644, st_size=654155, ...}) = 0
13:05:11 brk(0xb27a000) = 0xb27a000
13:05:13 stat64("/home/mcfrisk/video/2009/niseko_2009/mikko/20090127/p1000928_1.jpg", {st_mode=S_IFREG|0644, st_size=943151, ...}) = 0
13:05:13 stat64("/home/mcfrisk/video/2009/niseko_2009/mikko/20090128/p1000943.jpg", {st_mode=S_IFREG|0755, st_size=857575, ...}) = 0
13:05:14 stat64("/home/mcfrisk/video/2009/niseko_2009/mikko/20090128/p1000944.jpg", {st_mode=S_IFREG|0755, st_size=1146659, ...}) = 0
13:05:16 stat64("/home/mcfrisk/video/2009/niseko_2009/mikko/20090128/p1000949.jpg", {st_mode=S_IFREG|0755, st_size=567242, ...}) = 0
13:05:16 brk(0xb29b000) = 0xb29b000
13:05:18 stat64("/home/mcfrisk/video/2009/niseko_2009/mikko/20090128/p1000964.jpg", {st_mode=S_IFREG|0755, st_size=474969, ...}) = 0
13:05:20 stat64("/home/mcfrisk/video/2009/niseko_2009/mikko/20090128/p1000965.jpg", {st_mode=S_IFREG|0755, st_size=501262, ...}) = 0
13:05:23 stat64("/home/mcfrisk/video/2009/niseko_2009/mikko/20090128/p1000966.jpg", {st_mode=S_IFREG|0755, st_size=526569, ...}) = 0

While stat'ing, kdenlive is also using 90% of cputime doing something, which appears to not be that usefull. Perhaps the statting could be moved to the same point when the file is actually opened, mmapped and read. That would take maybe 5 minutes of my project opening time.

Since opening the project is already darn slow, I'm not eager to try with a profiling build or valgrind run, not yet anyway.

For reference, my editing host runs 32bit Debian unstable on AMD Athlon(tm) 64 Processor 3000+, gigabyte of memory, IDE disks combined with LVM and filesystem ext3, and an nVidia Corporation G86 [GeForce 8400 GS] graphics card with the proprietary drivers (in hope of real-time playing of 1028i clips).
TagsNo tags attached.
Build/Install Method(select)
Attached Filestxt file icon kdenlive_slow_start_log2.txt [^] (286,060 bytes) 2009-07-06 21:58

- Relationships
duplicate of 0001529closedttill Projekt load time 
related to 0000693closedttill kdenlive startup should have some sort of notification to user that it is loading project 

-  Notes
(0003606)
mcfrisk (reporter)
2009-07-06 21:56

ltrace trace of slow kdenlive startup.
(0006055)
ttill (developer)
2010-11-14 22:15
edited on: 2010-11-14 22:17

May I close?
Report 0001529 has more responses ...

(0006063)
mcfrisk (reporter)
2010-11-14 23:23

Sure, you can close this one.

- Issue History
Date Modified Username Field Change
2009-07-04 14:14 mcfrisk New Issue
2009-07-04 14:14 mcfrisk Build/Install Method => (select)
2009-07-06 21:56 mcfrisk Note Added: 0003606
2009-07-06 21:58 mcfrisk File Added: kdenlive_slow_start_log2.txt
2010-11-14 22:14 ttill Relationship added related to 0000693
2010-11-14 22:15 ttill Relationship added duplicate of 0001529
2010-11-14 22:15 ttill Note Added: 0006055
2010-11-14 22:15 ttill Assigned To => ttill
2010-11-14 22:15 ttill Status new => feedback
2010-11-14 22:16 ttill Note Edited: 0006055 View Revisions
2010-11-14 22:16 ttill Note Edited: 0006055 View Revisions
2010-11-14 22:17 ttill Note Edited: 0006055 View Revisions
2010-11-14 23:23 mcfrisk Note Added: 0006063
2010-11-14 23:23 mcfrisk Status feedback => assigned
2010-11-15 13:21 ttill Status assigned => resolved
2010-11-15 13:21 ttill Resolution open => duplicate
2010-11-15 13:21 ttill Fixed in Version => Recent git
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:49 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker